aboutsummaryrefslogtreecommitdiff
path: root/math/kbruch
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-10-17 00:03:42 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-10-17 00:03:42 +0000
commita2d3b5a4bc5047210b788a128596ec34749ffa11 (patch)
treec3c20b47c3435ddcaf02b8570db6aab5b70011af /math/kbruch
parentda6ade2349d0bdc372133d4d97bc6988aee94238 (diff)
downloadports-a2d3b5a4bc5047210b788a128596ec34749ffa11.tar.gz
ports-a2d3b5a4bc5047210b788a128596ec34749ffa11.zip
Notes
Diffstat (limited to 'math/kbruch')
-rw-r--r--math/kbruch/Makefile29
-rw-r--r--math/kbruch/distinfo2
-rw-r--r--math/kbruch/pkg-descr19
-rw-r--r--math/kbruch/pkg-plist45
4 files changed, 95 insertions, 0 deletions
diff --git a/math/kbruch/Makefile b/math/kbruch/Makefile
new file mode 100644
index 000000000000..e63d2e98610d
--- /dev/null
+++ b/math/kbruch/Makefile
@@ -0,0 +1,29 @@
+# New ports collection Makefile for: kbruch
+# Date created: 6 September 2011
+# Whom: Alberto Villa <avilla@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kbruch
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= math kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE 4 application to exercise fractions
+
+CONFLICTS= kdeedu-4.[0-6].*
+
+USE_KDE4= kdehier kdelibs kdeprefix automoc4
+KDE4_BUILDENV= yes
+USE_QT_VER= 4
+QT_COMPONENTS= corelib moc_build qmake_build rcc_build uic_build
+USE_BZIP2= yes
+MAKE_JOBS_SAFE= yes
+
+MAN1= kbruch.1
+
+.include <bsd.port.mk>
diff --git a/math/kbruch/distinfo b/math/kbruch/distinfo
new file mode 100644
index 000000000000..73a2bf1b5d67
--- /dev/null
+++ b/math/kbruch/distinfo
@@ -0,0 +1,2 @@
+SHA256 (KDE/kbruch-4.7.2.tar.bz2) = 5213ced8e41d8aa7c5e657fd434eb1f6fe8eecf57020ba0f785df3e53d6fac43
+SIZE (KDE/kbruch-4.7.2.tar.bz2) = 964368
diff --git a/math/kbruch/pkg-descr b/math/kbruch/pkg-descr
new file mode 100644
index 000000000000..bf56d5f78b0a
--- /dev/null
+++ b/math/kbruch/pkg-descr
@@ -0,0 +1,19 @@
+KBruch is a small program to practice calculating with fractions and
+percentages. Different exercises are provided for this purpose and you
+can use the learning mode to practice with fractions. The program
+checks the user's input and gives feedback.
+
+FEATURES
+- Arithmetic excercise: in this exercise you have to solve a given
+ fraction task. You have to enter the numerator and the denominator.
+ This is the main exercise.
+- Comparison excercise: in this exercise you have to compare the size
+ of two given fractions, using the symbols >, < or =.
+- Conversion excercise: in this exercise you have to convert a given
+ number into a fraction.
+- Factorization excercise: in this exercise you have to factorize a
+ given number into its prime factors.
+- Percentage excercise: in this exercise you have to calculate
+ percentages.
+
+WWW: http://www.kde.org/applications/education/kbruch
diff --git a/math/kbruch/pkg-plist b/math/kbruch/pkg-plist
new file mode 100644
index 000000000000..a42142b76500
--- /dev/null
+++ b/math/kbruch/pkg-plist
@@ -0,0 +1,45 @@
+bin/kbruch
+share/applications/kde4/kbruch.desktop
+share/apps/kbruch/AppMenuWidgetui.rc
+share/apps/kbruch/FractionRingWidgetui.rc
+share/apps/kbruch/kbruchui.rc
+share/apps/kbruch/pics/exercise_arithmetics.png
+share/apps/kbruch/pics/exercise_compare.png
+share/apps/kbruch/pics/exercise_conversion.png
+share/apps/kbruch/pics/exercise_factorization.png
+share/apps/kbruch/pics/exercise_mixed.png
+share/apps/kbruch/pics/exercise_percentage.png
+share/apps/kbruch/pics/icon_back_arrow.png
+share/apps/kbruch/pics/icon_freestyle.png
+share/apps/kbruch/pics/icon_freestyle_1.png
+share/apps/kbruch/pics/icon_learning.png
+share/apps/kbruch/pics/icon_learning_1.png
+share/apps/kbruch/pics/icon_test_case.png
+share/apps/kbruch/pics/icon_test_case_1.png
+share/config.kcfg/kbruch.kcfg
+share/doc/HTML/en/kbruch/checked.png
+share/doc/HTML/en/kbruch/common
+share/doc/HTML/en/kbruch/compare.png
+share/doc/HTML/en/kbruch/convert.png
+share/doc/HTML/en/kbruch/factorize.png
+share/doc/HTML/en/kbruch/gui_main.png
+share/doc/HTML/en/kbruch/gui_mode.png
+share/doc/HTML/en/kbruch/index.cache.bz2
+share/doc/HTML/en/kbruch/index.docbook
+share/doc/HTML/en/kbruch/learning.png
+share/doc/HTML/en/kbruch/man-kbruch.1.docbook
+share/doc/HTML/en/kbruch/mixed.png
+share/doc/HTML/en/kbruch/percentage.png
+share/doc/HTML/en/kbruch/reduced.png
+share/doc/HTML/en/kbruch/settings.png
+share/doc/HTML/en/kbruch/statistics.png
+share/icons/hicolor/128x128/apps/kbruch.png
+share/icons/hicolor/16x16/apps/kbruch.png
+share/icons/hicolor/22x22/apps/kbruch.png
+share/icons/hicolor/32x32/apps/kbruch.png
+share/icons/hicolor/48x48/apps/kbruch.png
+share/icons/hicolor/64x64/apps/kbruch.png
+share/icons/hicolor/scalable/apps/kbruch.svgz
+@dirrm share/doc/HTML/en/kbruch
+@dirrm share/apps/kbruch/pics
+@dirrm share/apps/kbruch