aboutsummaryrefslogtreecommitdiff
path: root/math/kcalc/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2009-05-09 19:38:16 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2009-05-09 19:38:16 +0000
commitc4efb99db9a863fc5634862ec14c82f8eeeae58f (patch)
tree93caf9fe09ed5fca76b36388a4fe15de2b67e9e3 /math/kcalc/Makefile
parentb1df87c2ed3148118da4eb634135e84b097a5983 (diff)
downloadports-c4efb99db9a863fc5634862ec14c82f8eeeae58f.tar.gz
ports-c4efb99db9a863fc5634862ec14c82f8eeeae58f.zip
Notes
Diffstat (limited to 'math/kcalc/Makefile')
-rw-r--r--math/kcalc/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/math/kcalc/Makefile b/math/kcalc/Makefile
index d1ab65405c28..bd21ac898aaf 100644
--- a/math/kcalc/Makefile
+++ b/math/kcalc/Makefile
@@ -14,16 +14,16 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Utilities for the KDE4 integrated X11 Desktop
-LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
zip.1:${PORTSDIR}/archivers/libzip \
qimageblitz.4:${PORTSDIR}/x11/qimageblitz
-RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
+RUN_DEPENDS= gpg2:${PORTSDIR}/security/gnupg
LATEST_LINK= ${PORTNAME}4
USE_BZIP2= yes
USE_QT_VER= 4
-KDE4_BUILDENV= yes
+KDE4_BUILDENV= yes
USE_KDE4= kdelibs pimlibs kdeprefix kdehier automoc4
QT_COMPONENTS= network gui porting xml \
qmake_build moc_build rcc_build uic_build
@@ -34,4 +34,9 @@ MAN1= ark.1
post-extract:
${MKDIR} ${WRKSRC}
+post-patch:
+#disable printer-applet, it comes with print/kdeutils4-printer-applet
+ ${REINPLACE_CMD} -e '/add_subdirectory.*printer-applet/d' \
+ ${WRKSRC}/../CMakeLists.txt
+
.include <bsd.port.mk>