aboutsummaryrefslogtreecommitdiff
path: root/math/lapack
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2012-03-12 07:47:17 +0000
committerMaho Nakata <maho@FreeBSD.org>2012-03-12 07:47:17 +0000
commitb87d6590d3c2a53d785e026fcebc9ef5ece41f00 (patch)
treeb2863d12d9cd05bf8fef1f02eb682d5d77122c53 /math/lapack
parent3d6a97a9a86554d48ba052748b4607d2a83a3b69 (diff)
downloadports-b87d6590d3c2a53d785e026fcebc9ef5ece41f00.tar.gz
ports-b87d6590d3c2a53d785e026fcebc9ef5ece41f00.zip
Notes
Diffstat (limited to 'math/lapack')
-rw-r--r--math/lapack/Makefile2
-rw-r--r--math/lapack/files/patch-r120711
2 files changed, 12 insertions, 1 deletions
diff --git a/math/lapack/Makefile b/math/lapack/Makefile
index 1234365f8269..c3b9bcb190e9 100644
--- a/math/lapack/Makefile
+++ b/math/lapack/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= lapack
PORTVERSION= 3.4.0
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= math
MASTER_SITES= NL/lapack/ \
http://service-spi.web.cern.ch/service-spi/external/tarFiles/
diff --git a/math/lapack/files/patch-r1207 b/math/lapack/files/patch-r1207
new file mode 100644
index 000000000000..549b6caf9eb1
--- /dev/null
+++ b/math/lapack/files/patch-r1207
@@ -0,0 +1,11 @@
+--- SRC/dgesvd.f 2011-11-12 04:34:11.000000000 +0900
++++ SRC/dgesvd.f 2012-03-12 16:38:41.000000000 +0900
+@@ -477,7 +477,7 @@
+ CALL DGELQF( M, N, A, LDA, DUM(1), DUM(1), -1, IERR )
+ LWORK_DGELQF=DUM(1)
+ * Compute space needed for DORGLQ
+- CALL DORGLQ( N, N, M, VT, LDVT, DUM(1), DUM(1), -1, IERR )
++ CALL DORGLQ( N, N, M, DUM(1), N, DUM(1), DUM(1), -1, IERR )
+ LWORK_DORGLQ_N=DUM(1)
+ CALL DORGLQ( M, N, M, A, LDA, DUM(1), DUM(1), -1, IERR )
+ LWORK_DORGLQ_M=DUM(1)