aboutsummaryrefslogtreecommitdiff
path: root/math/libmath++
diff options
context:
space:
mode:
authorJohn Baldwin <jhb@FreeBSD.org>2004-03-10 16:38:25 +0000
committerJohn Baldwin <jhb@FreeBSD.org>2004-03-10 16:38:25 +0000
commitb94d25458360defb8c2bec6c1b17f10853d99dde (patch)
treeafb1751c87cae87d6bc2adefbe80e0b83a0ddb97 /math/libmath++
parent9c0586294fea292acc9415e26e02c8e02a26ba3a (diff)
downloadports-b94d25458360defb8c2bec6c1b17f10853d99dde.tar.gz
ports-b94d25458360defb8c2bec6c1b17f10853d99dde.zip
Notes
Diffstat (limited to 'math/libmath++')
-rw-r--r--math/libmath++/Makefile20
-rw-r--r--math/libmath++/distinfo2
-rw-r--r--math/libmath++/files/patch-ltmain.sh35
-rw-r--r--math/libmath++/pkg-descr4
-rw-r--r--math/libmath++/pkg-plist26
5 files changed, 87 insertions, 0 deletions
diff --git a/math/libmath++/Makefile b/math/libmath++/Makefile
new file mode 100644
index 000000000000..ab2b3f38358c
--- /dev/null
+++ b/math/libmath++/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: libmath++
+# Date created: 14 February 2004
+# Whom: John Baldwin <jhb@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libmath++
+PORTVERSION= 0.0.3
+CATEGORIES= math devel
+MASTER_SITES= http://www.surakware.net/pub/unstable/releases/libmath++/
+
+MAINTAINER= jhb@FreeBSD.org
+COMMENT= C++ Library for Symbolic and Numeric Calculus Applications
+
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/math/libmath++/distinfo b/math/libmath++/distinfo
new file mode 100644
index 000000000000..7de61ac8c076
--- /dev/null
+++ b/math/libmath++/distinfo
@@ -0,0 +1,2 @@
+MD5 (libmath++-0.0.3.tar.gz) = f7d1bd1059b9620e5e9c8e2204430d3c
+SIZE (libmath++-0.0.3.tar.gz) = 216730
diff --git a/math/libmath++/files/patch-ltmain.sh b/math/libmath++/files/patch-ltmain.sh
new file mode 100644
index 000000000000..eab2bee2e8eb
--- /dev/null
+++ b/math/libmath++/files/patch-ltmain.sh
@@ -0,0 +1,35 @@
+$FreeBSD: /tmp/pcvs/ports/math/libmath++/files/patch-ltmain.sh,v 1.1 2004-03-10 16:38:25 jhb Exp $
+
+--- ltmain.sh.orig Thu Nov 22 05:43:58 2001
++++ ltmain.sh Fri Dec 7 07:18:03 2001
+@@ -944,6 +944,7 @@
+ ;;
+
+ -avoid-version)
++ build_old_libs=no
+ avoid_version=yes
+ continue
+ ;;
+@@ -2408,6 +2409,9 @@
+ *-*-netbsd*)
+ # Don't link with libc until the a.out ld.so is fixed.
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ # Add libc to deplibs on all other systems if necessary.
+ if test $build_libtool_need_lc = "yes"; then
+@@ -4175,10 +4179,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false ; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/math/libmath++/pkg-descr b/math/libmath++/pkg-descr
new file mode 100644
index 000000000000..0d288b5c306b
--- /dev/null
+++ b/math/libmath++/pkg-descr
@@ -0,0 +1,4 @@
+libmath++ is a template based math library, written in C++, for symbolic
+and numeric calculus applications.
+
+WWW: http://www.surakware.net/projects/libmath++/index.xml
diff --git a/math/libmath++/pkg-plist b/math/libmath++/pkg-plist
new file mode 100644
index 000000000000..813a22c7d6b4
--- /dev/null
+++ b/math/libmath++/pkg-plist
@@ -0,0 +1,26 @@
+include/math++/nodes.h
+include/math++/nodes.tcc
+include/math++/reader.h
+include/math++/reader.tcc
+include/math++/printer.h
+include/math++/printer.tcc
+include/math++/calculator.h
+include/math++/calculator.tcc
+include/math++/derive.h
+include/math++/derive.tcc
+include/math++/simplifier.h
+include/math++/simplifier.tcc
+include/math++/expander.h
+include/math++/expander.tcc
+include/math++/library.h
+include/math++/library.tcc
+include/math++/matcher.h
+include/math++/matcher.tcc
+include/math++/utils.h
+include/math++/utils.tcc
+include/math++/visitor.h
+include/math++/error.h
+lib/libmath++.so.0
+lib/libmath++.so
+lib/libmath++.a
+@dirrm include/math++