aboutsummaryrefslogtreecommitdiff
path: root/math/libmath++
diff options
context:
space:
mode:
authorJohn Baldwin <jhb@FreeBSD.org>2013-09-05 19:38:09 +0000
committerJohn Baldwin <jhb@FreeBSD.org>2013-09-05 19:38:09 +0000
commita940839726143eed646a264f0c1a9576720614ba (patch)
treeddaa9521b0d47a7c36f4fcc0473bb5761f8356f3 /math/libmath++
parentfb3d643ef97c3cf2051e6933119825579d8605a0 (diff)
downloadports-a940839726143eed646a264f0c1a9576720614ba.tar.gz
ports-a940839726143eed646a264f0c1a9576720614ba.zip
Notes
Diffstat (limited to 'math/libmath++')
-rw-r--r--math/libmath++/Makefile22
-rw-r--r--math/libmath++/distinfo2
-rw-r--r--math/libmath++/files/patch-ltmain.sh35
-rw-r--r--math/libmath++/files/patch-math-matcher.tcc44
-rw-r--r--math/libmath++/files/patch-math-nodes.h11
-rw-r--r--math/libmath++/files/patch-math-nodes.tcc379
-rw-r--r--math/libmath++/pkg-descr2
-rw-r--r--math/libmath++/pkg-plist27
8 files changed, 0 insertions, 522 deletions
diff --git a/math/libmath++/Makefile b/math/libmath++/Makefile
deleted file mode 100644
index 1a2291945d42..000000000000
--- a/math/libmath++/Makefile
+++ /dev/null
@@ -1,22 +0,0 @@
-# New ports collection makefile for: libmath++
-# Date created: 14 February 2004
-# Whom: John Baldwin <jhb@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= libmath++
-PORTVERSION= 0.0.3
-CATEGORIES= math devel
-MASTER_SITES= http://www.robertjohnkaper.com/downloads/atlantik/
-
-MAINTAINER= jhb@FreeBSD.org
-COMMENT= C++ Library for Symbolic and Numeric Calculus Applications
-
-USE_AUTOTOOLS= libtool
-USE_GMAKE= yes
-USE_AUTOTOOLS= libtool
-GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
-
-.include <bsd.port.mk>
diff --git a/math/libmath++/distinfo b/math/libmath++/distinfo
deleted file mode 100644
index 0f97b87429c3..000000000000
--- a/math/libmath++/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (libmath++-0.0.3.tar.gz) = b5681aa29c5e33c9d3d5b8bbf08cef30f48a018fd5e6d7f988d63dd0a68ae8eb
-SIZE (libmath++-0.0.3.tar.gz) = 218240
diff --git a/math/libmath++/files/patch-ltmain.sh b/math/libmath++/files/patch-ltmain.sh
deleted file mode 100644
index eab2bee2e8eb..000000000000
--- a/math/libmath++/files/patch-ltmain.sh
+++ /dev/null
@@ -1,35 +0,0 @@
-$FreeBSD: /tmp/pcvs/ports/math/libmath++/files/patch-ltmain.sh,v 1.1 2004-03-10 16:38:25 jhb Exp $
-
---- ltmain.sh.orig Thu Nov 22 05:43:58 2001
-+++ ltmain.sh Fri Dec 7 07:18:03 2001
-@@ -944,6 +944,7 @@
- ;;
-
- -avoid-version)
-+ build_old_libs=no
- avoid_version=yes
- continue
- ;;
-@@ -2408,6 +2409,9 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test $build_libtool_need_lc = "yes"; then
-@@ -4175,10 +4179,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false ; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/math/libmath++/files/patch-math-matcher.tcc b/math/libmath++/files/patch-math-matcher.tcc
deleted file mode 100644
index eca72518a8a3..000000000000
--- a/math/libmath++/files/patch-math-matcher.tcc
+++ /dev/null
@@ -1,44 +0,0 @@
---- math++/matcher.tcc.orig Fri Aug 13 13:11:35 2004
-+++ math++/matcher.tcc Fri Aug 13 13:15:44 2004
-@@ -35,12 +35,12 @@
-
- template<class T>
- TMatchRegistry<T>::TMatchRegistry() {
--};
-+}
-
- template<class T>
- TMatchRegistry<T>::TMatchRegistry(const TMatchRegistry<T>& AProto) :
- FAnyMap(AProto.FAnyMap), FNodeList(AProto.FNodeList) {
--};
-+}
-
- template<class T>
- void TMatchRegistry<T>::define(const std::string& AId, const TNode<T> *ANode) {
-@@ -158,7 +158,7 @@
- va_start(ap, ARight);
-
- while (TMatch<T> *p = va_arg(ap, TMatch<T> *))
-- FPatterns.push_back(p);
-+ this->FPatterns.push_back(p);
-
- va_end(ap);
- }
-@@ -166,7 +166,7 @@
- template<class T>
- bool TPlusMatch<T>::match(const TNode<T> *AExpr, TMatchRegistry<T> *AReg) const {
- // yet a primitive sequencial search
-- for (typename T2Match<T>::TList::const_iterator p = FPatterns.begin(); p != FPatterns.end(); ++p)
-+ for (typename T2Match<T>::TList::const_iterator p = this->FPatterns.begin(); p != this->FPatterns.end(); ++p)
- if (!TMatcher<T>::match(*p, AExpr, AReg))
- return false;
-
-@@ -182,7 +182,7 @@
- va_start(ap, ARight);
-
- while (TMatch<T> *p = va_arg(ap, TMatch<T> *))
-- FPatterns.push_back(p);
-+ this->FPatterns.push_back(p);
-
- va_end(ap);
- }
diff --git a/math/libmath++/files/patch-math-nodes.h b/math/libmath++/files/patch-math-nodes.h
deleted file mode 100644
index 638e6df4314b..000000000000
--- a/math/libmath++/files/patch-math-nodes.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- math++/nodes.h.orig Fri Aug 13 12:59:11 2004
-+++ math++/nodes.h Fri Aug 13 12:59:31 2004
-@@ -130,7 +130,7 @@
- TNode<T> *get() const { return FCurrent; }
-
- TNodeIterator<T>& operator++() { increment(); return *this; }
-- TNodeIterator<T>& operator--() { declrement(); return *this; }
-+ TNodeIterator<T>& operator--() { decrement(); return *this; }
- };
-
- template<typename T>
diff --git a/math/libmath++/files/patch-math-nodes.tcc b/math/libmath++/files/patch-math-nodes.tcc
deleted file mode 100644
index 51fa6df07e31..000000000000
--- a/math/libmath++/files/patch-math-nodes.tcc
+++ /dev/null
@@ -1,379 +0,0 @@
---- math++/nodes.tcc.orig Fri Aug 13 13:01:46 2004
-+++ math++/nodes.tcc Fri Aug 13 13:10:49 2004
-@@ -92,7 +92,7 @@
- // TNumberNode
- template<typename T>
- TNumberNode<T>::TNumberNode(const T& ANumber) :
-- TNode<T>(NUMBER_NODE, 0), FNumber(ANumber) {
-+ TNode<T>(TNode<T>::NUMBER_NODE, 0), FNumber(ANumber) {
- }
-
- template<typename T>
-@@ -112,14 +112,14 @@
-
- template<typename T>
- bool TNumberNode<T>::equals(const TNode<T> *ANode) const {
-- return this && ANode && ANode->nodeType() == NUMBER_NODE
-+ return this && ANode && ANode->nodeType() == TNode<T>::NUMBER_NODE
- && FNumber == static_cast<const TNumberNode<T> *>(ANode)->FNumber;
- }
-
- // TSymbolNode
- template<typename T>
- TSymbolNode<T>::TSymbolNode(const std::string& ASymbol) :
-- TNode<T>(SYMBOL_NODE, 0), FSymbol(ASymbol) {
-+ TNode<T>(TNode<T>::SYMBOL_NODE, 0), FSymbol(ASymbol) {
- }
-
- template<typename T>
-@@ -139,14 +139,14 @@
-
- template<typename T>
- bool TSymbolNode<T>::equals(const TNode<T> *ANode) const {
-- return this && ANode && ANode->nodeType() == SYMBOL_NODE
-+ return this && ANode && ANode->nodeType() == TNode<T>::SYMBOL_NODE
- && FSymbol == static_cast<const TSymbolNode<T> *>(ANode)->FSymbol;
- }
-
- // TParamNode
- template<typename T>
- TParamNode<T>::TParamNode() :
-- TNode<T>(PARAM_NODE, 0) {
-+ TNode<T>(TNode<T>::PARAM_NODE, 0) {
- }
-
- template<typename T>
-@@ -161,7 +161,7 @@
-
- template<typename T>
- bool TParamNode<T>::equals(const TNode<T> *ANode) const {
-- return this && ANode && ANode->nodeType() == PARAM_NODE;
-+ return this && ANode && ANode->nodeType() == TNode<T>::PARAM_NODE;
- }
-
- // TUnaryNodeOp
-@@ -186,7 +186,7 @@
- bool TUnaryNodeOp<T>::equals(const TNode<T> *ANode) const {
- // this method does not make use of the left() for performance reasons
-
-- return this && ANode && nodeType() == ANode->nodeType() &&
-+ return this && ANode && this->nodeType() == ANode->nodeType() &&
- FNode->equals(static_cast<const TUnaryNodeOp<T> *>(ANode)->FNode.get());
- }
-
-@@ -215,7 +215,7 @@
- // this method does not make use of the left() and right() methods
- // for performance reasons
-
-- return this && ANode && nodeType() == ANode->nodeType() &&
-+ return this && ANode && this->nodeType() == ANode->nodeType() &&
- FLeft->equals(static_cast<const TBinaryNodeOp<T> *>(ANode)->FLeft.get()) &&
- FRight->equals(static_cast<const TBinaryNodeOp<T> *>(ANode)->FRight.get());
- }
-@@ -223,7 +223,7 @@
- // TPlusNode
- template<typename T>
- TPlusNode<T>::TPlusNode(TNode<T> *ALeft, TNode<T> *ARight) :
-- TBinaryNodeOp<T>(PLUS_NODE, -5, ALeft, ARight) {
-+ TBinaryNodeOp<T>(TNode<T>::PLUS_NODE, -5, ALeft, ARight) {
- }
-
- template<typename T>
-@@ -233,13 +233,13 @@
-
- template<typename T>
- TPlusNode<T> *TPlusNode<T>::clone() const {
-- return new TPlusNode(left()->clone(), right()->clone());
-+ return new TPlusNode(this->left()->clone(), this->right()->clone());
- }
-
- // TNegNode
- template<typename T>
- TNegNode<T>::TNegNode(TNode<T> *ANode) :
-- TUnaryNodeOp<T>(NEG_NODE, -5, ANode) {
-+ TUnaryNodeOp<T>(TNode<T>::NEG_NODE, -5, ANode) {
- }
-
- template<typename T>
-@@ -249,13 +249,13 @@
-
- template<typename T>
- TNegNode<T> *TNegNode<T>::clone() const {
-- return new TNegNode(node()->clone());
-+ return new TNegNode(this->node()->clone());
- }
-
- // TMulNode
- template<typename T>
- TMulNode<T>::TMulNode(TNode<T> *ALeft, TNode<T> *ARight) :
-- TBinaryNodeOp<T>(MUL_NODE, -3, ALeft, ARight) {
-+ TBinaryNodeOp<T>(TNode<T>::MUL_NODE, -3, ALeft, ARight) {
- }
-
- template<typename T>
-@@ -265,13 +265,13 @@
-
- template<typename T>
- TMulNode<T> *TMulNode<T>::clone() const {
-- return new TMulNode(left()->clone(), right()->clone());
-+ return new TMulNode(this->left()->clone(), this->right()->clone());
- }
-
- // TDivNode
- template<typename T>
- TDivNode<T>::TDivNode(TNode<T> *ALeft, TNode<T> *ARight) :
-- TBinaryNodeOp<T>(DIV_NODE, -3, ALeft, ARight) {
-+ TBinaryNodeOp<T>(TNode<T>::DIV_NODE, -3, ALeft, ARight) {
- }
-
- template<typename T>
-@@ -281,13 +281,13 @@
-
- template<typename T>
- TDivNode<T> *TDivNode<T>::clone() const {
-- return new TDivNode(left()->clone(), right()->clone());
-+ return new TDivNode(this->left()->clone(), this->right()->clone());
- }
-
- // TPowNode
- template<typename T>
- TPowNode<T>::TPowNode(TNode<T> *ALeft, TNode<T> *ARight) :
-- TBinaryNodeOp<T>(POW_NODE, -1, ALeft, ARight) {
-+ TBinaryNodeOp<T>(TNode<T>::POW_NODE, -1, ALeft, ARight) {
- }
-
- template<typename T>
-@@ -297,13 +297,13 @@
-
- template<typename T>
- TPowNode<T> *TPowNode<T>::clone() const {
-- return new TPowNode<T>(left()->clone(), right()->clone());
-+ return new TPowNode<T>(this->left()->clone(), this->right()->clone());
- }
-
- // TSqrtNode
- template<typename T>
- TSqrtNode<T>::TSqrtNode(TNode<T> *ANode) :
-- TUnaryNodeOp<T>(SQRT_NODE, -1, ANode) {
-+ TUnaryNodeOp<T>(TNode<T>::SQRT_NODE, -1, ANode) {
- }
-
- template<typename T>
-@@ -313,13 +313,13 @@
-
- template<typename T>
- TSqrtNode<T> *TSqrtNode<T>::clone() const {
-- return new TSqrtNode(node()->clone());
-+ return new TSqrtNode(this->node()->clone());
- }
-
- // TSinNode
- template<typename T>
- TSinNode<T>::TSinNode(TNode<T> *ANode) :
-- TUnaryNodeOp<T>(SIN_NODE, -1, ANode) {
-+ TUnaryNodeOp<T>(TNode<T>::SIN_NODE, -1, ANode) {
- }
-
- template<typename T>
-@@ -329,13 +329,13 @@
-
- template<typename T>
- TSinNode<T> *TSinNode<T>::clone() const {
-- return new TSinNode(node()->clone());
-+ return new TSinNode(this->node()->clone());
- }
-
- // TCosNode
- template<typename T>
- TCosNode<T>::TCosNode(TNode<T> *ANode) :
-- TUnaryNodeOp<T>(COS_NODE, -1, ANode) {
-+ TUnaryNodeOp<T>(TNode<T>::COS_NODE, -1, ANode) {
- }
-
- template<typename T>
-@@ -345,13 +345,13 @@
-
- template<typename T>
- TCosNode<T> *TCosNode<T>::clone() const {
-- return new TCosNode(node()->clone());
-+ return new TCosNode(this->node()->clone());
- }
-
- // TTanNode
- template<typename T>
- TTanNode<T>::TTanNode(TNode<T> *ANode) :
-- TUnaryNodeOp<T>(TAN_NODE, -1, ANode) {
-+ TUnaryNodeOp<T>(TNode<T>::TAN_NODE, -1, ANode) {
- }
-
- template<typename T>
-@@ -361,7 +361,7 @@
-
- template<typename T>
- TTanNode<T> *TTanNode<T>::clone() const {
-- return new TTanNode(node()->clone());
-+ return new TTanNode(this->node()->clone());
- }
-
- // TCoTanNode
-@@ -373,7 +373,7 @@
- // TLnNode
- template<typename T>
- TLnNode<T>::TLnNode(TNode<T> *ANode) :
-- TUnaryNodeOp<T>(LN_NODE, -1, ANode) {
-+ TUnaryNodeOp<T>(TNode<T>::LN_NODE, -1, ANode) {
- }
-
- template<typename T>
-@@ -383,13 +383,13 @@
-
- template<typename T>
- TLnNode<T> *TLnNode<T>::clone() const {
-- return new TLnNode(node()->clone());
-+ return new TLnNode(this->node()->clone());
- }
-
- // TFuncNode
- template<typename T>
- TFuncNode<T>::TFuncNode(const std::string& AName, TNode<T> *AParam) :
-- TUnaryNodeOp<T>(FUNC_NODE, -1, AParam), FName(AName) {
-+ TUnaryNodeOp<T>(TNode<T>::FUNC_NODE, -1, AParam), FName(AName) {
- }
-
- template<typename T>
-@@ -404,13 +404,13 @@
-
- template<typename T>
- TFuncNode<T> *TFuncNode<T>::clone() const {
-- return new TFuncNode(FName, node()->clone());
-+ return new TFuncNode(FName, this->node()->clone());
- }
-
- // TIfNode
- template<typename T>
- TIfNode<T>::TIfNode(TNode<T> *ACondNode, TNode<T> *AThenNode, TNode<T> *AElseNode) :
-- TBinaryNodeOp<T>(IF_NODE, -1, AThenNode, AElseNode),
-+ TBinaryNodeOp<T>(TNode<T>::IF_NODE, -1, AThenNode, AElseNode),
- FCondition(ACondNode) {
- }
-
-@@ -421,12 +421,12 @@
-
- template<typename T>
- TNode<T> *TIfNode<T>::trueExpr() const {
-- return left();
-+ return this->left();
- }
-
- template<typename T>
- TNode<T> *TIfNode<T>::falseExpr() const {
-- return right();
-+ return this->right();
- }
-
- template<typename T>
-@@ -436,13 +436,13 @@
-
- template<typename T>
- TIfNode<T> *TIfNode<T>::clone() const {
-- return new TIfNode(FCondition->clone(), left()->clone(), right()->clone());
-+ return new TIfNode(FCondition->clone(), this->left()->clone(), this->right()->clone());
- }
-
- // TEquNode
- template<typename T>
- TEquNode<T>::TEquNode(TNode<T> *ALeft, TNode<T> *ARight) :
-- TBinaryNodeOp<T>(EQU_NODE, -10, ALeft, ARight) {
-+ TBinaryNodeOp<T>(TNode<T>::EQU_NODE, -10, ALeft, ARight) {
- }
-
- template<typename T>
-@@ -452,13 +452,13 @@
-
- template<typename T>
- TEquNode<T> *TEquNode<T>::clone() const {
-- return new TEquNode<T>(left()->clone(), right()->clone());
-+ return new TEquNode<T>(this->left()->clone(), this->right()->clone());
- }
-
- // TUnEquNode
- template<typename T>
- TUnEquNode<T>::TUnEquNode(TNode<T> *ALeft, TNode<T> *ARight) :
-- TBinaryNodeOp<T>(UNEQU_NODE, -10, ALeft, ARight) {
-+ TBinaryNodeOp<T>(TNode<T>::UNEQU_NODE, -10, ALeft, ARight) {
- }
-
- template<typename T>
-@@ -468,13 +468,13 @@
-
- template<typename T>
- TUnEquNode<T> *TUnEquNode<T>::clone() const {
-- return new TUnEquNode<T>(left()->clone(), right()->clone());
-+ return new TUnEquNode<T>(this->left()->clone(), this->right()->clone());
- }
-
- // TGreaterNode
- template<typename T>
- TGreaterNode<T>::TGreaterNode(TNode<T> *ALeft, TNode<T> *ARight) :
-- TBinaryNodeOp<T>(GREATER_NODE, -10, ALeft, ARight) {
-+ TBinaryNodeOp<T>(TNode<T>::GREATER_NODE, -10, ALeft, ARight) {
- }
-
- template<typename T>
-@@ -484,13 +484,13 @@
-
- template<typename T>
- TGreaterNode<T> *TGreaterNode<T>::clone() const {
-- return new TGreaterNode<T>(left()->clone(), right()->clone());
-+ return new TGreaterNode<T>(this->left()->clone(), this->right()->clone());
- }
-
- // TLessNode
- template<typename T>
- TLessNode<T>::TLessNode(TNode<T> *ALeft, TNode<T> *ARight) :
-- TBinaryNodeOp<T>(LESS_NODE, -10, ALeft, ARight) {
-+ TBinaryNodeOp<T>(TNode<T>::LESS_NODE, -10, ALeft, ARight) {
- }
-
- template<typename T>
-@@ -500,13 +500,13 @@
-
- template<typename T>
- TLessNode<T> *TLessNode<T>::clone() const {
-- return new TLessNode<T>(left()->clone(), right()->clone());
-+ return new TLessNode<T>(this->left()->clone(), this->right()->clone());
- }
-
- // TGreaterEquNode
- template<typename T>
- TGreaterEquNode<T>::TGreaterEquNode(TNode<T> *ALeft, TNode<T> *ARight) :
-- TBinaryNodeOp<T>(GREATER_EQU_NODE, -10, ALeft, ARight) {
-+ TBinaryNodeOp<T>(TNode<T>::GREATER_EQU_NODE, -10, ALeft, ARight) {
- }
-
- template<typename T>
-@@ -516,13 +516,13 @@
-
- template<typename T>
- TGreaterEquNode<T> *TGreaterEquNode<T>::clone() const {
-- return new TGreaterEquNode<T>(left()->clone(), right()->clone());
-+ return new TGreaterEquNode<T>(this->left()->clone(), this->right()->clone());
- }
-
- // TLessEquNode
- template<typename T>
- TLessEquNode<T>::TLessEquNode(TNode<T> *ALeft, TNode<T> *ARight) :
-- TBinaryNodeOp<T>(LESS_EQU_NODE, -10, ALeft, ARight) {
-+ TBinaryNodeOp<T>(TNode<T>::LESS_EQU_NODE, -10, ALeft, ARight) {
- }
-
- template<typename T>
-@@ -532,7 +532,7 @@
-
- template<typename T>
- TLessEquNode<T> *TLessEquNode<T>::clone() const {
-- return new TLessEquNode<T>(left()->clone(), right()->clone());
-+ return new TLessEquNode<T>(this->left()->clone(), this->right()->clone());
- }
-
- } // namespace math
diff --git a/math/libmath++/pkg-descr b/math/libmath++/pkg-descr
deleted file mode 100644
index 84cee217ca7d..000000000000
--- a/math/libmath++/pkg-descr
+++ /dev/null
@@ -1,2 +0,0 @@
-libmath++ is a template based math library, written in C++, for symbolic
-and numeric calculus applications.
diff --git a/math/libmath++/pkg-plist b/math/libmath++/pkg-plist
deleted file mode 100644
index fed091c87283..000000000000
--- a/math/libmath++/pkg-plist
+++ /dev/null
@@ -1,27 +0,0 @@
-include/math++/nodes.h
-include/math++/nodes.tcc
-include/math++/reader.h
-include/math++/reader.tcc
-include/math++/printer.h
-include/math++/printer.tcc
-include/math++/calculator.h
-include/math++/calculator.tcc
-include/math++/derive.h
-include/math++/derive.tcc
-include/math++/simplifier.h
-include/math++/simplifier.tcc
-include/math++/expander.h
-include/math++/expander.tcc
-include/math++/library.h
-include/math++/library.tcc
-include/math++/matcher.h
-include/math++/matcher.tcc
-include/math++/utils.h
-include/math++/utils.tcc
-include/math++/visitor.h
-include/math++/error.h
-lib/libmath++.so.0
-lib/libmath++.so
-lib/libmath++.la
-lib/libmath++.a
-@dirrm include/math++