aboutsummaryrefslogtreecommitdiff
path: root/math/libocas
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2012-02-07 12:41:05 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2012-02-07 12:41:05 +0000
commit7c88a36d53291b2002c5dd0ba1c4822c7585d40e (patch)
tree320227beedfb5fd8e50fdcb61270d93fb1a5702a /math/libocas
parentce58f7ccf2337320bf6144193535aa6c6e402f1c (diff)
downloadports-7c88a36d53291b2002c5dd0ba1c4822c7585d40e.tar.gz
ports-7c88a36d53291b2002c5dd0ba1c4822c7585d40e.zip
Notes
Diffstat (limited to 'math/libocas')
-rw-r--r--math/libocas/Makefile18
-rw-r--r--math/libocas/distinfo4
-rw-r--r--math/libocas/files/patch-linclass.c4
3 files changed, 13 insertions, 13 deletions
diff --git a/math/libocas/Makefile b/math/libocas/Makefile
index 188640196456..e1ab49c81716 100644
--- a/math/libocas/Makefile
+++ b/math/libocas/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libocas
-PORTVERSION= 0.94
+PORTVERSION= 0.95
CATEGORIES= math
MASTER_SITES= http://cmp.felk.cvut.cz/~xfrancv/ocas/ LOCAL/bf
DISTNAME= ${PORTNAME}_v${PORTVERSION:S/.//}
@@ -20,11 +20,11 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
USE_ZIP= yes
-ALL_TARGET= all linclass
-LIBS= -lm ${PTHREAD_LIBS}
-MAKE_ENV= MEXDETECTED=no
+ALL_TARGET= clean libocas.so.1 svmocas msvmocas linclassif
+CLIBS= -lm ${PTHREAD_LIBS}
+MAKE_ENV= CLIBS="${CLIBS}" MEXDETECTED=no
-PLIST_FILES= bin/linclass bin/msvmocas bin/svmocas lib/libocas.so \
+PLIST_FILES= bin/linclassif bin/msvmocas bin/svmocas lib/libocas.so \
lib/libocas.so.1
.include <bsd.port.pre.mk>
@@ -41,11 +41,11 @@ post-patch:
@${REINPLACE_CMD} \
-e '\|:=|d' \
-e 's|libocas\.so|&.1|' \
- -e '\|$$(CC) $$(CFLAGS) -o|{s|$$(CFLAGS)|& ${LDFLAGS}|;s|$$| ${LIBS}|;}' \
+ -e '\|$$(CC) $$(CFLAGS) -o|{s|$$(CFLAGS)|& ${LDFLAGS}|;}' \
${WRKSRC}/Makefile
do-install:
-.for p in linclass msvmocas svmocas
+.for p in linclassif msvmocas svmocas
@${INSTALL_PROGRAM} ${WRKSRC}/${p} ${PREFIX}/bin
.endfor
@${INSTALL_LIB} ${WRKSRC}/libocas.so.1 ${PREFIX}/lib
@@ -54,11 +54,11 @@ do-install:
check regression-test test: build
${WRKSRC}/msvmocas -c 10 -v 1 ${WRKSRC}/data/example4_train.light \
${WRKSRC}/data/msvmocas.model
- ${WRKSRC}/linclass -e -v 1 -o ${WRKSRC}/data/example4_test.pred \
+ ${WRKSRC}/linclassif -e -v 1 -o ${WRKSRC}/data/example4_test.pred \
${WRKSRC}/data/example4_test.light ${WRKSRC}/data/msvmocas.model
${WRKSRC}/svmocas -c 10 -b 1 -v 1 ${WRKSRC}/data/riply_trn.light \
${WRKSRC}/data/svmocas.model
- ${WRKSRC}/linclass -e -v 1 -o ${WRKSRC}/data/riply_tst.pred \
+ ${WRKSRC}/linclassif -e -v 1 -o ${WRKSRC}/data/riply_tst.pred \
${WRKSRC}/data/riply_tst.light ${WRKSRC}/data/svmocas.model
.include <bsd.port.post.mk>
diff --git a/math/libocas/distinfo b/math/libocas/distinfo
index 7f6c8cb2d367..a21029c9385e 100644
--- a/math/libocas/distinfo
+++ b/math/libocas/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libocas_v094.zip) = 159df397227682a0a268fb3e7869256756938496dd3be708ce4b184190e7f46d
-SIZE (libocas_v094.zip) = 3333733
+SHA256 (libocas_v095.zip) = 03219afa44489ed0fe5e17c4505b889f9a90741628dc5744291de7463e443564
+SIZE (libocas_v095.zip) = 6003649
diff --git a/math/libocas/files/patch-linclass.c b/math/libocas/files/patch-linclass.c
index 52399b846073..95417fe62ba6 100644
--- a/math/libocas/files/patch-linclass.c
+++ b/math/libocas/files/patch-linclass.c
@@ -1,5 +1,5 @@
---- linclass.c.orig 2010-05-05 08:55:55.000000000 -0400
-+++ linclass.c 2011-10-06 05:11:23.000000000 -0400
+--- linclassif.c.orig 2010-05-05 08:55:55.000000000 -0400
++++ linclassif.c 2011-10-06 05:11:23.000000000 -0400
@@ -62,7 +62,7 @@
uint32_t i, j;
int len;