aboutsummaryrefslogtreecommitdiff
path: root/math/libqalculate
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2014-06-19 02:04:01 +0000
committerJason E. Hale <jhale@FreeBSD.org>2014-06-19 02:04:01 +0000
commitecbdb907ad11ba43f6def98ded4fadc6a7cb0b2c (patch)
tree32355611b14ba69f5c40d02024df2cdc3c4519a3 /math/libqalculate
parent518cd87fa5a91331a0f5b9c2463359a501e9fc9a (diff)
downloadports-ecbdb907ad11ba43f6def98ded4fadc6a7cb0b2c.tar.gz
ports-ecbdb907ad11ba43f6def98ded4fadc6a7cb0b2c.zip
Notes
Diffstat (limited to 'math/libqalculate')
-rw-r--r--math/libqalculate/Makefile32
-rw-r--r--math/libqalculate/pkg-plist2
2 files changed, 16 insertions, 18 deletions
diff --git a/math/libqalculate/Makefile b/math/libqalculate/Makefile
index ad8e7036f605..1f2e14489d6c 100644
--- a/math/libqalculate/Makefile
+++ b/math/libqalculate/Makefile
@@ -7,36 +7,34 @@ PORTREVISION= 3
CATEGORIES= math
MASTER_SITES= SF/qalculate/${PORTNAME}/${PORTNAME}-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= jhale@FreeBSD.org
COMMENT= Multi-purpose desktop calculator (backend library)
-LIB_DEPENDS= cln:${PORTSDIR}/math/cln
+LIB_DEPENDS= libcln.so:${PORTSDIR}/math/cln
-USES= pkgconfig pathfix gmake
+USES= pkgconfig pathfix gmake libtool
USE_GNOME= glib20 intlhack libxml2
-USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
+NLS_USES= gettext
+NLS_CONFIGURE_ENV= GMSGFMT="${LOCALBASE}/bin/msgfmt"
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+.include <bsd.port.options.mk>
post-patch:
-.if ${PORT_OPTIONS:MNLS}
- @${REINPLACE_CMD} -e 's/^GMSGFMT = @GMSGFMT@/GMSGFMT = msgfmt/' ${WRKSRC}/po/Makefile.in.in
-.else
+.if !${PORT_OPTIONS:MNLS}
@${REINPLACE_CMD} -e '/^SUBDIRS =/s|po ||g' ${WRKSRC}/Makefile.in
.endif
@${REINPLACE_CMD} -e '/^SUBDIRS =/s|docs||g' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's/-pthread/${PTHREAD_LIBS}/g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's/-lpthread/${PTHREAD_LIBS}/g' ${WRKSRC}/libqalculate.pc.in
+ @${REINPLACE_CMD} -e 's/-lpthread/${PTHREAD_LIBS}/g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT} \
+ ${WRKSRC}/libqalculate.pc.in
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libqalculate.so*
.include <bsd.port.mk>
diff --git a/math/libqalculate/pkg-plist b/math/libqalculate/pkg-plist
index ef835700d466..67851440a2ec 100644
--- a/math/libqalculate/pkg-plist
+++ b/math/libqalculate/pkg-plist
@@ -13,9 +13,9 @@ include/libqalculate/includes.h
include/libqalculate/qalculate.h
include/libqalculate/util.h
lib/libqalculate.a
-lib/libqalculate.la
lib/libqalculate.so
lib/libqalculate.so.5
+lib/libqalculate.so.5.0.0
libdata/pkgconfig/libqalculate.pc
%%NLS%%share/locale/fr/LC_MESSAGES/libqalculate.mo
%%NLS%%share/locale/nl/LC_MESSAGES/libqalculate.mo