aboutsummaryrefslogtreecommitdiff
path: root/math/libtommath/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2016-03-09 07:46:56 +0000
committerWen Heping <wen@FreeBSD.org>2016-03-09 07:46:56 +0000
commit8c2f29747a851ccdd65730cf192fab1f7f7efcee (patch)
tree77f0e2d790072f18a435b704409b61f285ec37a4 /math/libtommath/Makefile
parent9923887cd7da43d47b3f0e6b54fcb7e6cb918d3f (diff)
downloadports-8c2f29747a851ccdd65730cf192fab1f7f7efcee.tar.gz
ports-8c2f29747a851ccdd65730cf192fab1f7f7efcee.zip
Notes
Diffstat (limited to 'math/libtommath/Makefile')
-rw-r--r--math/libtommath/Makefile17
1 files changed, 6 insertions, 11 deletions
diff --git a/math/libtommath/Makefile b/math/libtommath/Makefile
index 62fc3f9322ef..45b2b3a60523 100644
--- a/math/libtommath/Makefile
+++ b/math/libtommath/Makefile
@@ -1,17 +1,16 @@
# $FreeBSD$
PORTNAME= libtommath
-PORTVERSION= 0.42.0
-PORTREVISION= 2
+PORTVERSION= 1.0
CATEGORIES= math
-MASTER_SITES= http://libtom.net/files/
+MASTER_SITES= https://github.com/libtom/libtommath/releases/download/v${PORTVERSION}/
DISTNAME= ltm-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Comprehensive, modular, and portable mathematical routines
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USES= gmake tar:bzip2
+USES= gmake tar:xz
ALL_TARGET= default
CFLAGS+= -fPIC
PORTDOCS= *
@@ -24,14 +23,10 @@ OPTIONS_DEFINE= DOCS SHARED
SHARED_DESC= Build shared library
SHARED_USES= libtool:build
SHARED_USE= LDCONFIG=yes
-SHARED_PLIST_FILES= lib/libtommath.so lib/libtommath.so.0 lib/libtommath.so.0.0.41
+SHARED_PLIST_FILES= lib/libtommath.so lib/libtommath.so.1 lib/libtommath.so.1.0.0
SHARED_VARS= MAKEFILE=makefile.shared
SHARED_VARS_OFF= MAKEFILE=makefile
-post-patch:
- ${REINPLACE_CMD} -e 's|gcc|${CC}|g' ${WRKSRC}/makefile.shared
- ${REINPLACE_CMD} -e 's|DESTDIR=|DESTDIR?=| ; s|-g $$(GROUP) -o $$(USER)||' ${WRKSRC}/${MAKEFILE}
-
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/bn.pdf ${STAGEDIR}${DOCSDIR}
@@ -39,9 +34,9 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/tommath.pdf ${STAGEDIR}${DOCSDIR}
post-install-SHARED-on:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libtommath.so.0
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libtommath.so.1
-regression-test:
+do-test:
(cd ${WRKSRC}; \
${SETENV} ${MAKE_ENV} ${MAKE_CMD} -f ${MAKEFILE} mtest test; \
./mtest/mtest | ./test)