aboutsummaryrefslogtreecommitdiff
path: root/math/libtommath
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-04-18 13:27:18 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-04-18 13:27:18 +0000
commit210eca65bed07b49dee579ed3b8ac275f020623f (patch)
treed0fd5e4d22b49be91ef10e78c0bdb38440c41c1f /math/libtommath
parent3dec06a959724e2759377449d3f90b3e24ccc453 (diff)
downloadports-210eca65bed07b49dee579ed3b8ac275f020623f.tar.gz
ports-210eca65bed07b49dee579ed3b8ac275f020623f.zip
Notes
Diffstat (limited to 'math/libtommath')
-rw-r--r--math/libtommath/Makefile7
-rw-r--r--math/libtommath/files/patch-makefile17
2 files changed, 18 insertions, 6 deletions
diff --git a/math/libtommath/Makefile b/math/libtommath/Makefile
index 4116404b7aea..251705cf1c83 100644
--- a/math/libtommath/Makefile
+++ b/math/libtommath/Makefile
@@ -33,10 +33,8 @@ BUILD_DEPENDS= libtool:${PORTSDIR}/devel/libtool
USE_LDCONFIG= yes
PLIST_FILES+= lib/libtommath.la lib/libtommath.so.0 lib/libtommath.so
MAKEFILE= makefile.shared
-PLIST_SUB+= SHARED=""
.else
MAKEFILE= makefile
-PLIST_SUB+= SHARED="@comment "
.endif
.if ${PORT_OPTIONS:MDOCS}
@@ -47,4 +45,9 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/tommath.pdf ${DOCSDIR}/
.endif
+regression-test:
+ (cd ${WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} -f ${MAKEFILE} mtest test; \
+ ./mtest/mtest | ./test)
+
.include <bsd.port.mk>
diff --git a/math/libtommath/files/patch-makefile b/math/libtommath/files/patch-makefile
index 538ecb6a4585..8e262a3dadab 100644
--- a/math/libtommath/files/patch-makefile
+++ b/math/libtommath/files/patch-makefile
@@ -22,9 +22,9 @@
OBJECTS=bncore.o bn_mp_init.o bn_mp_clear.o bn_mp_exch.o bn_mp_grow.o bn_mp_shrink.o \
bn_mp_clamp.o bn_mp_zero.o bn_mp_set.o bn_mp_set_int.o bn_mp_init_size.o bn_mp_copy.o \
---- makefile.shared.bak 2010-07-30 12:05:21.219322050 +0200
-+++ makefile.shared 2010-07-30 12:07:19.588144344 +0200
-@@ -14,7 +14,7 @@
+--- makefile.shared.orig 2010-07-23 16:27:20.000000000 +0200
++++ makefile.shared 2013-04-18 15:26:25.000000000 +0200
+@@ -10,7 +10,7 @@
ifndef IGNORE_SPEED
#for speed
@@ -33,7 +33,7 @@
#for size
#CFLAGS += -Os
-@@ -53,9 +53,9 @@
+@@ -48,9 +48,9 @@
#INCPATH-The directory to install the header files for libtommath.
#DATAPATH-The directory to install the pdf docs.
DESTDIR=
@@ -46,3 +46,12 @@
OBJECTS=bncore.o bn_mp_init.o bn_mp_clear.o bn_mp_exch.o bn_mp_grow.o bn_mp_shrink.o \
bn_mp_clamp.o bn_mp_zero.o bn_mp_set.o bn_mp_set_int.o bn_mp_init_size.o bn_mp_copy.o \
+@@ -93,7 +93,7 @@
+
+ test: $(LIBNAME) demo/demo.o
+ gcc $(CFLAGS) -c demo/demo.c -o demo/demo.o
+- libtool --mode=link gcc -o test demo/demo.o $(LIBNAME_S)
++ libtool --mode=link gcc -o test demo/demo.o .libs/$(LIBNAME_S)
+
+ mtest: test
+ cd mtest ; gcc $(CFLAGS) mtest.c -o mtest