aboutsummaryrefslogtreecommitdiff
path: root/math/libtommath
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2017-09-15 11:27:05 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2017-09-15 11:27:05 +0000
commitbdb48613e9640ace2c6ccad67ee04267f56f11ba (patch)
treea2c26fb7db8e84b9417c38eacc2f6bcd8890e81e /math/libtommath
parent561801743120332fa87f17b2dce784758ff9f686 (diff)
downloadports-bdb48613e9640ace2c6ccad67ee04267f56f11ba.tar.gz
ports-bdb48613e9640ace2c6ccad67ee04267f56f11ba.zip
Notes
Diffstat (limited to 'math/libtommath')
-rw-r--r--math/libtommath/Makefile28
-rw-r--r--math/libtommath/distinfo5
-rw-r--r--math/libtommath/files/patch-makefile.include47
-rw-r--r--math/libtommath/files/patch-makefile__include.mk34
4 files changed, 55 insertions, 59 deletions
diff --git a/math/libtommath/Makefile b/math/libtommath/Makefile
index 45b2b3a60523..b517d24a4b1b 100644
--- a/math/libtommath/Makefile
+++ b/math/libtommath/Makefile
@@ -1,40 +1,48 @@
# $FreeBSD$
PORTNAME= libtommath
-PORTVERSION= 1.0
+PORTVERSION= 1.0.1
CATEGORIES= math
MASTER_SITES= https://github.com/libtom/libtommath/releases/download/v${PORTVERSION}/
DISTNAME= ltm-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gahr@FreeBSD.org
COMMENT= Comprehensive, modular, and portable mathematical routines
+LICENSE= PD WTFPL
+LICENSE_COMB= dual
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USES= gmake tar:xz
ALL_TARGET= default
CFLAGS+= -fPIC
PORTDOCS= *
-PLIST_FILES= include/tommath.h include/tommath_class.h \
- include/tommath_superclass.h lib/libtommath.a
+PLIST_FILES= include/tommath.h \
+ include/tommath_class.h \
+ include/tommath_superclass.h \
+ lib/libtommath.a \
+ libdata/pkgconfig/libtommath.pc
OPTIONS_DEFINE= DOCS SHARED
-SHARED_DESC= Build shared library
+SHARED_DESC= Build shared library
SHARED_USES= libtool:build
SHARED_USE= LDCONFIG=yes
-SHARED_PLIST_FILES= lib/libtommath.so lib/libtommath.so.1 lib/libtommath.so.1.0.0
+SHARED_PLIST_FILES= lib/libtommath.so \
+ lib/libtommath.so.${PORTVERSION:R:R} \
+ lib/libtommath.so.${PORTVERSION}
SHARED_VARS= MAKEFILE=makefile.shared
SHARED_VARS_OFF= MAKEFILE=makefile
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/bn.pdf ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/poster.pdf ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/tommath.pdf ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/bn.pdf ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/poster.pdf ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/tommath.pdf ${STAGEDIR}${DOCSDIR}
post-install-SHARED-on:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libtommath.so.1
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libtommath.so.${PORTVERSION}
do-test:
(cd ${WRKSRC}; \
diff --git a/math/libtommath/distinfo b/math/libtommath/distinfo
index e60c6709900c..7b79da457099 100644
--- a/math/libtommath/distinfo
+++ b/math/libtommath/distinfo
@@ -1,2 +1,3 @@
-SHA256 (ltm-1.0.tar.xz) = 993a7df9ee091fca430cdde3263df57d88ef62af8103903214da49fc51bbb56c
-SIZE (ltm-1.0.tar.xz) = 2191540
+TIMESTAMP = 1505472472
+SHA256 (ltm-1.0.1.tar.xz) = 47032fb39d698ce4cf9c9c462c198e6b08790ce8203ad1224086b9b978636c69
+SIZE (ltm-1.0.1.tar.xz) = 2210120
diff --git a/math/libtommath/files/patch-makefile.include b/math/libtommath/files/patch-makefile.include
deleted file mode 100644
index 9aa4bb7d7bf5..000000000000
--- a/math/libtommath/files/patch-makefile.include
+++ /dev/null
@@ -1,47 +0,0 @@
---- makefile.include.orig 2016-02-03 18:07:27 UTC
-+++ makefile.include
-@@ -14,15 +14,15 @@ ifndef PREFIX
- PREFIX=
- endif
-
--ifeq ($(CC),cc)
-- CC = $(PREFIX)gcc
--endif
--LD=$(PREFIX)ld
--AR=$(PREFIX)ar
--RANLIB=$(PREFIX)ranlib
-+#ifeq ($(CC),cc)
-+# CC = $(PREFIX)gcc
-+#endif
-+#LD=$(PREFIX)ld
-+AR=$(shell which ar)
-+RANLIB=$(shell which ranlib)
-
- ifndef MAKE
-- MAKE=make
-+ MAKE=$(shell which gmake)
- endif
-
- CFLAGS += -I./ -Wall -Wsign-compare -Wextra -Wshadow
-@@ -55,7 +55,7 @@ endif # COMPILE_SIZE
- endif # COMPILE_DEBUG
-
- # adjust coverage set
--ifneq ($(filter $(shell arch), i386 i686 x86_64 amd64 ia64),)
-+ifneq ($(filter $(shell /sbin/sysctl -b hw.machine_arch), i386 i686 x86_64 amd64 ia64),)
- COVERAGE = test_standalone timing
- COVERAGE_APP = ./test && ./ltmtest
- else
-@@ -71,9 +71,9 @@ test_standalone: CFLAGS+=-DLTM_DEMO_TEST
- #LIBPATH-The directory for libtommath to be installed to.
- #INCPATH-The directory to install the header files for libtommath.
- #DATAPATH-The directory to install the pdf docs.
--LIBPATH?=/usr/lib
--INCPATH?=/usr/include
--DATAPATH?=/usr/share/doc/libtommath/pdf
-+LIBPATH?=$(PREFIX)/lib
-+INCPATH?=$(PREFIX)/include
-+DATAPATH?=$(DOCSDIR)/pdf
-
- #make the code coverage of the library
- #
diff --git a/math/libtommath/files/patch-makefile__include.mk b/math/libtommath/files/patch-makefile__include.mk
new file mode 100644
index 000000000000..e8ac6d3375c3
--- /dev/null
+++ b/math/libtommath/files/patch-makefile__include.mk
@@ -0,0 +1,34 @@
+--- makefile_include.mk.orig 2017-08-29 20:27:36 UTC
++++ makefile_include.mk
+@@ -17,16 +17,16 @@ ifndef CROSS_COMPILE
+ CROSS_COMPILE=
+ endif
+
+-ifeq ($(CC),cc)
+- CC = $(CROSS_COMPILE)gcc
+-endif
++#ifeq ($(CC),cc)
++# CC = $(CROSS_COMPILE)gcc
++#endif
+ LD=$(CROSS_COMPILE)ld
+ AR=$(CROSS_COMPILE)ar
+ RANLIB=$(CROSS_COMPILE)ranlib
+
+-ifndef MAKE
+- MAKE=make
+-endif
++#ifndef MAKE
++# MAKE=make
++#endif
+
+ CFLAGS += -I./ -Wall -Wsign-compare -Wextra -Wshadow
+
+@@ -65,7 +65,7 @@ CFLAGS += -Wno-nullability-completeness
+ endif
+
+ # adjust coverage set
+-ifneq ($(filter $(shell arch), i386 i686 x86_64 amd64 ia64),)
++ifneq ($(filter $(shell /sbin/sysctl -b hw.machine_arch), i386 i686 x86_64 amd64 ia64),)
+ COVERAGE = test_standalone timing
+ COVERAGE_APP = ./test && ./ltmtest
+ else