aboutsummaryrefslogtreecommitdiff
path: root/math/linux-relview/Makefile
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2002-10-25 17:02:42 +0000
committerOliver Braun <obraun@FreeBSD.org>2002-10-25 17:02:42 +0000
commit3871c87a99c34961ecbadd8adbe2abd92aafb728 (patch)
tree3404a5966cce054a03d602382a8308cb72aa499e /math/linux-relview/Makefile
parent0e6938609be15d79327c64b5c843cb4814c81179 (diff)
Notes
Diffstat (limited to 'math/linux-relview/Makefile')
-rw-r--r--math/linux-relview/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/math/linux-relview/Makefile b/math/linux-relview/Makefile
new file mode 100644
index 000000000000..1c089a880e8c
--- /dev/null
+++ b/math/linux-relview/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: relview
+# Date created: October 24 2002
+# Whom: Michael Ebert <ebert@informatik.unibw-muenchen.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= relview
+PORTVERSION= 7.0.2
+CATEGORIES= math linux
+MASTER_SITES= ftp://ftp.informatik.uni-kiel.de/pub/kiel/relview/RELVIEW_7.0/LINUX/
+PKGNAMEPREFIX= linux-
+EXTRACT_SUFX= .gz
+
+MAINTAINER= ebert@informatik.unibw-muenchen.de
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux-gtk
+
+USE_LINUX= yes
+ONLY_FOR_ARCHS= i386
+
+NO_WRKSUBDIR= yes
+EXTRACT_AFTER_ARGS= > ${DISTNAME}
+
+NO_BUILD= yes
+
+PLIST_SUB= VERSION=${PORTVERSION}
+
+# Linux binary should not be stripped by INSTALL_PROGRAM
+# because as a side effect it brands the binary as FreeBSD.
+STRIP= # empty
+
+do-install:
+ brandelf -t Linux ${WRKDIR}/${DISTNAME}
+ ${INSTALL_PROGRAM} ${WRKDIR}/${DISTNAME} ${PREFIX}/bin
+ ${LN} -fhs ${PREFIX}/bin/${DISTNAME} ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>