aboutsummaryrefslogtreecommitdiff
path: root/math/lp_solve
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-07-24 08:03:40 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-07-24 08:03:40 +0000
commit625b28e732756c56ee7d0ac1bc56f5fb84cd4c55 (patch)
treee21c8fec6856d5f24ba82182936324f399f9f03d /math/lp_solve
parent58fbbba523a312a8ada696b41fec46668043f146 (diff)
Fix the fix.
PR: ports/148407 Submitted by: Mayo Jordanov (maintainer)
Notes
Notes: svn path=/head/; revision=258131
Diffstat (limited to 'math/lp_solve')
-rw-r--r--math/lp_solve/Makefile1
-rw-r--r--math/lp_solve/files/patch-shared+commonlib.c2
2 files changed, 2 insertions, 1 deletions
diff --git a/math/lp_solve/Makefile b/math/lp_solve/Makefile
index 6f069250b0a6..3666e858abfa 100644
--- a/math/lp_solve/Makefile
+++ b/math/lp_solve/Makefile
@@ -7,6 +7,7 @@
PORTNAME= lp_solve
PORTVERSION= 5.5.0.15
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= SF/lpsolve/lpsolve/${PORTVERSION}
DISTNAME= ${PORTNAME}_${PORTVERSION}_source
diff --git a/math/lp_solve/files/patch-shared+commonlib.c b/math/lp_solve/files/patch-shared+commonlib.c
index 978f0e153e73..bb4f7edd88a2 100644
--- a/math/lp_solve/files/patch-shared+commonlib.c
+++ b/math/lp_solve/files/patch-shared+commonlib.c
@@ -18,7 +18,7 @@
+ struct timezone tz;
+
+ gettimeofday(&tv, &tz);
-+ return((double)tv.tv_sec+((double)tv.tv_usec)/1000.0);
++ return((double)tv.tv_sec+((double)tv.tv_usec)/1000000.0);
- ftime(&buf);
- return((double)buf.time+((double) buf.millitm)/1000.0);