aboutsummaryrefslogtreecommitdiff
path: root/math/ltl
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-19 07:01:23 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-19 07:01:23 +0000
commitf09318273af567bf8983938363c8bd316ba27645 (patch)
tree90336b299d3bb7ddc1947824cc6a263402dd22fe /math/ltl
parenta4eec648158cbd45b24b3bdd0ba9084e7cef48bd (diff)
Notes
Diffstat (limited to 'math/ltl')
-rw-r--r--math/ltl/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/math/ltl/Makefile b/math/ltl/Makefile
index b554417c32b1..f7300292b1c1 100644
--- a/math/ltl/Makefile
+++ b/math/ltl/Makefile
@@ -10,12 +10,11 @@ MASTER_SITES= http://www.mpe.mpg.de/~drory/ltl/
MAINTAINER= rossiya@gmail.com
COMMENT= A C++ class SSE library for scientific computing
-LIB_DEPENDS= lapack.4:${PORTSDIR}/math/lapack \
- blas.2:${PORTSDIR}/math/blas
+LIB_DEPENDS= liblapack.so:${PORTSDIR}/math/lapack \
+ libblas.so:${PORTSDIR}/math/blas
-USES= gmake
+USES= gmake libtool
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --with-cxx=gcc --disable-doxygen --prefix=${PREFIX} --includedir=${PREFIX}/include/LTL
MAKE_ENV= prefix=${PREFIX} exec_prefix=${PREFIX}
MAKE_ARGS+= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
@@ -24,14 +23,12 @@ INSTALL_TARGET= install install-data distdir
PORTDOCS= *.html
-NO_STAGE= yes
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for docs in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/doc/html/${docs} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/html/${docs} ${STAGEDIR}${DOCSDIR}
.endfor
.endif
- @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
.include <bsd.port.mk>