aboutsummaryrefslogtreecommitdiff
path: root/math/ltl
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-09-19 19:37:57 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-09-19 19:37:57 +0000
commitdd62ee147c0af6880fb99a3359cadf3423c79407 (patch)
tree5cd235c1e320decbd23bc2b4e2098cd45bff6e77 /math/ltl
parent2d5c2ad67bf0c1bd8a8dce2068667ef9c6f486df (diff)
downloadports-dd62ee147c0af6880fb99a3359cadf3423c79407.tar.gz
ports-dd62ee147c0af6880fb99a3359cadf3423c79407.zip
Notes
Diffstat (limited to 'math/ltl')
-rw-r--r--math/ltl/Makefile9
-rw-r--r--math/ltl/distinfo6
-rw-r--r--math/ltl/pkg-plist9
3 files changed, 17 insertions, 7 deletions
diff --git a/math/ltl/Makefile b/math/ltl/Makefile
index fa15868feba7..60ec017b6ec0 100644
--- a/math/ltl/Makefile
+++ b/math/ltl/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= ltl
-PORTVERSION= 1.7.10
+PORTVERSION= 1.9.1
CATEGORIES= math
MASTER_SITES= http://www.mpe.mpg.de/~drory/ltl/
@@ -23,13 +23,14 @@ MAKE_ARGS+= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
INSTALL_TARGET= install install-data check distdir
-PORTDOCS= doc/html/*[h.][tp][mn][lg]
-PLIST_FILES= `ls ${WRKSRC}/doc/html/*[h.][tp][mn][lg] | ${SED} -e 's!${WRKSRC}/doc/html/!%%PORTDOCS%%%%DOCSDIR%%/!g'`
+PORTDOCS= *.html
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && pwd && ${INSTALL_DATA} -v ${PORTDOCS} ${DOCSDIR}
+.for docs in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/doc/html/${docs} ${DOCSDIR}
+.endfor
.endif
@${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
diff --git a/math/ltl/distinfo b/math/ltl/distinfo
index af5ccd23f434..084364a1ceeb 100644
--- a/math/ltl/distinfo
+++ b/math/ltl/distinfo
@@ -1,3 +1,3 @@
-MD5 (ltl-1.7.10.tar.gz) = ebd6dce461a56d4d696cb09219174c33
-SHA256 (ltl-1.7.10.tar.gz) = ee9cc0b8acb1a4aef6a9b5c219fa1c218db0c1a060969544599c662410d984e3
-SIZE (ltl-1.7.10.tar.gz) = 1244938
+MD5 (ltl-1.9.1.tar.gz) = 2e4edfd13f22d1270454d82d7ab3e3a1
+SHA256 (ltl-1.9.1.tar.gz) = 155294787c5bc5859583a2d88328cbf8992c46cb6d93e2c49f3b7b08df256fda
+SIZE (ltl-1.9.1.tar.gz) = 755500
diff --git a/math/ltl/pkg-plist b/math/ltl/pkg-plist
index 74eb58c85557..e9693ab42f0d 100644
--- a/math/ltl/pkg-plist
+++ b/math/ltl/pkg-plist
@@ -15,9 +15,13 @@ include/LTL/ltl/fmatrix/fmiter.h
include/LTL/ltl/fmatrix/fmtloops.h
include/LTL/ltl/fmatrix/fmtranspose.h
include/LTL/ltl/fmatrix/gaussj.h
+include/LTL/ltl/fmatrix/lmfit.h
+include/LTL/ltl/fmatrix/lusolve.h
include/LTL/ltl/fmatrix/marquardt.h
include/LTL/ltl/fmatrix/mrqfuncs.h
+include/LTL/ltl/fmatrix/mrqhesse.h
include/LTL/ltl/fmatrix/polynomfit.h
+include/LTL/ltl/fmatrix/svdsolve.h
include/LTL/ltl/fvector.h
include/LTL/ltl/fvector/fvbool.h
include/LTL/ltl/fvector/fvdot.h
@@ -34,6 +38,8 @@ include/LTL/ltl/io/fits_data.h
include/LTL/ltl/io/fits_header.h
include/LTL/ltl/linlsqfit.h
include/LTL/ltl/marray.h
+include/LTL/ltl/marray/apply.h
+include/LTL/ltl/marray/blas.h
include/LTL/ltl/marray/cast.h
include/LTL/ltl/marray/eval.h
include/LTL/ltl/marray/eval_reduc.h
@@ -41,11 +47,14 @@ include/LTL/ltl/marray/expr.h
include/LTL/ltl/marray/expr_iter.h
include/LTL/ltl/marray/expr_ops.h
include/LTL/ltl/marray/index_iter.h
+include/LTL/ltl/marray/lapack.h
include/LTL/ltl/marray/marray_iter.h
include/LTL/ltl/marray/marray_methods.h
include/LTL/ltl/marray/marray_ops.h
include/LTL/ltl/marray/merge.h
include/LTL/ltl/marray/reductions.h
+include/LTL/ltl/marray/reductions_sse.h
+include/LTL/ltl/marray/partial_reduc.h
include/LTL/ltl/marray/shape.h
include/LTL/ltl/marray/shape_iter.h
include/LTL/ltl/marray/simplevec.h