aboutsummaryrefslogtreecommitdiff
path: root/math/mate-calc
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-11-23 11:39:07 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-11-23 11:39:07 +0000
commita236e2d0bfa53f22be02c6a4cc7b2cf730bc69e1 (patch)
tree000a9ce64a1e669ce72ebf4b639d75f2ef29c214 /math/mate-calc
parentfdf023af8a1f19bbc7987f3abfb59c503eb6d52c (diff)
downloadports-a236e2d0bfa53f22be02c6a4cc7b2cf730bc69e1.tar.gz
ports-a236e2d0bfa53f22be02c6a4cc7b2cf730bc69e1.zip
Notes
Diffstat (limited to 'math/mate-calc')
-rw-r--r--math/mate-calc/Makefile32
-rw-r--r--math/mate-calc/distinfo2
-rw-r--r--math/mate-calc/files/patch-src_mate-calc-cmd.c93
-rw-r--r--math/mate-calc/pkg-descr5
-rw-r--r--math/mate-calc/pkg-plist154
5 files changed, 286 insertions, 0 deletions
diff --git a/math/mate-calc/Makefile b/math/mate-calc/Makefile
new file mode 100644
index 000000000000..7eaa94ca95c1
--- /dev/null
+++ b/math/mate-calc/Makefile
@@ -0,0 +1,32 @@
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mate-calc
+PORTVERSION= 1.6.0
+CATEGORIES= math mate
+MASTER_SITES= MATE
+DIST_SUBDIR= mate
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= MATE calculator tool based on the old calctool for OpenWindows
+
+PORTSCOUT= limitw:1,even
+
+USES= gettext gmake pathfix pkgconfig
+USE_XZ= yes
+USE_MATE= autogen common:build docutils intlhack
+USE_GNOME= glib20 gnomehier gtk20 libxml2
+USE_AUTOTOOLS= aclocal:env autoconf:env automake:env libtool libtoolize:env
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-gtk=2.0
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+PATHFIX_MAKEFILEIN= Makefile.*
+
+GLIB_SCHEMAS= org.mate.calc.gschema.xml
+
+post-configure:
+ @${REINPLACE_CMD} -e '/^DATADIRNAME/s/lib/share/' \
+ ${WRKSRC}/po/Makefile
+
+.include <bsd.port.mk>
diff --git a/math/mate-calc/distinfo b/math/mate-calc/distinfo
new file mode 100644
index 000000000000..6b0df7899ed9
--- /dev/null
+++ b/math/mate-calc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mate/mate-calc-1.6.0.tar.xz) = 400d5c4d2927edfec4abed6c340ddc125d62ec2b99bf272db09d799efcd2993f
+SIZE (mate/mate-calc-1.6.0.tar.xz) = 710904
diff --git a/math/mate-calc/files/patch-src_mate-calc-cmd.c b/math/mate-calc/files/patch-src_mate-calc-cmd.c
new file mode 100644
index 000000000000..86806b5f0b01
--- /dev/null
+++ b/math/mate-calc/files/patch-src_mate-calc-cmd.c
@@ -0,0 +1,93 @@
+--- src/mate-calc-cmd.c.orig 2013-03-24 20:56:44.000000000 -0500
++++ src/mate-calc-cmd.c 2013-03-24 20:58:28.000000000 -0500
+@@ -8,10 +8,12 @@
+ * license.
+ */
+
++#include <errno.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+ #include <sys/types.h>
++#include <sys/param.h>
+ #include <time.h>
+ #include <locale.h>
+
+@@ -22,6 +24,77 @@
+
+ static MpSerializer *result_serializer;
+
++#if __FreeBSD_version < 800067
++static ssize_t
++getline (char **lineptr, size_t *n, FILE *stream)
++{
++ char *line, *p;
++ long size, copy;
++
++ if (lineptr == NULL || n == NULL) {
++ errno = EINVAL;
++ return (ssize_t) -1;
++ }
++
++ if (ferror (stream))
++ return (ssize_t) -1;
++
++ /* Make sure we have a line buffer to start with. */
++ if (*lineptr == NULL || *n < 2) /* !seen and no buf yet need 2 chars. */ {
++#ifndef MAX_CANON
++#define MAX_CANON 256
++#endif
++ if (!*lineptr)
++ line = (char *) malloc (MAX_CANON);
++ else
++ line = (char *) realloc (*lineptr, MAX_CANON);
++ if (line == NULL)
++ return (ssize_t) -1;
++ *lineptr = line;
++ *n = MAX_CANON;
++ }
++
++ line = *lineptr;
++ size = *n;
++
++ copy = size;
++ p = line;
++
++ while (1) {
++ long len;
++
++ while (--copy > 0) {
++ int c = getc (stream);
++
++ if (c == EOF)
++ goto lose;
++ else if ((*p++ = c) == '\n')
++ goto win;
++ }
++
++ /* Need to enlarge the line buffer. */
++ len = p - line;
++ size *= 2;
++ line = (char *) realloc (line, size);
++ if (line == NULL)
++ goto lose;
++ *lineptr = line;
++ *n = size;
++ p = line + len;
++ copy = size - len;
++ }
++
++lose:
++ if (p == *lineptr)
++ return (ssize_t) -1;
++
++ /* Return a partial line since we got an error in the middle. */
++win:
++ *p = '\0';
++ return p - *lineptr;
++}
++#endif
++
+ static void
+ solve(const char *equation)
+ {
diff --git a/math/mate-calc/pkg-descr b/math/mate-calc/pkg-descr
new file mode 100644
index 000000000000..df9fa7a42b73
--- /dev/null
+++ b/math/mate-calc/pkg-descr
@@ -0,0 +1,5 @@
+Mate-calc is a powerful graphical calulator with financial, logical and
+scientific modes. It uses a multiple precision package to do its arithmetic to
+give a high degree of accuracy.
+
+WWW: http://mate-desktop.org/
diff --git a/math/mate-calc/pkg-plist b/math/mate-calc/pkg-plist
new file mode 100644
index 000000000000..4f5882af1588
--- /dev/null
+++ b/math/mate-calc/pkg-plist
@@ -0,0 +1,154 @@
+bin/mate-calc
+bin/mate-calc-cmd
+bin/mate-calculator
+man/man1/mate-calc.1.gz
+man/man1/mate-calc-cmd.1.gz
+share/applications/mate-calc.desktop
+share/locale/af/LC_MESSAGES/mate-calc.mo
+share/locale/am/LC_MESSAGES/mate-calc.mo
+share/locale/ar/LC_MESSAGES/mate-calc.mo
+share/locale/as/LC_MESSAGES/mate-calc.mo
+share/locale/ast/LC_MESSAGES/mate-calc.mo
+share/locale/az/LC_MESSAGES/mate-calc.mo
+share/locale/be/LC_MESSAGES/mate-calc.mo
+share/locale/be@latin/LC_MESSAGES/mate-calc.mo
+share/locale/bg/LC_MESSAGES/mate-calc.mo
+share/locale/bn/LC_MESSAGES/mate-calc.mo
+share/locale/bn_IN/LC_MESSAGES/mate-calc.mo
+share/locale/bs/LC_MESSAGES/mate-calc.mo
+share/locale/ca/LC_MESSAGES/mate-calc.mo
+share/locale/ca@valencia/LC_MESSAGES/mate-calc.mo
+share/locale/cs/LC_MESSAGES/mate-calc.mo
+share/locale/cy/LC_MESSAGES/mate-calc.mo
+share/locale/da/LC_MESSAGES/mate-calc.mo
+share/locale/de/LC_MESSAGES/mate-calc.mo
+share/locale/dz/LC_MESSAGES/mate-calc.mo
+share/locale/el/LC_MESSAGES/mate-calc.mo
+share/locale/en@shaw/LC_MESSAGES/mate-calc.mo
+share/locale/en_AU/LC_MESSAGES/mate-calc.mo
+share/locale/en_CA/LC_MESSAGES/mate-calc.mo
+share/locale/en_GB/LC_MESSAGES/mate-calc.mo
+share/locale/en_US/LC_MESSAGES/mate-calc.mo
+share/locale/eo/LC_MESSAGES/mate-calc.mo
+share/locale/es/LC_MESSAGES/mate-calc.mo
+share/locale/et/LC_MESSAGES/mate-calc.mo
+share/locale/eu/LC_MESSAGES/mate-calc.mo
+share/locale/fa/LC_MESSAGES/mate-calc.mo
+share/locale/fi/LC_MESSAGES/mate-calc.mo
+share/locale/fr/LC_MESSAGES/mate-calc.mo
+share/locale/ga/LC_MESSAGES/mate-calc.mo
+share/locale/gl/LC_MESSAGES/mate-calc.mo
+share/locale/gu/LC_MESSAGES/mate-calc.mo
+share/locale/he/LC_MESSAGES/mate-calc.mo
+share/locale/hi/LC_MESSAGES/mate-calc.mo
+share/locale/hr/LC_MESSAGES/mate-calc.mo
+share/locale/hu/LC_MESSAGES/mate-calc.mo
+share/locale/hy/LC_MESSAGES/mate-calc.mo
+share/locale/id/LC_MESSAGES/mate-calc.mo
+share/locale/it/LC_MESSAGES/mate-calc.mo
+share/locale/ja/LC_MESSAGES/mate-calc.mo
+share/locale/ka/LC_MESSAGES/mate-calc.mo
+share/locale/kk/LC_MESSAGES/mate-calc.mo
+share/locale/km/LC_MESSAGES/mate-calc.mo
+share/locale/kn/LC_MESSAGES/mate-calc.mo
+share/locale/ko/LC_MESSAGES/mate-calc.mo
+share/locale/ku/LC_MESSAGES/mate-calc.mo
+share/locale/ky/LC_MESSAGES/mate-calc.mo
+share/locale/lt/LC_MESSAGES/mate-calc.mo
+share/locale/lv/LC_MESSAGES/mate-calc.mo
+share/locale/mai/LC_MESSAGES/mate-calc.mo
+share/locale/mg/LC_MESSAGES/mate-calc.mo
+share/locale/mk/LC_MESSAGES/mate-calc.mo
+share/locale/ml/LC_MESSAGES/mate-calc.mo
+share/locale/mn/LC_MESSAGES/mate-calc.mo
+share/locale/mr/LC_MESSAGES/mate-calc.mo
+share/locale/ms/LC_MESSAGES/mate-calc.mo
+share/locale/my/LC_MESSAGES/mate-calc.mo
+share/locale/nb/LC_MESSAGES/mate-calc.mo
+share/locale/ne/LC_MESSAGES/mate-calc.mo
+share/locale/nl/LC_MESSAGES/mate-calc.mo
+share/locale/nn/LC_MESSAGES/mate-calc.mo
+share/locale/oc/LC_MESSAGES/mate-calc.mo
+share/locale/or/LC_MESSAGES/mate-calc.mo
+share/locale/pa/LC_MESSAGES/mate-calc.mo
+share/locale/pl/LC_MESSAGES/mate-calc.mo
+share/locale/pt/LC_MESSAGES/mate-calc.mo
+share/locale/pt_BR/LC_MESSAGES/mate-calc.mo
+share/locale/ro/LC_MESSAGES/mate-calc.mo
+share/locale/ru/LC_MESSAGES/mate-calc.mo
+share/locale/rw/LC_MESSAGES/mate-calc.mo
+share/locale/si/LC_MESSAGES/mate-calc.mo
+share/locale/sk/LC_MESSAGES/mate-calc.mo
+share/locale/sl/LC_MESSAGES/mate-calc.mo
+share/locale/sq/LC_MESSAGES/mate-calc.mo
+share/locale/sr/LC_MESSAGES/mate-calc.mo
+share/locale/sr@latin/LC_MESSAGES/mate-calc.mo
+share/locale/sv/LC_MESSAGES/mate-calc.mo
+share/locale/ta/LC_MESSAGES/mate-calc.mo
+share/locale/te/LC_MESSAGES/mate-calc.mo
+share/locale/th/LC_MESSAGES/mate-calc.mo
+share/locale/tk/LC_MESSAGES/mate-calc.mo
+share/locale/tr/LC_MESSAGES/mate-calc.mo
+share/locale/ug/LC_MESSAGES/mate-calc.mo
+share/locale/uk/LC_MESSAGES/mate-calc.mo
+share/locale/vi/LC_MESSAGES/mate-calc.mo
+share/locale/xh/LC_MESSAGES/mate-calc.mo
+share/locale/zh_CN/LC_MESSAGES/mate-calc.mo
+share/locale/zh_HK/LC_MESSAGES/mate-calc.mo
+share/locale/zh_TW/LC_MESSAGES/mate-calc.mo
+%%DATADIR%%/buttons-advanced.ui
+%%DATADIR%%/buttons-basic.ui
+%%DATADIR%%/buttons-financial.ui
+%%DATADIR%%/buttons-programming.ui
+%%DATADIR%%/preferences.ui
+@dirrm %%DATADIR%%
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/xh/LC_MESSAGES
+@dirrmtry share/locale/xh
+@dirrmtry share/locale/ug/LC_MESSAGES
+@dirrmtry share/locale/ug
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin
+@dirrmtry share/locale/si/LC_MESSAGES
+@dirrmtry share/locale/si
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
+@dirrmtry share/locale/oc/LC_MESSAGES
+@dirrmtry share/locale/oc
+@dirrmtry share/locale/my/LC_MESSAGES
+@dirrmtry share/locale/my
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/mg/LC_MESSAGES
+@dirrmtry share/locale/mg
+@dirrmtry share/locale/mai/LC_MESSAGES
+@dirrmtry share/locale/mai
+@dirrmtry share/locale/ky/LC_MESSAGES
+@dirrmtry share/locale/ky
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
+@dirrmtry share/locale/km/LC_MESSAGES
+@dirrmtry share/locale/km
+@dirrmtry share/locale/kk/LC_MESSAGES
+@dirrmtry share/locale/kk
+@dirrmtry share/locale/hy/LC_MESSAGES
+@dirrmtry share/locale/hy
+@dirrmtry share/locale/en_US/LC_MESSAGES
+@dirrmtry share/locale/en_US
+@dirrmtry share/locale/en@shaw/LC_MESSAGES
+@dirrmtry share/locale/en@shaw
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
+@dirrmtry share/locale/ca@valencia/LC_MESSAGES
+@dirrmtry share/locale/ca@valencia
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/be@latin/LC_MESSAGES
+@dirrmtry share/locale/be@latin
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast
+@dirrmtry share/locale/as/LC_MESSAGES
+@dirrmtry share/locale/as