aboutsummaryrefslogtreecommitdiff
path: root/math/mathomatic
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-10-26 07:52:07 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-10-26 07:52:07 +0000
commit96e924e3e0620616ba44248c18b855e651f6241e (patch)
treefe5a4168071e52b53ffe1ac53c3e9f3d60b6584c /math/mathomatic
parente12db4011c1e8691d75b86b102698bc4b94eeed6 (diff)
downloadports-96e924e3e0620616ba44248c18b855e651f6241e.tar.gz
ports-96e924e3e0620616ba44248c18b855e651f6241e.zip
Notes
Diffstat (limited to 'math/mathomatic')
-rw-r--r--math/mathomatic/Makefile23
-rw-r--r--math/mathomatic/pkg-plist3
2 files changed, 12 insertions, 14 deletions
diff --git a/math/mathomatic/Makefile b/math/mathomatic/Makefile
index 609c5a1baeb5..609590ff8270 100644
--- a/math/mathomatic/Makefile
+++ b/math/mathomatic/Makefile
@@ -18,33 +18,34 @@ USE_BZIP2= yes
MAKEFILE= makefile
PORTDOCS= *
-MAN1= mathomatic.1
+PLIST_FILES= bin/mathomatic man/man1/mathomatic.1.gz \
+ share/pixmaps/mathomatic.png \
+ share/applications/mathomatic.desktop
MAKE_ARGS= READLINE=1
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
regression-test: build
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/mathomatic ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/mathomatic.1 ${PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/mathomatic ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${PREFIX}/man/man1
${INSTALL_DATA} ${WRKSRC}/icons/mathomatic.desktop \
- ${PREFIX}/share/applications
- ${INSTALL_DATA} ${WRKSRC}/icons/mathomatic.png ${PREFIX}/share/pixmaps
+ ${STAGEDIR}${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/icons/mathomatic.png ${STAGEDIR}${PREFIX}/share/pixmaps
.if ${PORT_OPTIONS:MDOCS}
.for d in m4 tests
- ${MKDIR} ${DOCSDIR}/${d}
- ${INSTALL_DATA} ${WRKSRC}/${d}/* ${DOCSDIR}/${d}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/${d}
+ ${INSTALL_DATA} ${WRKSRC}/${d}/* ${STAGEDIR}${DOCSDIR}/${d}
.endfor
- ${MKDIR} ${DOCSDIR}/html
- ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}/html
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/html
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${STAGEDIR}${DOCSDIR}/html
.for f in AUTHORS README.txt changes.txt
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
.endfor
.endif
diff --git a/math/mathomatic/pkg-plist b/math/mathomatic/pkg-plist
deleted file mode 100644
index b15cc0220280..000000000000
--- a/math/mathomatic/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/mathomatic
-share/pixmaps/mathomatic.png
-share/applications/mathomatic.desktop