aboutsummaryrefslogtreecommitdiff
path: root/math/matrix
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-03-31 01:33:37 +0000
committerWill Andrews <will@FreeBSD.org>2001-03-31 01:33:37 +0000
commite6747057865eac8194696c51fc1a377b68618bd5 (patch)
tree56d64f4547dccd400952f234e5bee9d66efeda14 /math/matrix
parent91dbb2cfe3e3a24c306e4b39e92e26ba18f456cd (diff)
downloadports-e6747057865eac8194696c51fc1a377b68618bd5.tar.gz
ports-e6747057865eac8194696c51fc1a377b68618bd5.zip
Notes
Diffstat (limited to 'math/matrix')
-rw-r--r--math/matrix/Makefile22
-rw-r--r--math/matrix/distinfo1
-rw-r--r--math/matrix/pkg-comment1
-rw-r--r--math/matrix/pkg-descr4
-rw-r--r--math/matrix/pkg-plist6
5 files changed, 34 insertions, 0 deletions
diff --git a/math/matrix/Makefile b/math/matrix/Makefile
new file mode 100644
index 000000000000..5dfed92b48db
--- /dev/null
+++ b/math/matrix/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: matrix
+# Date created: 27 March 2001
+# Whom: Anton Voronin <anton@urc.ac.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= matrix
+PORTVERSION= 1.0
+CATEGORIES= math devel
+MASTER_SITES= http://rnoc.urc.ac.ru/~anton/projects/files/
+DISTNAME= matrix-${PORTVERSION}
+
+MAINTAINER= anton@urc.ac.ru
+
+WRKSRC= ${WRKDIR}/matrix
+
+USE_ZIP= yes
+INSTALLS_SHLIB= yes
+PLIST_SUB= LIBVERSION=1
+
+.include <bsd.port.mk>
diff --git a/math/matrix/distinfo b/math/matrix/distinfo
new file mode 100644
index 000000000000..2b82a2919fc8
--- /dev/null
+++ b/math/matrix/distinfo
@@ -0,0 +1 @@
+MD5 (matrix-1.0.zip) = 37e4d1a468a22d2529180d269bcd094d
diff --git a/math/matrix/pkg-comment b/math/matrix/pkg-comment
new file mode 100644
index 000000000000..4c61d323ee56
--- /dev/null
+++ b/math/matrix/pkg-comment
@@ -0,0 +1 @@
+C++ library to manipulate matrices and vectors
diff --git a/math/matrix/pkg-descr b/math/matrix/pkg-descr
new file mode 100644
index 000000000000..22bf648c89b5
--- /dev/null
+++ b/math/matrix/pkg-descr
@@ -0,0 +1,4 @@
+C++ library that lets to manipulate matrices and vectors using the base
+class MATRIX and derived class VECTOR.
+
+WWW: http://rnoc.urc.ac.ru/~anton/projects/matrix/Matrix.html
diff --git a/math/matrix/pkg-plist b/math/matrix/pkg-plist
new file mode 100644
index 000000000000..07ddf49d27b9
--- /dev/null
+++ b/math/matrix/pkg-plist
@@ -0,0 +1,6 @@
+include/matrix.h
+lib/libmatrix.a
+lib/libmatrix.so
+lib/libmatrix.so.%%LIBVERSION%%
+share/doc/matrix/Matrix.html
+@dirrm share/doc/matrix