aboutsummaryrefslogtreecommitdiff
path: root/math/maxima
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-12-09 12:54:44 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-12-09 12:54:44 +0000
commitbc2f8854ca44daf2a006e524b9c16e0d818c3a38 (patch)
tree055e40a6769f7604dcf7a90ecd5692f5e216db78 /math/maxima
parent43e194e1e9d43e61f49b2e97b13db0271043de12 (diff)
downloadports-bc2f8854ca44daf2a006e524b9c16e0d818c3a38.tar.gz
ports-bc2f8854ca44daf2a006e524b9c16e0d818c3a38.zip
Notes
Diffstat (limited to 'math/maxima')
-rw-r--r--math/maxima/Makefile38
-rw-r--r--math/maxima/pkg-message12
2 files changed, 30 insertions, 20 deletions
diff --git a/math/maxima/Makefile b/math/maxima/Makefile
index e40849057dd2..e63f04a7e295 100644
--- a/math/maxima/Makefile
+++ b/math/maxima/Makefile
@@ -7,20 +7,21 @@
PORTNAME= maxima
PORTVERSION= 5.25.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math lisp tk
MASTER_SITES= SF/maxima/Maxima-source/${PORTVERSION}-source
MAINTAINER= bf@FreeBSD.org
COMMENT= Symbolic mathematics program
+LICENSE= GPLv2
+
BUILD_DEPENDS= ${LOCALBASE}/bin/${LISPPORT}
PATCH_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
RUN_DEPENDS= ${LOCALBASE}/bin/${LISPPORT} \
${LOCALBASE}/bin/gnuplot:${PORTSDIR}/math/gnuplot \
${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
-LICENSE= GPLv2
USE_TK = 84+
USE_GMAKE= yes
USE_PERL5_BUILD= yes
@@ -60,7 +61,8 @@ LISPPORT= lisp:${PORTSDIR}/lang/cmucl
BINDIRECTORY= binary-cmucl
LISPBINARY= lisp
PLIST_SUB+= LISPBINARY=""
-MAXIMABINARY= maxima.core
+MAXIMABINARY= maxima_core
+STRIP= #strip(1) chokes on LISPBINARY
.elif defined(WITHOUT_CLISP) && defined(WITHOUT_CMUCL) && defined(WITH_GCL) && defined(WITHOUT_SBCL)
LISPSELECT= --enable-gcl
LISPPORT= gcl:${PORTSDIR}/lang/gcl
@@ -71,6 +73,8 @@ MAXIMABINARY= maxima
.elif defined(WITHOUT_CLISP) && defined(WITHOUT_CMUCL) && defined(WITHOUT_GCL) && defined(WITH_SBCL)
. if ${ARCH} == "i386"
DYNAMIC_SPACE_SIZE?= 512
+. else
+DYNAMIC_SPACE_SIZE?= 1024
. endif
. if defined(DYNAMIC_SPACE_SIZE)
MAXIMA_LISP_OPTIONS+= --dynamic-space-size ${DYNAMIC_SPACE_SIZE}
@@ -84,29 +88,37 @@ LISPPORT= sbcl:${PORTSDIR}/lang/sbcl
BINDIRECTORY= binary-sbcl
#LISPBINARY is null so fudge this so deinstall works cleanly
PLIST_SUB+= LISPBINARY="@comment "
-MAXIMABINARY= maxima.core
+MAXIMABINARY= maxima_core
.else
IGNORE= define only one lisp
.endif
post-patch:
- ${FIND} -X ${WRKSRC}/archive ${WRKSRC}/interfaces/xmaxima \
- -name 'Makefile.in' | ${XARGS} ${REINPLACE_CMD} -e "s;tclsh;${TCLSH};g"
- ${REINPLACE_CMD} -e "s;/usr;${LOCALBASE};g" ${WRKSRC}/src/intl.lisp
- (cd ${WRKSRC}/doc/info ; ${LOCALBASE}/bin/bash ./fix_crlf ; \
- ${LOCALBASE}/bin/bash ./fix_tab)
+ @${GREP} -Fe '.core' -l -r ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} \
+ -e 's;\.core;_core;g'
+ @${FIND} -X ${WRKSRC}/interfaces/xmaxima -name 'Makefile.in' | ${XARGS} \
+ ${REINPLACE_CMD} -e "s;tclsh;${TCLSH};g"
+ @${REINPLACE_CMD} -e "s;/usr;${LOCALBASE};g" ${WRKSRC}/src/intl.lisp
+ @cd ${WRKSRC}/doc/info ; ${LOCALBASE}/bin/bash ./fix_crlf ; \
+ ${LOCALBASE}/bin/bash ./fix_tab
+ @${REINPLACE_CMD} -e 's;$$maxima_image_base;$${maxima_image_base};g' \
+ ${WRKSRC}/src/maxima.in
.if defined(MAXIMA_LISP_OPTIONS) && !empty(MAXIMA_LISP_OPTIONS)
- ${REINPLACE_CMD} -e 's;"@SBCL_NAME@";@SBCL_NAME@;' \
+ @${REINPLACE_CMD} -e 's;"@SBCL_NAME@";@SBCL_NAME@;g' \
${WRKSRC}/src/maxima.in
.endif
+pre-build:
+ @${FIND} ${WRKSRC} \( -name '*.bak' -o -name '*.fbsd10bak' -o \
+ -name '*.orig' \) -delete
+
post-install:
@${ECHO_MSG} ""
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG} ""
-test check: build
- (cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${_MAKE_JOBS} \
- ${MAKE_ARGS} check)
+check test: build
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${_MAKE_JOBS} \
+ ${MAKE_ARGS} check
.include <bsd.port.post.mk>
diff --git a/math/maxima/pkg-message b/math/maxima/pkg-message
index 0c12e3ea65cd..ac35095ac1a2 100644
--- a/math/maxima/pkg-message
+++ b/math/maxima/pkg-message
@@ -1,7 +1,5 @@
-When built with sbcl, maxima imposes a default memory
-limit of 512MB on i386. A limit can be imposed on other
-architectures, or changed on i386, by defining
-DYNAMIC_SPACE_SIZE appropriately in the build environment.
-The limit can be overridden at runtime, via the
--X/--lisp-options option, or by defining the environment
-variable MAXIMA_LISP_OPTIONS.
+When built with sbcl, maxima imposes a default memory limit of 512MiB on i386,
+and 1GiB on amd64. The limit can be changed by defining DYNAMIC_SPACE_SIZE
+in the build environment. The limit can be overridden later, at run-time,
+via the -X or --lisp-options options, or by defining the environment variable
+MAXIMA_LISP_OPTIONS.