aboutsummaryrefslogtreecommitdiff
path: root/math/maxima
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2019-01-27 11:56:41 +0000
committerKurt Jaeger <pi@FreeBSD.org>2019-01-27 11:56:41 +0000
commit53f39b50b44968b7dc062c7a36454047ff325c4d (patch)
treecdbe61ff81fbadf6662bd4a3875864992d2d3d07 /math/maxima
parent489bff9e815117b4aeefd8b507abf809a087d404 (diff)
Notes
Diffstat (limited to 'math/maxima')
-rw-r--r--math/maxima/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/math/maxima/Makefile b/math/maxima/Makefile
index 853930db7728..e672c3dfae1c 100644
--- a/math/maxima/Makefile
+++ b/math/maxima/Makefile
@@ -3,6 +3,7 @@
PORTNAME= maxima
PORTVERSION= 5.42.2
+PORTREVISION= 1
CATEGORIES= math lisp tk
MASTER_SITES= SF/maxima/Maxima-source/${PORTVERSION}-source
@@ -27,11 +28,11 @@ INFO= imaxima maxima xmaxima abs_integrate drawutils kovacicODE logic
PLIST_SUB+= PORTVERSION=${PORTVERSION}
-OPTIONS_DEFINE= EXAMPLES DOCS MANPAGES TEST
+OPTIONS_DEFINE= EXAMPLES DOCS NOUSERINIT MANPAGES TEST
OPTIONS_SINGLE= LISP
OPTIONS_SINGLE_LISP= CCL CMUCL SBCL
-OPTIONS_DEFAULT= MANPAGES SBCL
+OPTIONS_DEFAULT= NOUSERINIT MANPAGES SBCL
OPTIONS_SUB= yes
CCL_DESC= Build with Clozure Common Lisp
@@ -46,6 +47,8 @@ CMUCL_RUN_DEPENDS= lisp:lang/cmucl
CMUCL_CONFIGURE_ON= --enable-cmucl
CMUCL_PLIST_SUB= BINDIR=binary-cmucl BINNAME=maxima_core
+NOUSERINIT_DESC= Do not load user init file for lisp (only for sbcl)
+
SBCL_DESC= Build with Steel Bank Common Lisp
SBCL_BUILD_DEPENDS= sbcl:lang/sbcl
SBCL_RUN_DEPENDS= sbcl:lang/sbcl
@@ -88,4 +91,7 @@ post-install-EXAMPLES-on:
post-install-MANPAGES-on:
${INSTALL_MAN} ${WRKSRC}/doc/man/maxima.1.gz ${STAGEDIR}${PREFIX}/man/man1
+post-install-NOUSERINIT-on:
+ ${REINPLACE_CMD} 's;--end-runtime-options;--end-runtime-options --no-userinit;' ${STAGEDIR}${PREFIX}/bin/maxima
+
.include <bsd.port.mk>