aboutsummaryrefslogtreecommitdiff
path: root/math/metis-edf/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2003-07-23 08:37:16 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2003-07-23 08:37:16 +0000
commit9fd1a0b83282b23a8c9624130a3835f777770ab1 (patch)
tree6f13a7cf8394b6f0d2bcd7707d19beba1c4ba430 /math/metis-edf/Makefile
parent419650db6282a7110332da4b84b0b51b987893c7 (diff)
downloadports-9fd1a0b83282b23a8c9624130a3835f777770ab1.tar.gz
ports-9fd1a0b83282b23a8c9624130a3835f777770ab1.zip
Notes
Diffstat (limited to 'math/metis-edf/Makefile')
-rw-r--r--math/metis-edf/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/math/metis-edf/Makefile b/math/metis-edf/Makefile
new file mode 100644
index 000000000000..2ffdb3f27bff
--- /dev/null
+++ b/math/metis-edf/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: metis-edf
+# Date created: Thu Jun 26 2003
+# Whom: thierry@pompo.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= metis-edf
+PORTVERSION= 3
+CATEGORIES= cad
+MASTER_SITES= http://www.code-aster.org/FICHIERS/metis/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Meshes partionning tool used by Code_Aster
+
+ALL_TARGET= default
+MAKE_ENV+= CC="${CC}" AR="${AR}" LD="${LD}" F77="${F77}"
+USE_REINPLACE= yes
+
+F77?= f77
+
+do-install:
+ @${CP} ${WRKSRC}/CONFIG/onmetis.in ${WRKSRC}/onmetis
+ @${REINPLACE_CMD} -e "s#HOME_METIS#${PREFIX}/bin#" ${WRKSRC}/onmetis
+ ${INSTALL_SCRIPT} ${WRKSRC}/onmetis ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/onmetis.exe ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/libmetis.a ${PREFIX}/lib
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/Doc/manual.ps ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/Test/fort.81 ${EXAMPLESDIR}
+ @${ECHO_MSG} "===> Test file installed in ${EXAMPLESDIR}."
+.endif
+
+.include <bsd.port.mk>