aboutsummaryrefslogtreecommitdiff
path: root/math/miracl
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-01-18 01:43:38 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-01-18 01:43:38 +0000
commit79e0c9b3c0e1de0ae7bc4ea82fa9594702f8ce87 (patch)
tree2122dd39e0fff8407d724e5ca0ca1e946b6d7215 /math/miracl
parent7224a1cee5876d2144e5f1af88e613944385bdf2 (diff)
downloadports-79e0c9b3c0e1de0ae7bc4ea82fa9594702f8ce87.tar.gz
ports-79e0c9b3c0e1de0ae7bc4ea82fa9594702f8ce87.zip
Notes
Diffstat (limited to 'math/miracl')
-rw-r--r--math/miracl/Makefile43
-rw-r--r--math/miracl/distinfo2
-rw-r--r--math/miracl/pkg-descr20
3 files changed, 65 insertions, 0 deletions
diff --git a/math/miracl/Makefile b/math/miracl/Makefile
new file mode 100644
index 000000000000..d8b60dc1a546
--- /dev/null
+++ b/math/miracl/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: MIRACL
+# Date created: Mon Jan 17 21:38:16 UTC 2005
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= miracl
+DISTVERSION= 4.85
+CATEGORIES= math
+MASTER_SITES= ftp://ftp.computing.dcu.ie/pub/crypto/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= Multiprecision Integer and Rational Arithmetic C/C++ Library
+
+USE_ZIP= yes
+USE_REINPLACE= yes
+NO_WRKSUBDIR= ys
+
+EXTRACT_BEFORE_ARGS= -j -aa -L
+
+PLIST_FILES= \
+ lib/libmiracl.a
+
+post-patch:
+# C{C,XX} safeness
+# CFLAGS safeness
+ @${REINPLACE_CMD} -E \
+ -e 's|gcc|${CC}|' \
+ -e 's|g\+\+|${CXX}|' \
+ -e 's|-O2|${CFLAGS}|' \
+ ${WRKSRC}/linux
+
+do-build:
+ @cd ${WRKSRC} && ${SH} ./linux
+
+do-install:
+# lib
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.a \
+ ${PREFIX}/lib/lib${PORTNAME}.a
+
+.include <bsd.port.mk>
diff --git a/math/miracl/distinfo b/math/miracl/distinfo
new file mode 100644
index 000000000000..8e1f18b6c6d3
--- /dev/null
+++ b/math/miracl/distinfo
@@ -0,0 +1,2 @@
+MD5 (miracl.zip) = d27a168c47a1d8f27e905125275e2168
+SIZE (miracl.zip) = 1414645
diff --git a/math/miracl/pkg-descr b/math/miracl/pkg-descr
new file mode 100644
index 000000000000..65f4b135e1da
--- /dev/null
+++ b/math/miracl/pkg-descr
@@ -0,0 +1,20 @@
+[ excerpt from developer's web site ]
+
+MIRACL is a Big Number Library which implements all of the primitives
+necessary to design Big Number Cryptography into your real-world
+application. It is primarily a tool for cryptographic system
+implementors. RSA public key cryptography, Diffie-Hellman Key
+exchange, DSA digital signature, they are all just a few procedure
+calls away. Support is also included for even more esoteric Elliptic
+Curves and Lucas function based schemes. The latest version offers
+full support for Elliptic Curve Cryptography over GF(p) and GF(2m).
+Less well-known techniques can also be implemented as MIRACL allows
+you to work directly and efficiently with the big numbers that are
+the building blocks of number-theoretic cryptography. Although
+implemented as a C library, a well-thought out C++ wrapper is
+provided, which greatly simplifies program development. Most example
+programs (25+ of them) are provided in both C and C++ versions.
+
+WWW: http://indigo.ie/~mscott/
+
+-- lioux@FreeBSD.org