aboutsummaryrefslogtreecommitdiff
path: root/math/mosesdecoder
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-10-24 14:16:31 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-10-24 14:16:31 +0000
commit77e43dab911febf142372be41f032364421f0692 (patch)
treec5b6ff39b0e37978c360f8e7226f624420ee4d38 /math/mosesdecoder
parent39dc010c7607ee89b5b9056fc5299231d2bf1f81 (diff)
downloadports-77e43dab911febf142372be41f032364421f0692.tar.gz
ports-77e43dab911febf142372be41f032364421f0692.zip
Notes
Diffstat (limited to 'math/mosesdecoder')
-rw-r--r--math/mosesdecoder/Makefile8
1 files changed, 1 insertions, 7 deletions
diff --git a/math/mosesdecoder/Makefile b/math/mosesdecoder/Makefile
index aa6c1df720cc..2f2eb69389fe 100644
--- a/math/mosesdecoder/Makefile
+++ b/math/mosesdecoder/Makefile
@@ -23,16 +23,10 @@ USE_GITHUB= yes
GH_ACCOUNT= moses-smt
USES= compiler:c++11-lang shebangfix
-SHEBANG_FILES= scripts/analysis/weight-scan-summarize.sh \
- scripts/training/wrappers/adam-suffix-array/suffix-array-extract.sh \
- scripts/training/wrappers/adam-suffix-array/suffix-array-create.sh
+SHEBANG_REGEX= ./scripts/.*\.(sh|pl|perl|cgi)
MAKE_ENV+= BOOST_BUILD_PATH=${WRKSRC}/jam-files/boost-build
-post-patch:
- @${FIND} ${WRKSRC}/scripts \( -name "*.pl" -o -name "*.perl" -o -name "*.cgi" \) -exec \
- ${REINPLACE_CMD} -i '' -e '1s|/usr/bin/perl|${perl_CMD}|' {} \;
-
do-build:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} bjam --with-boost=${LOCALBASE} --with-irstlm=${LOCALBASE} --with-randlm=${LOCALBASE} --without-tcmalloc --notrace --toolset=${CHOSEN_COMPILER_TYPE} debug-symbols=off ${_MAKE_JOBS}