aboutsummaryrefslogtreecommitdiff
path: root/math/mpc/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-04-11 08:16:27 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-04-11 08:16:27 +0000
commitfca026d60ce67c73dce43b4be95969b0d441d4c7 (patch)
treed7a463ffdda441b317f7bde0e7516fdbd343dc43 /math/mpc/Makefile
parentc96dc494c60b73ef4abf07abca35f1ed6006718f (diff)
downloadports-fca026d60ce67c73dce43b4be95969b0d441d4c7.tar.gz
ports-fca026d60ce67c73dce43b4be95969b0d441d4c7.zip
Notes
Diffstat (limited to 'math/mpc/Makefile')
-rw-r--r--math/mpc/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/math/mpc/Makefile b/math/mpc/Makefile
new file mode 100644
index 000000000000..a92e0dac9dc2
--- /dev/null
+++ b/math/mpc/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: mpc
+# Date created: 05 April, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mpc
+PORTVERSION= 0.6
+CATEGORIES= math devel
+MASTER_SITES= http://www.multiprecision.org/mpc/download/
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Library of complex numbers with arbitrarily high precision
+
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
+ mpfr.3:${PORTSDIR}/math/mpfr
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-gmp=${LOCALBASE} \
+ --with-mpfr=${LOCALBASE}
+USE_LDCONFIG= yes
+
+INFO= mpc
+
+regression-test: build
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
+
+.include <bsd.port.mk>