aboutsummaryrefslogtreecommitdiff
path: root/math/mpexpr
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-16 12:00:35 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-16 12:00:35 +0000
commitc03d48594b41aa1eb12c845c16d04599ea209d4d (patch)
tree275dd67d4c2d252d44027a9ff16a41a42d02ca97 /math/mpexpr
parent37a8237406c316fd5d966d25cec1bcd8e4c85216 (diff)
downloadports-c03d48594b41aa1eb12c845c16d04599ea209d4d.tar.gz
ports-c03d48594b41aa1eb12c845c16d04599ea209d4d.zip
- Pass maintainership to submitter
- Update to 1.1 PR: 110312 Submitted by: Martin Tournoij <carpetsmoker@xs4all.nl>
Notes
Notes: svn path=/head/; revision=187494
Diffstat (limited to 'math/mpexpr')
-rw-r--r--math/mpexpr/Makefile30
-rw-r--r--math/mpexpr/distinfo6
-rw-r--r--math/mpexpr/files/patch-aa51
-rw-r--r--math/mpexpr/files/patch-ab100
-rw-r--r--math/mpexpr/files/patch-generic-mpexpr.h13
-rw-r--r--math/mpexpr/files/patch-unix-Makefile.in58
-rw-r--r--math/mpexpr/files/patch-unix-configure33
7 files changed, 126 insertions, 165 deletions
diff --git a/math/mpexpr/Makefile b/math/mpexpr/Makefile
index fa85ff5fd20c..3ff8cf23fd51 100644
--- a/math/mpexpr/Makefile
+++ b/math/mpexpr/Makefile
@@ -6,24 +6,32 @@
#
PORTNAME= mpexpr
-PORTVERSION= 1.0
-CATEGORIES= math tcl83
+PORTVERSION= 1.1
+CATEGORIES= math tcl84
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= mpexpr
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= carpetsmoker@xs4all.nl
COMMENT= Multiple precision math for Tcl
-WRKSRC= ${WRKDIR}/mpexpr-1.0/unix
-
-CONFIGURE_ARGS= --prefix=${PREFIX} \
- --exec-prefix=${PREFIX}
-
-USE_TCL= 83
-USE_TCL_BUILD= 83
+WRKSRC= ${WRKDIR}/${DISTNAME}/unix
+PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}
+USE_TCL= yes
+USE_TCL_BUILD= yes
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_GMAKE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
+USE_LDCONFIG= yes
+PLIST_DIRS= lib/Mpexpr10
+PLIST_FILES= lib/libMpexpr10.so \
+ lib/Mpexpr10/pkgIndex.tcl
MANN= mpexpr.n
+do-install:
+ ${MKDIR} ${PREFIX}/lib/Mpexpr10
+ ${INSTALL_PROGRAM} ${WRKSRC}/libMpexpr10.so ${PREFIX}/lib/
+ ${INSTALL_DATA} ${WRKSRC}/pkgIndex.tcl ${PREFIX}/lib/Mpexpr10/
+ ${INSTALL_MAN} ${WRKDIR}/${DISTNAME}/doc/mpexpr.man ${PREFIX}/man/mann/mpexpr.n
+
.include <bsd.port.mk>
diff --git a/math/mpexpr/distinfo b/math/mpexpr/distinfo
index 16b1f8314325..58f7225c7c67 100644
--- a/math/mpexpr/distinfo
+++ b/math/mpexpr/distinfo
@@ -1,3 +1,3 @@
-MD5 (mpexpr-1.0.tar.gz) = 7978df5a42de32215b0d2f559cd55071
-SHA256 (mpexpr-1.0.tar.gz) = ddf354aeb1c2de4dfd3b2ebc962ae6917c0a146eb365c4536a4d3ab9e9070a96
-SIZE (mpexpr-1.0.tar.gz) = 216954
+MD5 (mpexpr-1.1.tar.gz) = 4b400755412235ab5c3f452870778aeb
+SHA256 (mpexpr-1.1.tar.gz) = 7fc81ef9a213591c0c03939f18acfc0e1e4ddadf3a2c225450d148ffc26a877b
+SIZE (mpexpr-1.1.tar.gz) = 231911
diff --git a/math/mpexpr/files/patch-aa b/math/mpexpr/files/patch-aa
deleted file mode 100644
index e1cf4af6ded2..000000000000
--- a/math/mpexpr/files/patch-aa
+++ /dev/null
@@ -1,51 +0,0 @@
-*** configure.orig Fri Dec 4 16:04:23 1998
---- configure Fri May 11 17:31:55 2001
-***************
-*** 21,26 ****
---- 21,28 ----
- # Initialize some variables set by options.
- # The variables have the same names as the options, with
- # dashes changed to underlines.
-+ TCL_EXEC=tclsh8.3
-+ WISH_EXEC=wish8.3
- build=NONE
- cache_file=./config.cache
- exec_prefix=NONE
-***************
-*** 704,711 ****
-
- # find include/tcl.h
- for f in $prefix_locations ; do
-! if test -r "$f/include/tcl.h"; then
-! TCL_INC_DIR=$f/include
- echo "$ac_t""setting TCL_INC_DIR to $TCL_INC_DIR" 1>&6
- break
- fi
---- 706,713 ----
-
- # find include/tcl.h
- for f in $prefix_locations ; do
-! if test -r "$f/include/tcl8.3/tcl.h"; then
-! TCL_INC_DIR=$f/include/tcl8.3
- echo "$ac_t""setting TCL_INC_DIR to $TCL_INC_DIR" 1>&6
- break
- fi
-***************
-*** 713,720 ****
-
- # find lib/tclConfig.sh
- for f in $exec_prefix_locations ; do
-! if test -r "$f/lib/tclConfig.sh"; then
-! TCL_LIB_DIR=$f/lib
- echo "$ac_t""setting TCL_LIB_DIR to $TCL_LIB_DIR" 1>&6
- break
- fi
---- 715,722 ----
-
- # find lib/tclConfig.sh
- for f in $exec_prefix_locations ; do
-! if test -r "$f/lib/tcl8.3/tclConfig.sh"; then
-! TCL_LIB_DIR=$f/lib/tcl8.3
- echo "$ac_t""setting TCL_LIB_DIR to $TCL_LIB_DIR" 1>&6
- break
- fi
diff --git a/math/mpexpr/files/patch-ab b/math/mpexpr/files/patch-ab
deleted file mode 100644
index 632f872ecc8e..000000000000
--- a/math/mpexpr/files/patch-ab
+++ /dev/null
@@ -1,100 +0,0 @@
-*** Makefile.in.orig Fri Dec 4 16:04:23 1998
---- Makefile.in Thu Feb 27 18:37:45 2003
-***************
-*** 83,95 ****
- #------------------------------------------------------------------------------
- # define names for Mpexpr tclsh/tcl executable
-
-! TCL_EXEC = tclsh
- TCLX_EXEC = tcl
-
- #------------------------------------------------------------------------------
- # define name for Mpexpr wish/wishx executable
-
-! WISH_EXEC = wish
- WISHX_EXEC = wishx
-
- #------------------------------------------------------------------------------
---- 83,95 ----
- #------------------------------------------------------------------------------
- # define names for Mpexpr tclsh/tcl executable
-
-! TCL_EXEC = tclsh8.3
- TCLX_EXEC = tcl
-
- #------------------------------------------------------------------------------
- # define name for Mpexpr wish/wishx executable
-
-! WISH_EXEC = wish8.3
- WISHX_EXEC = wishx
-
- #------------------------------------------------------------------------------
-***************
-*** 210,226 ****
- # a make clobber and try LITTLE_ENDIAN. If that fails, ask a wizard
- # for help.
- #
-! BYTE_ORDER=
- #BYTE_ORDER= BIG_ENDIAN
-! #BYTE_ORDER= LITTLE_ENDIAN
-
- # Determine the number of bits in a long
- #
- # If in doubt, leave LONG_BITS empty. This makefile will run
- # the longbits program to determine the length.
- #
-! LONG_BITS=
-! #LONG_BITS= 32
- #LONG_BITS= 64
-
-
---- 210,226 ----
- # a make clobber and try LITTLE_ENDIAN. If that fails, ask a wizard
- # for help.
- #
-! #BYTE_ORDER=
- #BYTE_ORDER= BIG_ENDIAN
-! BYTE_ORDER= LITTLE_ENDIAN
-
- # Determine the number of bits in a long
- #
- # If in doubt, leave LONG_BITS empty. This makefile will run
- # the longbits program to determine the length.
- #
-! #LONG_BITS=
-! LONG_BITS= 32
- #LONG_BITS= 64
-
-
-***************
-*** 473,486 ****
- #------------------------------------------------------------------------------
- # install targets
-
-! install: @INSTALL_TARGET@ install-man install-tools
-
- install-shared: $(LIB_SH_MPEXPR)
- @echo installing $(LIB_SH_MPEXPR)
- $(INSTALL_PROGRAM) $(LIB_SH_MPEXPR) $(LIB_DIR)/$(LIB_SH_MPEXPR)
- @echo installing pkgIndex.tcl
- -mkdir $(LIB_DIR)/Mpexpr$(MPEXPR_LIBVER)
-! $(INSTALL_PROGRAM) pkgIndex.tcl $(LIB_DIR)/Mpexpr$(MPEXPR_LIBVER)/pkgIndex.tcl
-
- install-static: @PROGS@ $(LIB_MPEXPR)
- @for f in $(T_EXEC) $(W_EXEC) ; do \
---- 473,487 ----
- #------------------------------------------------------------------------------
- # install targets
-
-! #install: @INSTALL_TARGET@ install-man install-tools
-! install: @INSTALL_TARGET@ install-man
-
- install-shared: $(LIB_SH_MPEXPR)
- @echo installing $(LIB_SH_MPEXPR)
- $(INSTALL_PROGRAM) $(LIB_SH_MPEXPR) $(LIB_DIR)/$(LIB_SH_MPEXPR)
- @echo installing pkgIndex.tcl
- -mkdir $(LIB_DIR)/Mpexpr$(MPEXPR_LIBVER)
-! $(INSTALL_DATA) pkgIndex.tcl $(LIB_DIR)/Mpexpr$(MPEXPR_LIBVER)/pkgIndex.tcl
-
- install-static: @PROGS@ $(LIB_MPEXPR)
- @for f in $(T_EXEC) $(W_EXEC) ; do \
diff --git a/math/mpexpr/files/patch-generic-mpexpr.h b/math/mpexpr/files/patch-generic-mpexpr.h
new file mode 100644
index 000000000000..4205741fdf47
--- /dev/null
+++ b/math/mpexpr/files/patch-generic-mpexpr.h
@@ -0,0 +1,13 @@
+--- generic/mpexpr.h.orig Thu Mar 15 03:21:12 2007
++++ generic/mpexpr.h Thu Mar 15 03:21:46 2007
+@@ -100,8 +100,8 @@
+
+ /* mpexpr tcl command procs */
+
+-EXTERN Tcl_CmdProc Mp_ExprCmd;
+-EXTERN Tcl_CmdProc Mp_FormatCmd;
++EXTERN int Mp_ExprCmd(ClientData, Tcl_Interp *interp, int argc, char **argv);
++EXTERN int Mp_FormatCmd(ClientData, Tcl_Interp *interp, int argc, char **argv);
+
+
+ #endif
diff --git a/math/mpexpr/files/patch-unix-Makefile.in b/math/mpexpr/files/patch-unix-Makefile.in
new file mode 100644
index 000000000000..3c659b2b734f
--- /dev/null
+++ b/math/mpexpr/files/patch-unix-Makefile.in
@@ -0,0 +1,58 @@
+--- unix/Makefile.in.orig Tue Jun 8 04:16:40 2004
++++ unix/Makefile.in Thu Mar 15 03:28:30 2007
+@@ -92,13 +92,13 @@
+ #------------------------------------------------------------------------------
+ # define names for Mpexpr tclsh/tcl executable
+
+-TCL_EXEC = tclsh
++TCL_EXEC = tclsh8.4
+ TCLX_EXEC = tcl
+
+ #------------------------------------------------------------------------------
+ # define name for Mpexpr wish/wishx executable
+
+-WISH_EXEC = wish
++WISH_EXEC = wish8.4
+ WISHX_EXEC = wishx
+
+ #------------------------------------------------------------------------------
+@@ -219,17 +219,17 @@
+ # a make clobber and try LITTLE_ENDIAN. If that fails, ask a wizard
+ # for help.
+ #
+-BYTE_ORDER=
++#BYTE_ORDER=
+ #BYTE_ORDER= BIG_ENDIAN
+-#BYTE_ORDER= LITTLE_ENDIAN
++BYTE_ORDER= LITTLE_ENDIAN
+
+ # Determine the number of bits in a long
+ #
+ # If in doubt, leave LONG_BITS empty. This makefile will run
+ # the longbits program to determine the length.
+ #
+-LONG_BITS=
+-#LONG_BITS= 32
++#LONG_BITS=
++LONG_BITS= 32
+ #LONG_BITS= 64
+
+
+@@ -402,14 +402,15 @@
+ #------------------------------------------------------------------------------
+ # install targets
+
+-install: @INSTALL_TARGET@ install-man install-tools
++#install: @INSTALL_TARGET@ install-man install-tools
++install: @INSTALL_TARGET@ install-man
+
+ install-shared: $(LIB_SH_MPEXPR)
+ @echo installing $(LIB_SH_MPEXPR)
+ $(INSTALL_PROGRAM) $(LIB_SH_MPEXPR) $(LIB_DIR)/$(LIB_SH_MPEXPR)
+ @echo installing pkgIndex.tcl
+ -mkdir $(LIB_DIR)/Mpexpr$(MPEXPR_LIBVER)
+- $(INSTALL_PROGRAM) pkgIndex.tcl $(LIB_DIR)/Mpexpr$(MPEXPR_LIBVER)/pkgIndex.tcl
++ $(INSTALL_DATA) pkgIndex.tcl $(LIB_DIR)/Mpexpr$(MPEXPR_LIBVER)/pkgIndex.tcl
+
+ install-static: @PROGS@ $(LIB_MPEXPR)
+ @for f in $(T_EXEC) $(W_EXEC) ; do \
diff --git a/math/mpexpr/files/patch-unix-configure b/math/mpexpr/files/patch-unix-configure
new file mode 100644
index 000000000000..8bcd02d0bb1e
--- /dev/null
+++ b/math/mpexpr/files/patch-unix-configure
@@ -0,0 +1,33 @@
+--- unix/configure.orig Thu Mar 15 03:26:26 2007
++++ unix/configure Thu Mar 15 03:25:16 2007
+@@ -23,6 +23,8 @@
+ # Initialize some variables set by options.
+ # The variables have the same names as the options, with
+ # dashes changed to underlines.
++TCL_EXEC=tclsh8.4
++WISH_EXEC=wish8.4
+ build=NONE
+ cache_file=./config.cache
+ exec_prefix=NONE
+@@ -735,8 +737,8 @@
+
+ # find include/tcl.h
+ for f in $with_tclpath $prefix_locations ; do
+- if test -r "$f/include/tcl.h"; then
+- TCL_INC_DIR=$f/include
++ if test -r "$f/include/tcl8.4/tcl.h"; then
++ TCL_INC_DIR=$f/include/tcl8.4
+ echo "$ac_t""setting TCL_INC_DIR to $TCL_INC_DIR" 1>&6
+ break
+ fi
+@@ -744,8 +746,8 @@
+
+ # find lib/tclConfig.sh
+ for f in $with_tclpath $exec_prefix_locations ; do
+- if test -r "$f/lib/tclConfig.sh"; then
+- TCL_LIB_DIR=$f/lib
++ if test -r "$f/lib/tcl8.4/tclConfig.sh"; then
++ TCL_LIB_DIR=$f/lib/tcl8.4
+ echo "$ac_t""setting TCL_LIB_DIR to $TCL_LIB_DIR" 1>&6
+ break
+ fi