aboutsummaryrefslogtreecommitdiff
path: root/math/mppp
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-01-04 04:46:24 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-01-04 04:46:24 +0000
commita57e28ed4649fef4e15b75b1766140d9e1a4a05a (patch)
tree81762261b9098b46e65fd7afc4558814519b423c /math/mppp
parentbec672b264e60d43752c00c36ef8747ebffcadaf (diff)
downloadports-a57e28ed4649fef4e15b75b1766140d9e1a4a05a.tar.gz
ports-a57e28ed4649fef4e15b75b1766140d9e1a4a05a.zip
Notes
Diffstat (limited to 'math/mppp')
-rw-r--r--math/mppp/Makefile4
-rw-r--r--math/mppp/distinfo6
-rw-r--r--math/mppp/pkg-plist6
3 files changed, 9 insertions, 7 deletions
diff --git a/math/mppp/Makefile b/math/mppp/Makefile
index d863878c48b4..ee20b074dca8 100644
--- a/math/mppp/Makefile
+++ b/math/mppp/Makefile
@@ -2,7 +2,7 @@
PORTNAME= mppp
DISTVERSIONPREFIX= v
-DISTVERSION= 0.21
+DISTVERSION= 0.22
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -18,6 +18,8 @@ LIB_DEPENDS= libarb.so:math/arb \
libmpfr.so:math/mpfr
USES= cmake compiler:c++14-lang
+USE_LDCONFIG= yes
+
USE_GITHUB= yes
GH_ACCOUNT= bluescarni
diff --git a/math/mppp/distinfo b/math/mppp/distinfo
index bb5d8eaf4d6d..1d4e95764d3a 100644
--- a/math/mppp/distinfo
+++ b/math/mppp/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1592547827
-SHA256 (bluescarni-mppp-v0.21_GH0.tar.gz) = 49a05fc6874a800cb42a3ac16eb46a50583f0b59d3b54008c58af766186a8c69
-SIZE (bluescarni-mppp-v0.21_GH0.tar.gz) = 1857134
+TIMESTAMP = 1609734013
+SHA256 (bluescarni-mppp-v0.22_GH0.tar.gz) = 92e34a393c7b6e61daec6a26827a2b73b9b61d961ab37bcabbf051cc7ff19ad2
+SIZE (bluescarni-mppp-v0.22_GH0.tar.gz) = 1868147
diff --git a/math/mppp/pkg-plist b/math/mppp/pkg-plist
index 15d803390d81..3f86ac636968 100644
--- a/math/mppp/pkg-plist
+++ b/math/mppp/pkg-plist
@@ -2,7 +2,6 @@ include/mp++/complex.hpp
include/mp++/complex128.hpp
include/mp++/concepts.hpp
include/mp++/config.hpp
-include/mp++/detail/fwd_decl.hpp
include/mp++/detail/gmp.hpp
include/mp++/detail/integer_literals.hpp
include/mp++/detail/mpc.hpp
@@ -16,6 +15,7 @@ include/mp++/detail/utils.hpp
include/mp++/detail/visibility.hpp
include/mp++/exceptions.hpp
include/mp++/extra/pybind11.hpp
+include/mp++/fwd.hpp
include/mp++/integer.hpp
include/mp++/mp++.hpp
include/mp++/rational.hpp
@@ -30,5 +30,5 @@ lib/cmake/mp++/mp++-config.cmake
lib/cmake/mp++/mp++_export-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/mp++/mp++_export.cmake
lib/libmp++.so
-lib/libmp++.so.7
-lib/libmp++.so.7.0
+lib/libmp++.so.8
+lib/libmp++.so.8.0