aboutsummaryrefslogtreecommitdiff
path: root/math/msieve/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-11-09 16:54:01 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-11-09 16:54:01 +0000
commit6c2224077f9c29eb175c7281cd233677c102eeb6 (patch)
treee10029a4b268bc187a6a9613740eb53ed3d26032 /math/msieve/Makefile
parent26873a40b354485bfda6cc20c12277cd4628adb6 (diff)
downloadports-6c2224077f9c29eb175c7281cd233677c102eeb6.tar.gz
ports-6c2224077f9c29eb175c7281cd233677c102eeb6.zip
Notes
Diffstat (limited to 'math/msieve/Makefile')
-rw-r--r--math/msieve/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/math/msieve/Makefile b/math/msieve/Makefile
index d4c8254272b4..31df50a19378 100644
--- a/math/msieve/Makefile
+++ b/math/msieve/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= msieve
-PORTVERSION= 1.34
+PORTVERSION= 1.38
CATEGORIES= math
MASTER_SITES= http://www.boo.net/~jasonp/ \
http://mirror.roe.ch/dist/msieve/
@@ -39,13 +39,9 @@ CFLAGS+= -O3 -ffast-math -fomit-frame-pointer -D_FILE_OFFSET_BITS=64
CFLAGS+= -D_FILE_OFFSET_BITS=64
.endif
-# Does not build with GCC 4.2
-.if ${OSVERSION} >= 700042
-USE_GCC= 3.4
-.if ${ARCH} == "sparc64"
+.if ${OSVERSION} >= 700042 && ${ARCH} == "sparc64"
BROKEN= Does not compile on sparc64-7
.endif
-.endif
ALL_TARGET= generic
.if ${ARCH} == "i386"