aboutsummaryrefslogtreecommitdiff
path: root/math/mtl/Makefile
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2012-01-01 17:34:49 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2012-01-01 17:34:49 +0000
commit486a856d6bb14bad22e55b3d87f80a69725aa3dd (patch)
tree2a445277d1931fe7cb8a0742786c969c93e84c21 /math/mtl/Makefile
parentcedadbf3efc8ad3b8cc7610d03b45ca726eda8e2 (diff)
downloadports-486a856d6bb14bad22e55b3d87f80a69725aa3dd.tar.gz
ports-486a856d6bb14bad22e55b3d87f80a69725aa3dd.zip
Notes
Diffstat (limited to 'math/mtl/Makefile')
-rw-r--r--math/mtl/Makefile48
1 files changed, 44 insertions, 4 deletions
diff --git a/math/mtl/Makefile b/math/mtl/Makefile
index 4198ce3d2b2c..00148bcd2f61 100644
--- a/math/mtl/Makefile
+++ b/math/mtl/Makefile
@@ -7,15 +7,55 @@
#
PORTNAME= mtl
-PORTVERSION= 2.1.2.22
+DISTVERSION= 2.1.2-23.tentative
CATEGORIES= math devel
MASTER_SITES= http://www.osl.iu.edu/download/research/mtl/
-DISTNAME= ${PORTNAME}-2.1.2-22
MAINTAINER= bf@FreeBSD.org
-COMMENT= The Matrix Template Library
+COMMENT= The Matrix Template Library, Version 2
+LICENSE= MTL
+LICENSE_NAME= Matrix Template Library License
+LICENSE_FILE= ${WRKSRC}/license.mtl.txt
+LICENSE_PERMS= auto-accept
+
+CONFIGURE_ENV= CXXCPP="${CXXCPP}"
+CXXCPP?= ${CXX} -E
GNU_CONFIGURE= yes
NO_BUILD= yes
+USE_PERL5_BUILD= yes
+WRKSRC = ${WRKDIR}/${DISTNAME:R}
+
+post-patch:
+ @${REINPLACE_CMD} -e '/gnu\*)/,/;;/{/CXX=/d; /CXX_OPTIMIZE_FLAGS=/d; \
+ s/CXXFLAGS="/&$$ac_cv_env_CXXFLAGS_value /; }' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|\./.*\.pl[[:blank:]]|${PERL} &|' \
+ ${WRKSRC}/test/Makefile.in
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${TOUCH} -m
+
+check regression-test test: build
+ @cd ${WRKSRC}/test; ${SETENV} ${MAKE_ENV} ${MAKE} ${_MAKE_JOBS} \
+ ${MAKE_ARGS} QUICK=-qQ test summary
+
+fulltest: build
+ @cd ${WRKSRC}/test; ${SETENV} ${MAKE_ENV} ${MAKE} ${_MAKE_JOBS} \
+ ${MAKE_ARGS} QUICK= test summary
+
+
+.include <bsd.port.pre.mk>
+
+.if defined(USE_GCC) || !empty(CXX:M*g++4*)
+CXXFLAGS+= -fpermissive
+.endif
+
+.if !defined(NOPORTEXAMPLES)
+PORTEXAMPLES= *
+
+post-install:
+ @${INSTALL_DATA} -d ${EXAMPLESDIR}/doubledouble
+ @${INSTALL_DATA} ${WRKSRC}/contrib/examples/* ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/contrib/doubledouble/* ${EXAMPLESDIR}/doubledouble
-.include <bsd.port.mk>
+.endif
+.include <bsd.port.post.mk>