aboutsummaryrefslogtreecommitdiff
path: root/math/mtl
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-15 09:12:15 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-15 09:12:15 +0000
commitf305f49948c1ac7f1cb05a3403d413ca728908e3 (patch)
treec9cb48923aaa369dca8668e18ca35a7956d7a43f /math/mtl
parente34af0d1832156eeab0b62410d43ca154c256b26 (diff)
downloadports-f305f49948c1ac7f1cb05a3403d413ca728908e3.tar.gz
ports-f305f49948c1ac7f1cb05a3403d413ca728908e3.zip
Notes
Diffstat (limited to 'math/mtl')
-rw-r--r--math/mtl/Makefile19
-rw-r--r--math/mtl/distinfo1
-rw-r--r--math/mtl/pkg-comment1
-rw-r--r--math/mtl/pkg-descr12
-rw-r--r--math/mtl/pkg-plist71
5 files changed, 104 insertions, 0 deletions
diff --git a/math/mtl/Makefile b/math/mtl/Makefile
new file mode 100644
index 000000000000..85cc8a0fe884
--- /dev/null
+++ b/math/mtl/Makefile
@@ -0,0 +1,19 @@
+# ex:ts=8
+# Ports collection makefile for: mtl
+# Date created: Mar 15, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= mtl
+PORTVERSION= 2.1.2.20
+CATEGORIES= math devel
+MASTER_SITES= http://www.osl.iu.edu/download/research/mtl/
+DISTNAME= ${PORTNAME}-2.1.2-20
+
+MAINTAINER= ports@FreeBSD.org
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/math/mtl/distinfo b/math/mtl/distinfo
new file mode 100644
index 000000000000..440c0845f7d1
--- /dev/null
+++ b/math/mtl/distinfo
@@ -0,0 +1 @@
+MD5 (mtl-2.1.2-20.tar.gz) = d4bde52cde7d5f45a6c27c4b171cecd8
diff --git a/math/mtl/pkg-comment b/math/mtl/pkg-comment
new file mode 100644
index 000000000000..d5aabc75116e
--- /dev/null
+++ b/math/mtl/pkg-comment
@@ -0,0 +1 @@
+The Matrix Template Library
diff --git a/math/mtl/pkg-descr b/math/mtl/pkg-descr
new file mode 100644
index 000000000000..4c9d3f769f03
--- /dev/null
+++ b/math/mtl/pkg-descr
@@ -0,0 +1,12 @@
+The Matrix Template Library (MTL) is a high-performance generic component
+library that provides comprehensive linear algebra functionality for a wide
+variety of matrix formats.
+As with the Standard Template Library (STL), MTL uses a five-fold approach,
+consisting of generic functions, containers, iterators, adaptors, and function
+objects, all developed specifically for high performance numerical linear
+algebra. Within this framework, MTL provides generic algorithms corresponding
+to the mathematical operations that define linear algebra. Similarly, the
+containers, adaptors, and iterators are used to represent and to manipulate
+concrete linear algebra objects such as matrices and vectors.
+
+WWW: http://www.osl.iu.edu/research/mtl/
diff --git a/math/mtl/pkg-plist b/math/mtl/pkg-plist
new file mode 100644
index 000000000000..2e743f0e511b
--- /dev/null
+++ b/math/mtl/pkg-plist
@@ -0,0 +1,71 @@
+include/mtl/abs.h
+include/mtl/array2D.h
+include/mtl/banded_indexer.h
+include/mtl/bare_bones_array.h
+include/mtl/blais.h
+include/mtl/blas_interface.h
+include/mtl/block1D.h
+include/mtl/block2D.h
+include/mtl/compressed1D.h
+include/mtl/compressed2D.h
+include/mtl/compressed_iter.h
+include/mtl/conj.h
+include/mtl/cplx_dbldbl.h
+include/mtl/dense1D.h
+include/mtl/dense2D.h
+include/mtl/dense_iterator.h
+include/mtl/diagonal_indexer.h
+include/mtl/dim_calc.h
+include/mtl/dimension.h
+include/mtl/dumptofile.h
+include/mtl/elt.h
+include/mtl/entry.h
+include/mtl/envelope2D.h
+include/mtl/external_vector.h
+include/mtl/fast.h
+include/mtl/harwell_boeing_stream.h
+include/mtl/initialize.h
+include/mtl/iohb.h
+include/mtl/iterator_adaptor.h
+include/mtl/lapack_interface.h
+include/mtl/light1D.h
+include/mtl/light_matrix.h
+include/mtl/linalg_vec.h
+include/mtl/lu.h
+include/mtl/matlabio.h
+include/mtl/matrix.h
+include/mtl/matrix_implementation.h
+include/mtl/matrix_market_stream.h
+include/mtl/matrix_stream.h
+include/mtl/matrix_traits.h
+include/mtl/meta_equal.h
+include/mtl/meta_if.h
+include/mtl/mmio.h
+include/mtl/mtl.h
+include/mtl/mtl2lapack.h
+include/mtl/mtl_algo.h
+include/mtl/mtl_complex.h
+include/mtl/mtl_config.h
+include/mtl/mtl_exception.h
+include/mtl/mtl_iterator.h
+include/mtl/mtl_limits.h
+include/mtl/mtl_set.h
+include/mtl/norm.h
+include/mtl/not_at.h
+include/mtl/oned_part.h
+include/mtl/orien.h
+include/mtl/partition.h
+include/mtl/rect_indexer.h
+include/mtl/refcnt_ptr.h
+include/mtl/reverse_iter.h
+include/mtl/scale_iterator.h
+include/mtl/scaled1D.h
+include/mtl/scaled2D.h
+include/mtl/sparse1D.h
+include/mtl/sparse_iterator.h
+include/mtl/strided1D.h
+include/mtl/strided_iterator.h
+include/mtl/transform_iterator.h
+include/mtl/uplo.h
+include/mtl/utils.h
+@dirrm include/mtl