aboutsummaryrefslogtreecommitdiff
path: root/math/mtrxmath/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-07 16:41:00 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-07 16:41:00 +0000
commit0ebb8e91940e2944443be3b4a54fa6b294af1972 (patch)
tree98d5377cd0fb65c330db6344f84882b50d01d1db /math/mtrxmath/Makefile
parentabbf5f79157616aa03c499fd787910c4e2b87099 (diff)
downloadports-0ebb8e91940e2944443be3b4a54fa6b294af1972.tar.gz
ports-0ebb8e91940e2944443be3b4a54fa6b294af1972.zip
Notes
Diffstat (limited to 'math/mtrxmath/Makefile')
-rw-r--r--math/mtrxmath/Makefile24
1 files changed, 14 insertions, 10 deletions
diff --git a/math/mtrxmath/Makefile b/math/mtrxmath/Makefile
index 8f5914fb2a23..1f5f594cb73e 100644
--- a/math/mtrxmath/Makefile
+++ b/math/mtrxmath/Makefile
@@ -5,21 +5,25 @@
# $FreeBSD$
#
-PORTNAME= mtrxmath
-PORTVERSION= 0.9.3
-PORTREVISION= 1
-CATEGORIES= math
-MASTER_SITES= http://www.angelfire.com/linux/linuxjeff/mtrxmath/files/
+PORTNAME= mtrxmath
+PORTVERSION= 1.0.2
+CATEGORIES= math
+MASTER_SITES= http://www.angelfire.com/linux/linuxjeff/mtrxmath/files/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= A small tool for matrix mathemetics
-USE_GETOPT_LONG=yes
-MAKE_ENV= CPPFLAGS="${CPPFLAGS}" \
- LDFLAGS="${LDFLAGS}"
+USE_GETOPT_LONG= yes
+MAKE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+PORTDOCS= README
+PLIST_FILES= bin/mtrxmath
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mtrxmath ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/README.mtrxmath
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
.include <bsd.port.mk>