aboutsummaryrefslogtreecommitdiff
path: root/math/mupad/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-10-28 17:19:31 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-10-28 17:19:31 +0000
commit4d409c35da110155b3d9b4c1c62d9d7d9dffbccd (patch)
tree1cd3028752cff520704e01d5446c062d8dfefcb7 /math/mupad/Makefile
parent177172cf3b83da99efec7ccde77909598b582c37 (diff)
downloadports-4d409c35da110155b3d9b4c1c62d9d7d9dffbccd.tar.gz
ports-4d409c35da110155b3d9b4c1c62d9d7d9dffbccd.zip
Notes
Diffstat (limited to 'math/mupad/Makefile')
-rw-r--r--math/mupad/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/math/mupad/Makefile b/math/mupad/Makefile
index b8ed5b187878..215709ef5292 100644
--- a/math/mupad/Makefile
+++ b/math/mupad/Makefile
@@ -6,16 +6,18 @@
#
PORTNAME= mupad
-PORTVERSION= 2.5.0
+PORTVERSION= 2.5.1
CATEGORIES= math linux
MASTER_SITES= ftp://ftp.mupad.de/MuPAD/distrib/unix/ \
ftp://archives.cs.ehime-u.ac.jp/pub/MuPAD/distrib/unix/ \
ftp://ftp.uni-paderborn.de/pub/MuPAD/distrib/unix/
-DISTFILES= bin_linux_scilab_250.tgz share_250.tgz
+DISTFILES= bin_linux_scilab_251.tgz share_251.tgz
DIST_SUBDIR= mupad
MAINTAINER= chat95@mbox.kyoto-inet.or.jp
+RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXm.so.2:${PORTSDIR}/x11-toolkits/linux-openmotif
+
NO_CDROM= "unsure to sell for profit"
USE_LINUX= yes
@@ -36,12 +38,12 @@ do-install:
${RM} -rf ${WRKSRC}/packages/scilab/linux
${RM} -rf ${WRKSRC}/packages/scilab/solaris
${TAR} cf - -C ${WRKSRC}/linux . | ${TAR} xf - -C ${PREFIX}/mupad/freebsd
- ${TAR} --exclude man1 --exclude mann -cf - -C ${WRKSRC}/share . | ${TAR} xf - -C ${PREFIX}/mupad/share
+ ${TAR} --exclude doc --exclude man1 --exclude mann -cf - -C ${WRKSRC}/share . | ${TAR} xf - -C ${PREFIX}/mupad/share
${TAR} -cf - -C ${WRKSRC}/packages . | ${TAR} xf - -C ${PREFIX}/mupad/packages
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/mupad
${INSTALL_DATA} ${WRKSRC}/INSTALL ${PREFIX}/mupad
${INSTALL_DATA} ${WRKSRC}/LICENSE ${PREFIX}/mupad
-.for d in mupad mmg mxdvi mxmupad mxvcam version20
+.for d in mmg mupad mxdvi mxmupad mxvcam
brandelf -t Linux ${PREFIX}/mupad/freebsd/bin/$d
.endfor
@@ -51,6 +53,11 @@ do-install:
.endfor
.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/mupad/share/doc
+ ${TAR} cf - -C ${WRKSRC}/share/doc --exclude man1 --exclude mann . | ${TAR} xf - -C ${PREFIX}/mupad/share/doc
+.endif
+
post-install:
@${SED} -e 's,/usr/local,${PREFIX},g' ${PKGMESSAGE}