aboutsummaryrefslogtreecommitdiff
path: root/math/muparser/Makefile
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2017-03-07 00:06:43 +0000
committerJason E. Hale <jhale@FreeBSD.org>2017-03-07 00:06:43 +0000
commit6c2d9007d520f0240baf0c9f4e640b202fedba9c (patch)
tree75f4b564266d3a2e215575cae937faa28941a53e /math/muparser/Makefile
parentdb40a4a04e2d1395737ecf0c98d224a11765c2a5 (diff)
downloadports-6c2d9007d520f0240baf0c9f4e640b202fedba9c.tar.gz
ports-6c2d9007d520f0240baf0c9f4e640b202fedba9c.zip
Notes
Diffstat (limited to 'math/muparser/Makefile')
-rw-r--r--math/muparser/Makefile44
1 files changed, 22 insertions, 22 deletions
diff --git a/math/muparser/Makefile b/math/muparser/Makefile
index 3e55217a5240..79d4d401c401 100644
--- a/math/muparser/Makefile
+++ b/math/muparser/Makefile
@@ -2,53 +2,53 @@
# $FreeBSD$
PORTNAME= muparser
-PORTVERSION= 2.2.3
+PORTVERSION= 2.2.5
+DISTVERSIONPREFIX= v
CATEGORIES= math devel
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Version%20${PORTVERSION}
-DISTNAME= ${PORTNAME}_v${PORTVERSION:S/./_/g}
MAINTAINER= nivit@FreeBSD.org
COMMENT= Mathematical expressions parser library written in C++
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/License.txt
-ALL_TARGET= lib
-
-DOCS_CONFIGURE_ON= --docdir=${DOCSDIR}
+USE_GITHUB= yes
+GH_ACCOUNT= beltoforion
-EXAMPLES_CONFIGURE_ENABLE= samples
-EXAMPLES_ALL_TARGET= samples
+USES= dos2unix pathfix
+USE_LDCONFIG= yes
+ALL_TARGET= lib
GNU_CONFIGURE= yes
-
# otherwise it fails to build when the EXAMPLES option is ON
-MAKE_JOBS_UNSAFE=yes
-
-OPTIONS_DEFINE= DOCS EXAMPLES
+MAKE_JOBS_UNSAFE= yes
-USE_LDCONFIG= yes
-USES= pathfix zip
+OPTIONS_DEFINE= DOXYGEN EXAMPLES
-.include <bsd.port.pre.mk>
+DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen \
+ dot:graphics/graphviz
+DOXYGEN_ALL_TARGET= documentation
+DOXYGEN_PORTDOCS= *
+# PORTDOCS macro won't work if NOPORTDOCS is defined or if DOCS is disabled
+DOXYGEN_IMPLIES= DOCS
+.undef NOPORTDOCS
-.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
-CFLAGS+= -fPIC
-.endif
+EXAMPLES_CONFIGURE_ENABLE= samples
+EXAMPLES_ALL_TARGET= samples
post-patch:
@${REINPLACE_CMD} -E 's,^(CXXFLAGS|LDFLAGS) = ,\1 ?= ,g' \
${WRKSRC}/Makefile.in
-post-install:
+post-install-DOXYGEN-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/docs/html && \
${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
-.if ${PORT_OPTIONS:MEXAMPLES}
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
(cd ${WRKSRC}/samples/example1 && \
${INSTALL_PROGRAM} example1 ${STAGEDIR}${EXAMPLESDIR} && \
${INSTALL_DATA} example1.cpp ${STAGEDIR}${EXAMPLESDIR})
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>