aboutsummaryrefslogtreecommitdiff
path: root/math/muparser
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2014-07-07 02:42:22 +0000
committerNicola Vitale <nivit@FreeBSD.org>2014-07-07 02:42:22 +0000
commitacce37229623179e602a10bf21d3098c6adc9a22 (patch)
tree06c35aff13e2363ee508c2c74cc7a9b0d6e171a6 /math/muparser
parentf668f88d3964c30527a738fbd5cf9e3e254c8b11 (diff)
downloadports-acce37229623179e602a10bf21d3098c6adc9a22.tar.gz
ports-acce37229623179e602a10bf21d3098c6adc9a22.zip
Notes
Diffstat (limited to 'math/muparser')
-rw-r--r--math/muparser/Makefile45
-rw-r--r--math/muparser/distinfo4
-rw-r--r--math/muparser/pkg-descr3
-rw-r--r--math/muparser/pkg-plist30
4 files changed, 40 insertions, 42 deletions
diff --git a/math/muparser/Makefile b/math/muparser/Makefile
index af0838235f82..3e55217a5240 100644
--- a/math/muparser/Makefile
+++ b/math/muparser/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= muparser
-PORTVERSION= 2.2.0
+PORTVERSION= 2.2.3
CATEGORIES= math devel
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Version%20${PORTVERSION}
DISTNAME= ${PORTNAME}_v${PORTVERSION:S/./_/g}
@@ -12,38 +12,43 @@ COMMENT= Mathematical expressions parser library written in C++
LICENSE= MIT
-USES= pathfix gmake zip
+ALL_TARGET= lib
+
+DOCS_CONFIGURE_ON= --docdir=${DOCSDIR}
+
+EXAMPLES_CONFIGURE_ENABLE= samples
+EXAMPLES_ALL_TARGET= samples
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --enable-shared=no
-.if defined(NOPORTEXAMPLES)
-CONFIGURE_ARGS+= --enable-samples=no
-.endif
-.if !defined(NOPORTDOCS)
-CONFIGURE_ARGS+= --docdir=${DOCSDIR}
-.endif
-NO_STAGE= yes
+# otherwise it fails to build when the EXAMPLES option is ON
+MAKE_JOBS_UNSAFE=yes
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+USE_LDCONFIG= yes
+USES= pathfix zip
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
CFLAGS+= -fPIC
.endif
-# taken from audio/taglib
post-patch:
@${REINPLACE_CMD} -E 's,^(CXXFLAGS|LDFLAGS) = ,\1 ?= ,g' \
${WRKSRC}/Makefile.in
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR} && \
- cd ${WRKSRC}/docs/html && \
- ${COPYTREE_SHARE} . ${DOCSDIR}
-.endif
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR} && \
- cd ${WRKSRC}/samples && \
- ${COPYTREE_SHARE} . ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/docs/html && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
+
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/samples/example1 && \
+ ${INSTALL_PROGRAM} example1 ${STAGEDIR}${EXAMPLESDIR} && \
+ ${INSTALL_DATA} example1.cpp ${STAGEDIR}${EXAMPLESDIR})
.endif
.include <bsd.port.post.mk>
diff --git a/math/muparser/distinfo b/math/muparser/distinfo
index c57bc5c64fd4..aa2d2fa3d2e3 100644
--- a/math/muparser/distinfo
+++ b/math/muparser/distinfo
@@ -1,2 +1,2 @@
-SHA256 (muparser_v2_2_0.zip) = 3f543c49594dc77536049e837436ad8562a23fcfdb28150f3a63ab5369b77fb5
-SIZE (muparser_v2_2_0.zip) = 1504870
+SHA256 (muparser_v2_2_3.zip) = dfe831b69392ab0b1eb59d3601b7b1575554a85057cf2f234f64f930c4148902
+SIZE (muparser_v2_2_3.zip) = 1481359
diff --git a/math/muparser/pkg-descr b/math/muparser/pkg-descr
index cdfd4084a17e..c3c5a8b45876 100644
--- a/math/muparser/pkg-descr
+++ b/math/muparser/pkg-descr
@@ -2,5 +2,4 @@ muParser is an extensible high performance math parser library written in C++.
It is based on transforming an expression into a bytecode and precalculating
constant parts of it.
-Author: Ingo Berg <ingo_berg@gmx.de>
-WWW: http://muparser.beltoforion.de/
+WWW: http://muparser.beltoforion.de/
diff --git a/math/muparser/pkg-plist b/math/muparser/pkg-plist
index cc365a99d45b..7a2f5476415f 100644
--- a/math/muparser/pkg-plist
+++ b/math/muparser/pkg-plist
@@ -12,7 +12,9 @@ include/muParserTemplateMagic.h
include/muParserTest.h
include/muParserToken.h
include/muParserTokenReader.h
-lib/libmuparser.a
+lib/libmuparser.so
+lib/libmuparser.so.2
+lib/libmuparser.so.2.2.3
libdata/pkgconfig/muparser.pc
%%PORTDOCS%%%%DOCSDIR%%/images/api.png
%%PORTDOCS%%%%DOCSDIR%%/images/api_dark.png
@@ -89,20 +91,12 @@ libdata/pkgconfig/muparser.pc
%%PORTDOCS%%%%DOCSDIR%%/sources/mup_version_meta.html
%%PORTDOCS%%%%DOCSDIR%%/sources/navigation.html
%%PORTDOCS%%%%DOCSDIR%%/style/formate.css
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/example1
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1/example1.cpp
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example2/Readme.txt
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example2/example2.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example2/muparser32.dll
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example2/muparser64.dll
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example2/muparserd32.dll
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example2/muparserd64.dll
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/example2
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/example1
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/style
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/sources
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/script
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/misc
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/images
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1.cpp
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%/images
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%/misc
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%/script
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%/sources
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%/style
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%