aboutsummaryrefslogtreecommitdiff
path: root/math/naturalmath/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-12-03 06:20:00 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-12-03 06:20:00 +0000
commit93afc658ba8549898ba819c348a822edf65a0c54 (patch)
tree9ed1070c6504ff10fbec1dd421231f182d32aa32 /math/naturalmath/Makefile
parent6ce2153e2589e52f42b70e93e999f58ea9c3150d (diff)
downloadports-93afc658ba8549898ba819c348a822edf65a0c54.tar.gz
ports-93afc658ba8549898ba819c348a822edf65a0c54.zip
Notes
Diffstat (limited to 'math/naturalmath/Makefile')
-rw-r--r--math/naturalmath/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/math/naturalmath/Makefile b/math/naturalmath/Makefile
new file mode 100644
index 000000000000..ff58fdcca272
--- /dev/null
+++ b/math/naturalmath/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: naturalmath
+# Date created: 1 November 2001
+# Whom: Stephen Montgomery-Smith
+#
+# $FreeBSD$
+#
+
+PORTNAME= naturalmath
+PORTVERSION= 0.5
+CATEGORIES= math
+MASTER_SITES= http://www.math.missouri.edu/~stephen/naturalmath/
+
+MAINTAINER= stephen@math.missouri.edu
+
+BUILD_DEPENDS= latex:${PORTSDIR}/print/teTeX
+
+USE_PERL5= yes
+
+post-patch:
+ @${PERL} -pi -e 's,^#!/usr/bin/perl,#!${PERL},' ${WRKSRC}/naturalmath
+
+do-build:
+ (cd ${WRKSRC}; ./naturalmath tutor.nat; \
+ ${LOCALBASE}/bin/latex tutor; ${LOCALBASE}/bin/latex tutor; \
+ ${LOCALBASE}/bin/dvips tutor -o tutor.ps)
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/naturalmath ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/install.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/tutor.nat ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/tutor.tex ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/tutor.dvi ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/tutor.ps ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/naturalmath.cgi ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>