aboutsummaryrefslogtreecommitdiff
path: root/math/netcdf
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-06 14:16:24 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-06 14:16:24 +0000
commit857e094afe4f012e4bca5f4e082c102f5960387b (patch)
treec95fa0702dd7209a2988401c7ff21e45e4a66cc3 /math/netcdf
parentd7896d335fea2aec52950169a86206063cdee03a (diff)
downloadports-857e094afe4f012e4bca5f4e082c102f5960387b.tar.gz
ports-857e094afe4f012e4bca5f4e082c102f5960387b.zip
Notes
Diffstat (limited to 'math/netcdf')
-rw-r--r--math/netcdf/Makefile8
-rw-r--r--math/netcdf/files/patch-ncvalues.h20
2 files changed, 21 insertions, 7 deletions
diff --git a/math/netcdf/Makefile b/math/netcdf/Makefile
index 1270af16e61c..13a6bf93e48d 100644
--- a/math/netcdf/Makefile
+++ b/math/netcdf/Makefile
@@ -24,12 +24,6 @@ INSTALLS_SHLIB= yes
MAN1= ncdump.1 ncgen.1
MAN3= netcdf.3 netcdf.3f
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502000
-BROKEN= "Does not compile"
-.endif
-
post-build:
@(cd ${WRKSRC}/libsrc && \
${SETENV} ${MAKE_ENV} ${MAKE} linux_shared_library)
@@ -42,4 +36,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/cxx/libnetcdf_c++.so ${PREFIX}/lib/libnetcdf_c++.so.1
${LN} -sf libnetcdf_c++.so.1 ${PREFIX}/lib/libnetcdf_c++.so
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/netcdf/files/patch-ncvalues.h b/math/netcdf/files/patch-ncvalues.h
new file mode 100644
index 000000000000..1988e2b8746d
--- /dev/null
+++ b/math/netcdf/files/patch-ncvalues.h
@@ -0,0 +1,20 @@
+--- cxx/ncvalues.h.orig Thu Oct 29 02:10:16 1998
++++ cxx/ncvalues.h Thu Feb 5 20:51:02 2004
+@@ -14,7 +14,7 @@
+ #ifdef STRSTREAM_H_SPEC
+ # include STRSTREAM_H_SPEC
+ #else
+-# include <strstream.h>
++# include <strstream>
+ #endif
+ #include <limits.h>
+ #include <string.h>
+@@ -220,7 +220,7 @@
+ char* NcVal(TYPE)::as_string( long n ) const \
+ { \
+ char* s = new char[32]; \
+- ostrstream ostr(s, sizeof(s)); \
++ std::ostrstream ostr(s, sizeof(s)); \
+ ostr << the_values[n] << ends; \
+ return s; \
+ }