aboutsummaryrefslogtreecommitdiff
path: root/math/nfft/Makefile
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2017-12-03 23:12:34 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2017-12-03 23:12:34 +0000
commit646a05f6f8120714655b2ef6d75e60047694b072 (patch)
treeb03853dfc62e7d499fb3895376fcd1a661b1fade /math/nfft/Makefile
parentcdcd1b22af24bf9656d4740e2a0e8e407f08397a (diff)
downloadports-646a05f6f8120714655b2ef6d75e60047694b072.tar.gz
ports-646a05f6f8120714655b2ef6d75e60047694b072.zip
Notes
Diffstat (limited to 'math/nfft/Makefile')
-rw-r--r--math/nfft/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/math/nfft/Makefile b/math/nfft/Makefile
new file mode 100644
index 000000000000..adcbcf6aea63
--- /dev/null
+++ b/math/nfft/Makefile
@@ -0,0 +1,42 @@
+# $FreeBSD$
+
+PORTNAME= nfft
+PORTVERSION= 3.3.2
+CATEGORIES= math
+
+MAINTAINER= mike.d.ft402@gmail.com
+COMMENT= Nonequispaced fast Fourier transform
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libfftw3.so:math/fftw3
+BUILD_DEPENDS= bash:shells/bash
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-fftw3=${PREFIX}
+USES= autoreconf libtool
+USE_AUTOTOOLS= autoconf:env
+USE_LDCONFIG= yes
+TEST_TARGET= check
+
+USE_GITHUB= yes
+GH_ACCOUNT= NFFT
+
+OPTIONS_DEFINE= DOXYGEN
+OPTIONS_SUB= DOXYGEN
+
+DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
+DOXYGEN_ALL_TARGET= all doc
+
+.include <bsd.port.pre.mk>
+
+post-extract:
+ ${CP} ${PATCHDIR}/cpow.c ${WRKSRC}/3rdparty
+
+pre-configure:
+ cd ${WRKSRC} && bash ./bootstrap.sh
+
+do-configure:
+ cd ${WRKSRC} && bash ${WRKSRC}/configure ${CONFIGURE_ARGS}
+
+.include <bsd.port.post.mk>