aboutsummaryrefslogtreecommitdiff
path: root/math/ntl/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-19 08:23:58 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-19 08:23:58 +0000
commitcdfa9aa633146c372914aa2873878fc4cb409c1b (patch)
tree0fc667ff2746d04c4411fa67c0ee0c4d3046e3d0 /math/ntl/Makefile
parent2853ffe4ffae494f6cca780ee9bcf00ba035e14a (diff)
downloadports-cdfa9aa633146c372914aa2873878fc4cb409c1b.tar.gz
ports-cdfa9aa633146c372914aa2873878fc4cb409c1b.zip
Notes
Diffstat (limited to 'math/ntl/Makefile')
-rw-r--r--math/ntl/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/math/ntl/Makefile b/math/ntl/Makefile
index 3967240fae42..150f2911d664 100644
--- a/math/ntl/Makefile
+++ b/math/ntl/Makefile
@@ -11,7 +11,7 @@ COMMENT= Victor Shoup's Number Theory Library
# ntl is faster with libgmp4, but you can disable it
.if !defined(WITHOUT_GMP)
-LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
+LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
CONFIGURE_ARGS= NTL_GMP_LIP=on
.endif
@@ -30,16 +30,15 @@ CFLAGS+= -fPIC
WRKSRC= ${WRKDIR}/${DISTNAME}/src
MAKEFILE= makefile
-NO_STAGE= yes
do-install:
- ${MKDIR} ${PREFIX}/include/NTL
- ${INSTALL_DATA} ${WRKSRC}/../include/NTL/* ${PREFIX}/include/NTL/
- ${INSTALL_DATA} ${WRKSRC}/ntl.a ${PREFIX}/lib/libntl.a
+ ${MKDIR} ${STAGEDIR}${PREFIX}/include/NTL
+ ${INSTALL_DATA} ${WRKSRC}/../include/NTL/* ${STAGEDIR}${PREFIX}/include/NTL/
+ ${INSTALL_DATA} ${WRKSRC}/ntl.a ${STAGEDIR}${PREFIX}/lib/libntl.a
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/../doc/* ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/../doc/* ${STAGEDIR}${DOCSDIR}
.endif
test: build