aboutsummaryrefslogtreecommitdiff
path: root/math/ntl
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-06-27 20:18:22 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-06-27 20:18:22 +0000
commit54d34b2deb9414c980afb53f144cfffa05ada76d (patch)
tree013c4ebf2f46c3dd1ffd4e820330a0fadf642477 /math/ntl
parentdafa834bbaee7b2ddc579720d05a092f51e01a11 (diff)
downloadports-54d34b2deb9414c980afb53f144cfffa05ada76d.tar.gz
ports-54d34b2deb9414c980afb53f144cfffa05ada76d.zip
Notes
Diffstat (limited to 'math/ntl')
-rw-r--r--math/ntl/Makefile31
-rw-r--r--math/ntl/distinfo4
-rw-r--r--math/ntl/pkg-descr2
-rw-r--r--math/ntl/pkg-plist166
4 files changed, 102 insertions, 101 deletions
diff --git a/math/ntl/Makefile b/math/ntl/Makefile
index 1a4f34aa9912..38fb38ac054b 100644
--- a/math/ntl/Makefile
+++ b/math/ntl/Makefile
@@ -6,41 +6,40 @@
#
PORTNAME= ntl
-PORTVERSION= 5.3.1
+PORTVERSION= 5.4
CATEGORIES= math
MASTER_SITES= http://www.shoup.net/ntl/
MAINTAINER= matthiasb@acm.org
COMMENT= Victor Shoup's Number Theory Library
+# ntl is faster with libgmp4, but you can disable it
+.if !defined(WITHOUT_GMP)
LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
+.endif
HAS_CONFIGURE= yes
CONFIGURE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" \
- CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
- NTL_GMP_LIP=on GMP_PREFIX="${LOCALBASE}"
-CONFIGURE_WRKSRC= ${BUILD_WRKSRC}
+ CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" NTL_STD_CXX=on
-BUILD_WRKSRC= ${WRKSRC}/src
-MAKEFILE= makefile
+.if !defined(WITHOUT_GMP)
+CONFIGURE_ARGS+= NTL_GMP_LIP=on GMP_PREFIX="${LOCALBASE}"
+.endif
-# Build with WITH_ISO_CXX=yes if you want to use the "Standard C++"
-# version of NTL. In this version, all of NTL is "wrapped" inside
-# the namespace NTL, and are no longer directly accessible---you must
-# either use explicit qualification, or using directives, or
-# using declarations.
+CONFIGURE_WRKSRC= ${BUILD_WRKSRC}
-.if defined(WITH_ISO_CXX)
-CONFIGURE_ARGS+= NTL_STD_CXX=on
-.endif
+BUILD_WRKSRC= ${WRKSRC}/src
+MAKEFILE= makefile
do-install:
${MKDIR} ${PREFIX}/include/NTL
${INSTALL_DATA} ${WRKSRC}/include/NTL/* ${PREFIX}/include/NTL/
${INSTALL_DATA} ${BUILD_WRKSRC}/ntl.a ${PREFIX}/lib/libntl.a
+
+post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/NTL
- ${INSTALL_DATA} ${WRKSRC}/doc/* ${PREFIX}/share/doc/NTL/
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/math/ntl/distinfo b/math/ntl/distinfo
index 7e8c8a41bfba..764a1f0a9453 100644
--- a/math/ntl/distinfo
+++ b/math/ntl/distinfo
@@ -1,2 +1,2 @@
-MD5 (ntl-5.3.1.tar.gz) = 07e28598b9b50197b36723f7f536e293
-SIZE (ntl-5.3.1.tar.gz) = 669649
+MD5 (ntl-5.4.tar.gz) = 1d2a683ecbc12cdf03bf92dbc97c0dd4
+SIZE (ntl-5.4.tar.gz) = 681173
diff --git a/math/ntl/pkg-descr b/math/ntl/pkg-descr
index f4eaf750512d..827f7f92eeb8 100644
--- a/math/ntl/pkg-descr
+++ b/math/ntl/pkg-descr
@@ -8,6 +8,8 @@ by Victor Shoup. It provides objects and methods for
- vectors and matrices over extensions
- finite rings
+Unless you define WITHOUT_GMP, NTL requires libgmp4.
+
WWW: http://www.shoup.net/
Matthias Bauer
diff --git a/math/ntl/pkg-plist b/math/ntl/pkg-plist
index 8c50706b28df..2507b2a6c9d4 100644
--- a/math/ntl/pkg-plist
+++ b/math/ntl/pkg-plist
@@ -1,4 +1,3 @@
-@comment $FreeBSD$
include/NTL/FFT.h
include/NTL/FacVec.h
include/NTL/GF2.h
@@ -11,6 +10,7 @@ include/NTL/GF2XVec.h
include/NTL/HNF.h
include/NTL/LLL.h
include/NTL/RR.h
+include/NTL/SPMM_ASM.h
include/NTL/WordVector.h
include/NTL/ZZ.h
include/NTL/ZZVec.h
@@ -89,86 +89,86 @@ include/NTL/vector.h
include/NTL/version.h
include/NTL/xdouble.h
lib/libntl.a
-%%PORTDOCS%%share/doc/NTL/GF2.txt
-%%PORTDOCS%%share/doc/NTL/GF2E.txt
-%%PORTDOCS%%share/doc/NTL/GF2EX.txt
-%%PORTDOCS%%share/doc/NTL/GF2EXFactoring.txt
-%%PORTDOCS%%share/doc/NTL/GF2X.txt
-%%PORTDOCS%%share/doc/NTL/GF2XFactoring.txt
-%%PORTDOCS%%share/doc/NTL/GF2XVec.txt
-%%PORTDOCS%%share/doc/NTL/HNF.txt
-%%PORTDOCS%%share/doc/NTL/LLL.txt
-%%PORTDOCS%%share/doc/NTL/RR.txt
-%%PORTDOCS%%share/doc/NTL/ZZ.txt
-%%PORTDOCS%%share/doc/NTL/ZZVec.txt
-%%PORTDOCS%%share/doc/NTL/ZZX.txt
-%%PORTDOCS%%share/doc/NTL/ZZXFactoring.txt
-%%PORTDOCS%%share/doc/NTL/ZZ_p.txt
-%%PORTDOCS%%share/doc/NTL/ZZ_pE.txt
-%%PORTDOCS%%share/doc/NTL/ZZ_pEX.txt
-%%PORTDOCS%%share/doc/NTL/ZZ_pEXFactoring.txt
-%%PORTDOCS%%share/doc/NTL/ZZ_pX.txt
-%%PORTDOCS%%share/doc/NTL/ZZ_pXFactoring.txt
-%%PORTDOCS%%share/doc/NTL/arrow1.gif
-%%PORTDOCS%%share/doc/NTL/arrow2.gif
-%%PORTDOCS%%share/doc/NTL/arrow3.gif
-%%PORTDOCS%%share/doc/NTL/config.txt
-%%PORTDOCS%%share/doc/NTL/conversions.txt
-%%PORTDOCS%%share/doc/NTL/copying.txt
-%%PORTDOCS%%share/doc/NTL/flags.txt
-%%PORTDOCS%%share/doc/NTL/lzz_p.txt
-%%PORTDOCS%%share/doc/NTL/lzz_pE.txt
-%%PORTDOCS%%share/doc/NTL/lzz_pEX.txt
-%%PORTDOCS%%share/doc/NTL/lzz_pEXFactoring.txt
-%%PORTDOCS%%share/doc/NTL/lzz_pX.txt
-%%PORTDOCS%%share/doc/NTL/lzz_pXFactoring.txt
-%%PORTDOCS%%share/doc/NTL/mat_GF2.txt
-%%PORTDOCS%%share/doc/NTL/mat_GF2E.txt
-%%PORTDOCS%%share/doc/NTL/mat_RR.txt
-%%PORTDOCS%%share/doc/NTL/mat_ZZ.txt
-%%PORTDOCS%%share/doc/NTL/mat_ZZ_p.txt
-%%PORTDOCS%%share/doc/NTL/mat_ZZ_pE.txt
-%%PORTDOCS%%share/doc/NTL/mat_lzz_p.txt
-%%PORTDOCS%%share/doc/NTL/mat_lzz_pE.txt
-%%PORTDOCS%%share/doc/NTL/mat_poly_ZZ.txt
-%%PORTDOCS%%share/doc/NTL/mat_poly_ZZ_p.txt
-%%PORTDOCS%%share/doc/NTL/mat_poly_lzz_p.txt
-%%PORTDOCS%%share/doc/NTL/matrix.txt
-%%PORTDOCS%%share/doc/NTL/names.txt
-%%PORTDOCS%%share/doc/NTL/pair.txt
-%%PORTDOCS%%share/doc/NTL/quad_float.txt
-%%PORTDOCS%%share/doc/NTL/sedscript.txt
-%%PORTDOCS%%share/doc/NTL/tools.txt
-%%PORTDOCS%%share/doc/NTL/tour-ack.html
-%%PORTDOCS%%share/doc/NTL/tour-changes.html
-%%PORTDOCS%%share/doc/NTL/tour-ex1.html
-%%PORTDOCS%%share/doc/NTL/tour-ex2.html
-%%PORTDOCS%%share/doc/NTL/tour-ex3.html
-%%PORTDOCS%%share/doc/NTL/tour-ex4.html
-%%PORTDOCS%%share/doc/NTL/tour-ex5.html
-%%PORTDOCS%%share/doc/NTL/tour-ex6.html
-%%PORTDOCS%%share/doc/NTL/tour-examples.html
-%%PORTDOCS%%share/doc/NTL/tour-gmp.html
-%%PORTDOCS%%share/doc/NTL/tour-impl.html
-%%PORTDOCS%%share/doc/NTL/tour-intro.html
-%%PORTDOCS%%share/doc/NTL/tour-modules.html
-%%PORTDOCS%%share/doc/NTL/tour-roadmap.html
-%%PORTDOCS%%share/doc/NTL/tour-stdcxx.html
-%%PORTDOCS%%share/doc/NTL/tour-struct.html
-%%PORTDOCS%%share/doc/NTL/tour-time.html
-%%PORTDOCS%%share/doc/NTL/tour-unix.html
-%%PORTDOCS%%share/doc/NTL/tour-win.html
-%%PORTDOCS%%share/doc/NTL/tour.html
-%%PORTDOCS%%share/doc/NTL/vec_GF2.txt
-%%PORTDOCS%%share/doc/NTL/vec_GF2E.txt
-%%PORTDOCS%%share/doc/NTL/vec_RR.txt
-%%PORTDOCS%%share/doc/NTL/vec_ZZ.txt
-%%PORTDOCS%%share/doc/NTL/vec_ZZ_p.txt
-%%PORTDOCS%%share/doc/NTL/vec_ZZ_pE.txt
-%%PORTDOCS%%share/doc/NTL/vec_lzz_p.txt
-%%PORTDOCS%%share/doc/NTL/vec_lzz_pE.txt
-%%PORTDOCS%%share/doc/NTL/vector.txt
-%%PORTDOCS%%share/doc/NTL/version.txt
-%%PORTDOCS%%share/doc/NTL/xdouble.txt
+%%PORTDOCS%%%%DOCSDIR%%/GF2.txt
+%%PORTDOCS%%%%DOCSDIR%%/GF2E.txt
+%%PORTDOCS%%%%DOCSDIR%%/GF2EX.txt
+%%PORTDOCS%%%%DOCSDIR%%/GF2EXFactoring.txt
+%%PORTDOCS%%%%DOCSDIR%%/GF2X.txt
+%%PORTDOCS%%%%DOCSDIR%%/GF2XFactoring.txt
+%%PORTDOCS%%%%DOCSDIR%%/GF2XVec.txt
+%%PORTDOCS%%%%DOCSDIR%%/HNF.txt
+%%PORTDOCS%%%%DOCSDIR%%/LLL.txt
+%%PORTDOCS%%%%DOCSDIR%%/RR.txt
+%%PORTDOCS%%%%DOCSDIR%%/ZZ.txt
+%%PORTDOCS%%%%DOCSDIR%%/ZZVec.txt
+%%PORTDOCS%%%%DOCSDIR%%/ZZX.txt
+%%PORTDOCS%%%%DOCSDIR%%/ZZXFactoring.txt
+%%PORTDOCS%%%%DOCSDIR%%/ZZ_p.txt
+%%PORTDOCS%%%%DOCSDIR%%/ZZ_pE.txt
+%%PORTDOCS%%%%DOCSDIR%%/ZZ_pEX.txt
+%%PORTDOCS%%%%DOCSDIR%%/ZZ_pEXFactoring.txt
+%%PORTDOCS%%%%DOCSDIR%%/ZZ_pX.txt
+%%PORTDOCS%%%%DOCSDIR%%/ZZ_pXFactoring.txt
+%%PORTDOCS%%%%DOCSDIR%%/arrow1.gif
+%%PORTDOCS%%%%DOCSDIR%%/arrow2.gif
+%%PORTDOCS%%%%DOCSDIR%%/arrow3.gif
+%%PORTDOCS%%%%DOCSDIR%%/config.txt
+%%PORTDOCS%%%%DOCSDIR%%/conversions.txt
+%%PORTDOCS%%%%DOCSDIR%%/copying.txt
+%%PORTDOCS%%%%DOCSDIR%%/flags.txt
+%%PORTDOCS%%%%DOCSDIR%%/lzz_p.txt
+%%PORTDOCS%%%%DOCSDIR%%/lzz_pE.txt
+%%PORTDOCS%%%%DOCSDIR%%/lzz_pEX.txt
+%%PORTDOCS%%%%DOCSDIR%%/lzz_pEXFactoring.txt
+%%PORTDOCS%%%%DOCSDIR%%/lzz_pX.txt
+%%PORTDOCS%%%%DOCSDIR%%/lzz_pXFactoring.txt
+%%PORTDOCS%%%%DOCSDIR%%/mat_GF2.txt
+%%PORTDOCS%%%%DOCSDIR%%/mat_GF2E.txt
+%%PORTDOCS%%%%DOCSDIR%%/mat_RR.txt
+%%PORTDOCS%%%%DOCSDIR%%/mat_ZZ.txt
+%%PORTDOCS%%%%DOCSDIR%%/mat_ZZ_p.txt
+%%PORTDOCS%%%%DOCSDIR%%/mat_ZZ_pE.txt
+%%PORTDOCS%%%%DOCSDIR%%/mat_lzz_p.txt
+%%PORTDOCS%%%%DOCSDIR%%/mat_lzz_pE.txt
+%%PORTDOCS%%%%DOCSDIR%%/mat_poly_ZZ.txt
+%%PORTDOCS%%%%DOCSDIR%%/mat_poly_ZZ_p.txt
+%%PORTDOCS%%%%DOCSDIR%%/mat_poly_lzz_p.txt
+%%PORTDOCS%%%%DOCSDIR%%/matrix.txt
+%%PORTDOCS%%%%DOCSDIR%%/names.txt
+%%PORTDOCS%%%%DOCSDIR%%/pair.txt
+%%PORTDOCS%%%%DOCSDIR%%/quad_float.txt
+%%PORTDOCS%%%%DOCSDIR%%/sedscript.txt
+%%PORTDOCS%%%%DOCSDIR%%/tools.txt
+%%PORTDOCS%%%%DOCSDIR%%/tour-ack.html
+%%PORTDOCS%%%%DOCSDIR%%/tour-changes.html
+%%PORTDOCS%%%%DOCSDIR%%/tour-ex1.html
+%%PORTDOCS%%%%DOCSDIR%%/tour-ex2.html
+%%PORTDOCS%%%%DOCSDIR%%/tour-ex3.html
+%%PORTDOCS%%%%DOCSDIR%%/tour-ex4.html
+%%PORTDOCS%%%%DOCSDIR%%/tour-ex5.html
+%%PORTDOCS%%%%DOCSDIR%%/tour-ex6.html
+%%PORTDOCS%%%%DOCSDIR%%/tour-examples.html
+%%PORTDOCS%%%%DOCSDIR%%/tour-gmp.html
+%%PORTDOCS%%%%DOCSDIR%%/tour-impl.html
+%%PORTDOCS%%%%DOCSDIR%%/tour-intro.html
+%%PORTDOCS%%%%DOCSDIR%%/tour-modules.html
+%%PORTDOCS%%%%DOCSDIR%%/tour-roadmap.html
+%%PORTDOCS%%%%DOCSDIR%%/tour-stdcxx.html
+%%PORTDOCS%%%%DOCSDIR%%/tour-struct.html
+%%PORTDOCS%%%%DOCSDIR%%/tour-time.html
+%%PORTDOCS%%%%DOCSDIR%%/tour-unix.html
+%%PORTDOCS%%%%DOCSDIR%%/tour-win.html
+%%PORTDOCS%%%%DOCSDIR%%/tour.html
+%%PORTDOCS%%%%DOCSDIR%%/vec_GF2.txt
+%%PORTDOCS%%%%DOCSDIR%%/vec_GF2E.txt
+%%PORTDOCS%%%%DOCSDIR%%/vec_RR.txt
+%%PORTDOCS%%%%DOCSDIR%%/vec_ZZ.txt
+%%PORTDOCS%%%%DOCSDIR%%/vec_ZZ_p.txt
+%%PORTDOCS%%%%DOCSDIR%%/vec_ZZ_pE.txt
+%%PORTDOCS%%%%DOCSDIR%%/vec_lzz_p.txt
+%%PORTDOCS%%%%DOCSDIR%%/vec_lzz_pE.txt
+%%PORTDOCS%%%%DOCSDIR%%/vector.txt
+%%PORTDOCS%%%%DOCSDIR%%/version.txt
+%%PORTDOCS%%%%DOCSDIR%%/xdouble.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/NTL
-%%PORTDOCS%%@dirrm share/doc/NTL