aboutsummaryrefslogtreecommitdiff
path: root/math/ocaml-ocamlgraph/Makefile
diff options
context:
space:
mode:
authorJoseph Koshy <jkoshy@FreeBSD.org>2004-05-28 02:29:40 +0000
committerJoseph Koshy <jkoshy@FreeBSD.org>2004-05-28 02:29:40 +0000
commitdbb37b7e94aa3a2a8309293e90b4854556dbf96d (patch)
tree6d466a94317a83db7c34af1baf35e14132d73f3e /math/ocaml-ocamlgraph/Makefile
parent3ac32c4306cdfadd8ba025d77f2ac6bafeb889e4 (diff)
Notes
Diffstat (limited to 'math/ocaml-ocamlgraph/Makefile')
-rw-r--r--math/ocaml-ocamlgraph/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/math/ocaml-ocamlgraph/Makefile b/math/ocaml-ocamlgraph/Makefile
new file mode 100644
index 000000000000..b5045f5963f0
--- /dev/null
+++ b/math/ocaml-ocamlgraph/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: ocaml-ocamlgraph
+# Date created: 25 May 2004
+# Whom: Joseph Koshy <jkoshy@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ocamlgraph
+PORTVERSION= 0.70
+CATEGORIES= math
+MASTER_SITES= http://www.lri.fr/~filliatr/ftp/ocamlgraph/
+PKGNAMEPREFIX= ocaml-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= jkoshy@freebsd.org
+COMMENT= Graph manipulation library for OCaml
+
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
+RUN_DEPENDS= ocaml:${PORTSDIR}/lang/ocaml
+
+USE_GMAKE= yes
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS+= --prefix=${PREFIX}
+
+ALL_TARGET= all
+.ifndef NOPORTDOCS
+ALL_TARGET+= doc
+.endif
+
+.ifndef NOPORTDOCS
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/doc; ${INSTALL_DATA} * ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>