aboutsummaryrefslogtreecommitdiff
path: root/math/ocaml-ocamlgraph
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2009-06-26 12:32:44 +0000
committerJohan van Selst <johans@FreeBSD.org>2009-06-26 12:32:44 +0000
commit07fe54d31b2012e02e10d182be31a47e0b8721f5 (patch)
tree78445f1cabac5908d252e7db306a2baf9f6ff775 /math/ocaml-ocamlgraph
parentc19c33ab70db65b1a9344bcad1b9e15226c6a1a7 (diff)
downloadports-07fe54d31b2012e02e10d182be31a47e0b8721f5.tar.gz
ports-07fe54d31b2012e02e10d182be31a47e0b8721f5.zip
Notes
Diffstat (limited to 'math/ocaml-ocamlgraph')
-rw-r--r--math/ocaml-ocamlgraph/Makefile20
-rw-r--r--math/ocaml-ocamlgraph/distinfo6
-rw-r--r--math/ocaml-ocamlgraph/pkg-plist6
3 files changed, 26 insertions, 6 deletions
diff --git a/math/ocaml-ocamlgraph/Makefile b/math/ocaml-ocamlgraph/Makefile
index 85992ec656de..793c2881685c 100644
--- a/math/ocaml-ocamlgraph/Makefile
+++ b/math/ocaml-ocamlgraph/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ocamlgraph
-PORTVERSION= 1.0
+PORTVERSION= 1.1
CATEGORIES= math
MASTER_SITES= http://ocamlgraph.lri.fr/download/
PKGNAMEPREFIX= ocaml-
@@ -14,10 +14,13 @@ PKGNAMEPREFIX= ocaml-
MAINTAINER= johans@stack.nl
COMMENT= Graph manipulation library for OCaml
+OPTIONS= GUI "Include user programs: viewer and editor" off
+
USE_OCAML= yes
+USE_OCAML_FINDLIB= yes
USE_OCAML_LDCONFIG= yes
USE_GMAKE= yes
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
PLIST_SUB+= OCAML_LIBDIR="${OCAML_LIBDIR}"
@@ -26,6 +29,17 @@ ALL_TARGET= all
ALL_TARGET+= doc
PORTDOCS= *
+.include <bsd.port.pre.mk>
+
+.ifdef WITH_GUI
+BUILD_DEPENDS+= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
+RUN_DEPENDS+= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
+PLIST_SUB+= GUI=""
+.else
+CONFIGURE_ARGS+= LABLGTK2=no
+PLIST_SUB+= GUI="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/VIEWER_DIR. doc/d' ${WRKSRC}/Makefile.in
@@ -34,4 +48,4 @@ post-install:
cd ${WRKSRC}/doc; ${INSTALL_DATA} * ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/ocaml-ocamlgraph/distinfo b/math/ocaml-ocamlgraph/distinfo
index bdd6b52d9428..5c93992e13ed 100644
--- a/math/ocaml-ocamlgraph/distinfo
+++ b/math/ocaml-ocamlgraph/distinfo
@@ -1,3 +1,3 @@
-MD5 (ocamlgraph-1.0.tar.gz) = 65dfcab73bc15776f7547860a78d682a
-SHA256 (ocamlgraph-1.0.tar.gz) = 6fb6a752a08caa08e309dde8b6f32d71907b6ad2cf2d8edb0d9d2710c7918de6
-SIZE (ocamlgraph-1.0.tar.gz) = 193213
+MD5 (ocamlgraph-1.1.tar.gz) = 62cf4b0c273db2af1dbf4f8fac957bfc
+SHA256 (ocamlgraph-1.1.tar.gz) = 955e0bfbfda83e055b0cf0527af0b706c8f4a14f680d3a77be1e1e725e1cfb3f
+SIZE (ocamlgraph-1.1.tar.gz) = 195045
diff --git a/math/ocaml-ocamlgraph/pkg-plist b/math/ocaml-ocamlgraph/pkg-plist
index 5dccd896c1b3..956ba65201b6 100644
--- a/math/ocaml-ocamlgraph/pkg-plist
+++ b/math/ocaml-ocamlgraph/pkg-plist
@@ -1,3 +1,9 @@
+%%GUI%%bin/graph-viewer.byte
+%%GUI%%bin/graph-viewer.opt
+%%GUI%%bin/graph-viewer
+%%GUI%%bin/graph-editor.byte
+%%GUI%%bin/graph-editor.opt
+%%GUI%%bin/graph-editor
%%OCAML_LIBDIR%%/graph.a
%%OCAML_LIBDIR%%/graph.cma
%%OCAML_LIBDIR%%/graph.cmi