aboutsummaryrefslogtreecommitdiff
path: root/math/octave-devel/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-26 17:32:40 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-26 17:32:40 +0000
commitf87963630cbb4fc06b7cf8102af1187e3cedcc28 (patch)
tree7158ccd776cb2b435c150e53547766b60e175ed2 /math/octave-devel/Makefile
parentaa173afd0bd7a67b398bc7bb07843fe067d9a7f7 (diff)
downloadports-f87963630cbb4fc06b7cf8102af1187e3cedcc28.tar.gz
ports-f87963630cbb4fc06b7cf8102af1187e3cedcc28.zip
Notes
Diffstat (limited to 'math/octave-devel/Makefile')
-rw-r--r--math/octave-devel/Makefile58
1 files changed, 22 insertions, 36 deletions
diff --git a/math/octave-devel/Makefile b/math/octave-devel/Makefile
index 9f8ab015b360..1035777d5287 100644
--- a/math/octave-devel/Makefile
+++ b/math/octave-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= octave
-PORTVERSION= 2.1.63
+PORTVERSION= 2.1.71
CATEGORIES= math
MASTER_SITES= ftp://ftp.octave.org/pub/octave/bleeding-edge/ \
ftp://ftp.eos.hokudai.ac.jp/pub/GNU/misc/octave/bleeding-edge/
@@ -21,62 +21,48 @@ LIB_DEPENDS= fftw.2:${PORTSDIR}/math/fftw \
USE_BZIP2= yes
USE_PERL5_BUILD=yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= "Does not compile on FreeBSD 4.x"
-.else
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
+INFO= octave liboctave
+MAN1= octave.1 octave-bug.1 mkoctfile.1 octave-config.1
-.if ${PORTOBJFORMAT} == "elf"
-GNU_HOST= ${ARCH}-portbld-freebsd${OSREL}
-.else
-GNU_HOST= ${ARCH}-portbld-freebsdaout${OSREL}
-.endif
OCTAVE_VERSION= ${PORTVERSION}
+GNU_HOST= ${ARCH}-portbld-freebsd${OSREL}
PLIST_SUB= OCTAVE_VERSION=${OCTAVE_VERSION} GNU_HOST=${GNU_HOST}
-BLAS_LIBS= "-L${LOCALBASE}/lib -lf77blas -lcblas -latlas"
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-
-CONIGURE_ARGS= --host=${GNU_HOST} --with-fftw --with-blas=${BLAS_LIBS} \
- --with-lapack=-lalapack --enable-shared
+F77?= f77
-CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ F77="${F77}" \
FFLAGS="${FFLAGS}"
+CONFIGURE_ARGS= --host=${GNU_HOST} \
+ --with-blas="-L${LOCALBASE}/lib -lf77blas -lcblas -latlas" \
+ --with-lapack=-lalapack \
+ --enable-shared
+
+SUB_FILES= octave
+SUB_LIST= OCTAVE_VERSION="${OCTAVE_VERSION}"
+
+.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 400004
-CONFIGURE_ARGS+= --with-f2c
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
.endif
.if ${OSVERSION} < 500000
CONFIGURE_ARGS+= --disable-readline
.endif
-MAN1= octave.1 octave-bug.1 mkoctfile.1 octave-config.1
-
-post-extract:
- @${RM} -f ${WRKSRC}/doc/interpreter/octave.info*
- @${RM} -f ${WRKSRC}/doc/liboctave/liboctave.info*
post-install:
- @${SED} -e 's,%%PREFIX%%,${PREFIX},g ; \
- s,%%OCTAVE_VERSION%%,${OCTAVE_VERSION},g' \
- ${FILESDIR}/octave > ${WRKDIR}/octave
- ${RM} ${PREFIX}/bin/octave
${INSTALL_SCRIPT} ${WRKDIR}/octave ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/doc/liboctave/liboctave.info ${PREFIX}/info
- install-info --entry='* Octave: (octave). Interactive language for numerical computations.' $(PREFIX)/info/octave.info $(PREFIX)/info/dir
- install-info --entry='* LibOctave: (liboctave). C++ class library for Octave.' $(PREFIX)/info/liboctave.info $(PREFIX)/info/dir
-.ifndef NOPORTDOCS
+.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in faq/Octave-FAQ.ps interpreter/octave.ps liboctave/liboctave.ps \
refcard/refcard-a4.ps refcard/refcard-legal.ps refcard/refcard-letter.ps
- $(INSTALL_DATA) ${WRKSRC}/doc/${file} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
.endfor
.endif