aboutsummaryrefslogtreecommitdiff
path: root/math/octave-devel/Makefile
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2010-02-16 07:07:52 +0000
committerMaho Nakata <maho@FreeBSD.org>2010-02-16 07:07:52 +0000
commit20ff4437eef1eb5c1282e36aeb7dc6dcbce029d5 (patch)
tree6bbc3a27dcf4eb7ae5614ad717e0bb7fe5c0d04c /math/octave-devel/Makefile
parent1760aa0a37ee7459eab3e4de0d45f7310ef571c4 (diff)
downloadports-20ff4437eef1eb5c1282e36aeb7dc6dcbce029d5.tar.gz
ports-20ff4437eef1eb5c1282e36aeb7dc6dcbce029d5.zip
Notes
Diffstat (limited to 'math/octave-devel/Makefile')
-rw-r--r--math/octave-devel/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/math/octave-devel/Makefile b/math/octave-devel/Makefile
index a08c014a765d..a696ed2e9d76 100644
--- a/math/octave-devel/Makefile
+++ b/math/octave-devel/Makefile
@@ -44,7 +44,7 @@ MAN1= octave.1 octave-bug.1 mkoctfile.1 octave-config.1
USE_BLAS?= reference
-.if exists(${LOCALBASE}/lib/libgoto.so)
+.if exists(${LOCALBASE}/lib/libgoto2.so)
USE_BLAS= gotoblas
.elif exists(${LOCALBASE}/lib/libatlas_r.so)
USE_BLAS= atlas
@@ -56,10 +56,9 @@ LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
BLAS= -lblas
LAPACK= -llapack
.elif ${USE_BLAS} == gotoblas
-LIB_DEPENDS+= goto:${PORTSDIR}/math/gotoblas
-LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
-BLAS= -lgotop
-LAPACK= -lgotop -llapack
+LIB_DEPENDS+= goto2:${PORTSDIR}/math/gotoblas
+BLAS= -lgoto2p
+LAPACK= -lgoto2p
.elif ${USE_BLAS} == atlas
LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
BLAS= -lptf77blas -lptcblas -latlas_r