aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-cgi/Makefile
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2012-11-20 22:57:13 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2012-11-20 22:57:13 +0000
commit2d5fd949f7afbfc657d942cebb1b8d61515cefeb (patch)
tree21dd204906da63495d25f5201dbf180bebd44ef8 /math/octave-forge-cgi/Makefile
parent2200d5fd0caf9b7c0e15154d312070581a4c492d (diff)
downloadports-2d5fd949f7afbfc657d942cebb1b8d61515cefeb.tar.gz
ports-2d5fd949f7afbfc657d942cebb1b8d61515cefeb.zip
Notes
Diffstat (limited to 'math/octave-forge-cgi/Makefile')
-rw-r--r--math/octave-forge-cgi/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/math/octave-forge-cgi/Makefile b/math/octave-forge-cgi/Makefile
new file mode 100644
index 000000000000..86f2df92a90a
--- /dev/null
+++ b/math/octave-forge-cgi/Makefile
@@ -0,0 +1,26 @@
+# Created by: Stephen Montgomery-Smith <stephen@FreeBSd.org>
+# $FreeBSD$
+
+PORTNAME= octave-forge-cgi
+PORTVERSION= 0.1.0
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${OCTAVE_PKGNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.octave.mk"
+do-build:
+ @${DO_NADA}
+
+post-build:
+ ${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.post.mk>