aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-dicom
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2012-01-02 17:06:34 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2012-01-02 17:06:34 +0000
commitd7c399420e61f63810a5f64ff3f0b33219440784 (patch)
treedfa61cbf9f3f37cb5577234c9ac94ae9d7825bec /math/octave-forge-dicom
parent1fc02cd6ad272ef5f69d2aca52d42d404ff17b0e (diff)
downloadports-d7c399420e61f63810a5f64ff3f0b33219440784.tar.gz
ports-d7c399420e61f63810a5f64ff3f0b33219440784.zip
Notes
Diffstat (limited to 'math/octave-forge-dicom')
-rw-r--r--math/octave-forge-dicom/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/math/octave-forge-dicom/Makefile b/math/octave-forge-dicom/Makefile
index f6de4d152b56..736b4b61d0d3 100644
--- a/math/octave-forge-dicom/Makefile
+++ b/math/octave-forge-dicom/Makefile
@@ -7,14 +7,13 @@
PORTNAME= octave-forge-dicom
PORTVERSION= 0.1.1
+PORTREVISION= 1
CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
-#LIB_DEPENDS+= gdcmCommon:${PORTSDIR}/devel/gdcm
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libgdcmCommon.so:${PORTSDIR}/devel/gdcm
-RUN_DEPENDS+= ${LOCALBASE}/lib/libgdcmCommon.so:${PORTSDIR}/devel/gdcm
+LIB_DEPENDS+= gdcmCommon:${PORTSDIR}/devel/gdcm
# OCTSRC is the name of the directory of the package.
# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
@@ -22,6 +21,13 @@ OCTSRC= ${OCTAVE_PKGNAME}
WRKSRC= ${WRKDIR}/${OCTSRC}/src
+GDCM_MAJ= 2.2
+post-patch:
+ ${REINPLACE_CMD} s/gdcm-2.0/gdcm-${GDCM_MAJ}/ \
+ ${WRKSRC}/dicominfo.cpp ${WRKSRC}/dicomdict.cpp \
+ ${WRKSRC}/dicomread.cpp ${WRKSRC}/dicomlookup.cpp \
+ ${WRKSRC}/_gendicomdict.cpp ${WRKSRC}/dicomwrite.cpp
+
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/Mk/bsd.octave.mk"