aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-gsl
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2021-02-21 22:41:34 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2021-02-21 22:41:34 +0000
commit6473aac25b6dc63be299faa4fc1ed9cde77f1957 (patch)
tree5f81e978342b34ec7b1784c80dc5be7182d55dcf /math/octave-forge-gsl
parente906f6434c9ac6119ad6536e7f73592e5d69d557 (diff)
downloadports-6473aac25b6dc63be299faa4fc1ed9cde77f1957.tar.gz
ports-6473aac25b6dc63be299faa4fc1ed9cde77f1957.zip
Notes
Diffstat (limited to 'math/octave-forge-gsl')
-rw-r--r--math/octave-forge-gsl/Makefile2
-rw-r--r--math/octave-forge-gsl/files/patch-gsl__sf.cc26
2 files changed, 27 insertions, 1 deletions
diff --git a/math/octave-forge-gsl/Makefile b/math/octave-forge-gsl/Makefile
index 7078bebad156..2c85f662d46e 100644
--- a/math/octave-forge-gsl/Makefile
+++ b/math/octave-forge-gsl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= octave-forge-gsl
PORTVERSION= 2.1.1
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
diff --git a/math/octave-forge-gsl/files/patch-gsl__sf.cc b/math/octave-forge-gsl/files/patch-gsl__sf.cc
new file mode 100644
index 000000000000..4849f194f6cd
--- /dev/null
+++ b/math/octave-forge-gsl/files/patch-gsl__sf.cc
@@ -0,0 +1,26 @@
+--- gsl_sf.cc.orig 2021-02-21 21:41:43 UTC
++++ gsl_sf.cc
+@@ -26,11 +26,7 @@
+ #include <gsl/gsl_errno.h>
+ #include <gsl/gsl_version.h>
+
+-#ifdef OCTAVE_HAS_OV_ISREAL_METHOD
+ #define ISREAL(x) ((x).isreal ())
+-#else
+-#define ISREAL(x) ((x).is_real_type ())
+-#endif
+
+ void octave_gsl_errorhandler (const char * reason, const char * file,
+ int line, int gsl_errno)
+@@ -47,11 +43,7 @@ special functions of the GNU Scientific Library (GSL).
+ \n\
+ @end deftypefn\n")
+ {
+-#ifdef OCTAVE_HAS_FEVAL_IN_OCTAVE_NAMESPACE
+ octave::feval ("help", octave_value ("gsl_sf"));
+-#else
+- feval ("help", octave_value ("gsl_sf"));
+-#endif
+
+ return octave_value();
+ }