aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-linear-algebra/Makefile
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2011-11-21 01:17:40 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2011-11-21 01:17:40 +0000
commitdf56e1f431553fe11f5a8e45d94d71e5bc584ad4 (patch)
treea49ff5cb6b00ab4e248704a358294b0151f9ee4f /math/octave-forge-linear-algebra/Makefile
parentd9b2767be3eb8223e3bebb0529ddd1d8771bba4a (diff)
downloadports-df56e1f431553fe11f5a8e45d94d71e5bc584ad4.tar.gz
ports-df56e1f431553fe11f5a8e45d94d71e5bc584ad4.zip
Notes
Diffstat (limited to 'math/octave-forge-linear-algebra/Makefile')
-rw-r--r--math/octave-forge-linear-algebra/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/math/octave-forge-linear-algebra/Makefile b/math/octave-forge-linear-algebra/Makefile
index ec1f0f8e6118..fc269c1ea1aa 100644
--- a/math/octave-forge-linear-algebra/Makefile
+++ b/math/octave-forge-linear-algebra/Makefile
@@ -12,12 +12,16 @@ CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
-WRKSRC= ${WRKDIR}/${OCTAVE_PKGNAME}/src
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${OCTAVE_PKGNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/Mk/bsd.octave.mk"
post-build:
${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
- cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTAVE_PKGNAME}
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
.include <bsd.port.post.mk>