aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-mvn
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2014-01-01 04:00:22 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2014-01-01 04:00:22 +0000
commitd6543984ffd0763da57ae9e49a65d1c17cbb1a04 (patch)
tree52887d674a86c1a187b1a0d377f36e419ac5e94b /math/octave-forge-mvn
parentd3a4959a30ea5332e22b94c842938e8be6794068 (diff)
downloadports-d6543984ffd0763da57ae9e49a65d1c17cbb1a04.tar.gz
ports-d6543984ffd0763da57ae9e49a65d1c17cbb1a04.zip
Notes
Diffstat (limited to 'math/octave-forge-mvn')
-rw-r--r--math/octave-forge-mvn/Makefile25
-rw-r--r--math/octave-forge-mvn/distinfo2
-rw-r--r--math/octave-forge-mvn/pkg-descr10
-rw-r--r--math/octave-forge-mvn/pkg-plist1
4 files changed, 38 insertions, 0 deletions
diff --git a/math/octave-forge-mvn/Makefile b/math/octave-forge-mvn/Makefile
new file mode 100644
index 000000000000..1b10bf0485b4
--- /dev/null
+++ b/math/octave-forge-mvn/Makefile
@@ -0,0 +1,25 @@
+# Created by: Stephen Montgomery-Smith <stephen@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= octave-forge-mvn
+PORTVERSION= 1.1.0
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${OCTAVE_PKGNAME}
+
+NO_STAGE= yes
+.include "${.CURDIR}/../../Mk/bsd.octave.mk"
+
+do-build:
+ @${DO_NADA}
+
+post-build:
+ ${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.mk>
diff --git a/math/octave-forge-mvn/distinfo b/math/octave-forge-mvn/distinfo
new file mode 100644
index 000000000000..a6a76be1bdd8
--- /dev/null
+++ b/math/octave-forge-mvn/distinfo
@@ -0,0 +1,2 @@
+SHA256 (octave-forge/mvn-1.1.0.tar.gz) = af5a16b91cb6b83ef05ba62321fc1b8a90c8fe7ee79a4fc819b5618b3b4c8603
+SIZE (octave-forge/mvn-1.1.0.tar.gz) = 20623
diff --git a/math/octave-forge-mvn/pkg-descr b/math/octave-forge-mvn/pkg-descr
new file mode 100644
index 000000000000..91a5e1f928ef
--- /dev/null
+++ b/math/octave-forge-mvn/pkg-descr
@@ -0,0 +1,10 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is mvn.
+
+ Multivariate normal distribution clustering and utility functions.
+
+WWW: http://octave.sourceforge.net/
diff --git a/math/octave-forge-mvn/pkg-plist b/math/octave-forge-mvn/pkg-plist
new file mode 100644
index 000000000000..a999ec86c07e
--- /dev/null
+++ b/math/octave-forge-mvn/pkg-plist
@@ -0,0 +1 @@
+@comment This file intentionally left empty