aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-ncarray
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2012-07-20 23:29:42 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2012-07-20 23:29:42 +0000
commitb5c1778defef04eb3cf0043007d04c1170a1c6ad (patch)
tree2a690e1c76896c51668cea968ef263d5d8218234 /math/octave-forge-ncarray
parent65709a17d1534374225e99ed8a6d2ac66c282ada (diff)
downloadports-b5c1778defef04eb3cf0043007d04c1170a1c6ad.tar.gz
ports-b5c1778defef04eb3cf0043007d04c1170a1c6ad.zip
Notes
Diffstat (limited to 'math/octave-forge-ncarray')
-rw-r--r--math/octave-forge-ncarray/Makefile32
-rw-r--r--math/octave-forge-ncarray/distinfo2
-rw-r--r--math/octave-forge-ncarray/pkg-descr10
-rw-r--r--math/octave-forge-ncarray/pkg-plist1
4 files changed, 45 insertions, 0 deletions
diff --git a/math/octave-forge-ncarray/Makefile b/math/octave-forge-ncarray/Makefile
new file mode 100644
index 000000000000..e8d7f28ed307
--- /dev/null
+++ b/math/octave-forge-ncarray/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: octave-forge-ncarray
+# Date created: 20 July 2012
+# Whom: Stephen Montgomery-Smith <stephen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= octave-forge-ncarray
+PORTVERSION= 1.0.0
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ncArray
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
+
+RUN_DEPENDS+= ${TARBALLS_DIR}/octcdf.tar.gz:${PORTSDIR}/math/octave-forge-octcdf
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.octave.mk"
+do-build:
+ @${DO_NADA}
+
+post-build:
+ ${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.post.mk>
diff --git a/math/octave-forge-ncarray/distinfo b/math/octave-forge-ncarray/distinfo
new file mode 100644
index 000000000000..b2079698f48f
--- /dev/null
+++ b/math/octave-forge-ncarray/distinfo
@@ -0,0 +1,2 @@
+SHA256 (octave-forge/ncarray-1.0.0.tar.gz) = deef2a9de5f087c8cae84e84da10dc42e7336f2a18a97d1ba337b98e678bed20
+SIZE (octave-forge/ncarray-1.0.0.tar.gz) = 18379
diff --git a/math/octave-forge-ncarray/pkg-descr b/math/octave-forge-ncarray/pkg-descr
new file mode 100644
index 000000000000..76280ee10fa6
--- /dev/null
+++ b/math/octave-forge-ncarray/pkg-descr
@@ -0,0 +1,10 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is ncarray.
+
+ Access a single or a collection of NetCDF files as a multi-dimensional array.
+
+WWW: http://octave.sourceforge.net/
diff --git a/math/octave-forge-ncarray/pkg-plist b/math/octave-forge-ncarray/pkg-plist
new file mode 100644
index 000000000000..a999ec86c07e
--- /dev/null
+++ b/math/octave-forge-ncarray/pkg-plist
@@ -0,0 +1 @@
+@comment This file intentionally left empty