aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-octclip/Makefile
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2011-06-21 01:46:10 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2011-06-21 01:46:10 +0000
commit3895d16357c5b27f246cfaaa1b5b6876139a10ca (patch)
treec22df829f1dc9423d76ef71fa206d5a990c395ec /math/octave-forge-octclip/Makefile
parent0e9d2323d30eba26221a91443964dd7f3ff55375 (diff)
Notes
Diffstat (limited to 'math/octave-forge-octclip/Makefile')
-rw-r--r--math/octave-forge-octclip/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/math/octave-forge-octclip/Makefile b/math/octave-forge-octclip/Makefile
new file mode 100644
index 000000000000..bdd116d98a83
--- /dev/null
+++ b/math/octave-forge-octclip/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: octave-forge-octclip
+# Date created: 13 Janurary 2011
+# Whom: Stephen Montgomery-Smith <stephen@math.missouri.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= octave-forge-octclip
+PORTVERSION= 1.0.0
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+WRKSRC= ${WRKDIR}/${OCTAVE_PKGNAME}/src
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.octave.mk"
+post-extract:
+ ${REINPLACE_CMD} s/CC/MKOCTFILE/ ${WRKSRC}/Makefile
+
+post-build:
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTAVE_PKGNAME}
+
+.include <bsd.port.post.mk>