aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-secs1d/Makefile
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2012-04-11 05:06:46 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2012-04-11 05:06:46 +0000
commitc5cc886aa8a941e5507fd3372bcc7f8bf1a0dd67 (patch)
tree33f48d3ade457cf65315b841a31c61c7106fb241 /math/octave-forge-secs1d/Makefile
parent0d42a204ccf82a52136204bfba44dd2db8ad2ff4 (diff)
Notes
Diffstat (limited to 'math/octave-forge-secs1d/Makefile')
-rw-r--r--math/octave-forge-secs1d/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/math/octave-forge-secs1d/Makefile b/math/octave-forge-secs1d/Makefile
index 0e3481a8b484..c4217affb437 100644
--- a/math/octave-forge-secs1d/Makefile
+++ b/math/octave-forge-secs1d/Makefile
@@ -6,14 +6,25 @@
#
PORTNAME= octave-forge-secs1d
-PORTVERSION= 0.0.8
-PORTREVISION= 6
+PORTVERSION= 0.0.9
CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
-GNU_CONFIGURE= yes
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${DISTNAME}
+
+RUN_DEPENDS+= ${TARBALLS_DIR}/bim.tar.gz:${PORTSDIR}/math/octave-forge-bim
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/Mk/bsd.octave.mk"
+do-build:
+ @${DO_NADA}
+
+post-build:
+ ${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
.include <bsd.port.post.mk>