aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-xraylib/Makefile
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2008-09-08 06:42:27 +0000
committerMaho Nakata <maho@FreeBSD.org>2008-09-08 06:42:27 +0000
commite10e305cb9d11a405b82df1128ec342a019db654 (patch)
tree08c1370a7a5ee97a171e9676ee89720c78057e78 /math/octave-forge-xraylib/Makefile
parent5bae94b40b88f0a795f767fa6587e07595ff2b92 (diff)
downloadports-e10e305cb9d11a405b82df1128ec342a019db654.tar.gz
ports-e10e305cb9d11a405b82df1128ec342a019db654.zip
Notes
Diffstat (limited to 'math/octave-forge-xraylib/Makefile')
-rw-r--r--math/octave-forge-xraylib/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/math/octave-forge-xraylib/Makefile b/math/octave-forge-xraylib/Makefile
new file mode 100644
index 000000000000..209121b0746d
--- /dev/null
+++ b/math/octave-forge-xraylib/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: octave-forge
+# Date created: 5 May 2004
+# Whom: Stephen Montgomery-Smith <stephen@math.missouri.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= octave-forge-xraylib
+PORTVERSION= 1.0.7
+CATEGORIES= math
+
+MAINTAINER= stephen@math.missouri.edu
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+post-patch:
+ @${REINPLACE_CMD} s+/bin/bash+/usr/local/bin/bash+g ${WRKSRC}/src/xraylib/src/*.sh
+ @${REINPLACE_CMD} s+/bin/bash+/usr/local/bin/bash+g ${WRKSRC}/src/xraylib/src/Makefile
+ @${REINPLACE_CMD} s+/bin/bash+/usr/local/bin/bash+g ${WRKSRC}/src/xraylib/bin/xraylib
+ @${REINPLACE_CMD} s+/bin/bash+/usr/local/bin/bash+g ${WRKSRC}/src/xraylib/*.sh
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.octave.mk"
+.include <bsd.port.post.mk>